aboutsummaryrefslogtreecommitdiff
path: root/editors/vile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2007-05-29 16:55:40 +0000
committerGary Jennejohn <gj@FreeBSD.org>2007-05-29 16:55:40 +0000
commit43d7545b843b8577c5f1df32c2499c5a09ada55a (patch)
treee4c1b8970874196013941011c4b2c5a30088d352 /editors/vile
parent58ea5067de36c5f73eb285ff1dd766471bda6159 (diff)
downloadports-43d7545b843b8577c5f1df32c2499c5a09ada55a.tar.gz
ports-43d7545b843b8577c5f1df32c2499c5a09ada55a.zip
Notes
Diffstat (limited to 'editors/vile')
-rw-r--r--editors/vile/Makefile23
-rw-r--r--editors/vile/distinfo9
-rw-r--r--editors/vile/files/patch-configure10
-rw-r--r--editors/vile/files/patch-configure.in10
-rw-r--r--editors/vile/pkg-plist2
-rw-r--r--editors/vile/pkg-plist.filt2
-rw-r--r--editors/vile/pkg-plist.perl2
-rw-r--r--editors/vile/pkg-plist.perl+filt2
8 files changed, 50 insertions, 10 deletions
diff --git a/editors/vile/Makefile b/editors/vile/Makefile
index adb7ad4e25a7..0375ba8b23ca 100644
--- a/editors/vile/Makefile
+++ b/editors/vile/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vile
-PORTVERSION= 9.5n
+PORTVERSION= 9.5q
CATEGORIES= editors
MASTER_SITES= ftp://dickey.his.com/vile/ \
ftp://invisible-island.net/vile/ \
@@ -28,24 +28,27 @@ PATCHFILES= vile-9.5a.patch.gz \
vile-9.5k.patch.gz \
vile-9.5l.patch.gz \
vile-9.5m.patch.gz \
- vile-9.5n.patch.gz
+ vile-9.5n.patch.gz \
+ vile-9.5o.patch.gz \
+ vile-9.5p.patch.gz \
+ vile-9.5q.patch.gz
MAINTAINER= gj@FreeBSD.org
COMMENT= VI Like Emacs. a vi "workalike", with many additional features
MAKEFILE= makefile
GNU_CONFIGURE= yes
-USE_PERL5= yes
MAN1= vile.1
-.if defined(WITH_ALL)
-WITH_FILTERS=1
-WITH_PERL=1
-.endif
+OPTIONS= FILTERS "Add support for loadable filters" OFF
+OPTIONS+= PERL "Add support for perl functions" OFF
+
+.include <bsd.port.pre.mk>
.if defined(WITH_PERL)
CONFIGURE_ARGS+= --with-perl
PLIST= ${PKGDIR}/pkg-plist.perl
+USE_PERL5= yes
.endif
.if defined(WITH_FILTERS)
@@ -59,11 +62,11 @@ PLIST= ${PKGDIR}/pkg-plist.perl+filt
pre-configure:
.if ! defined(WITH_PERL)
- @${ECHO_MSG} "Define WITH_PERL if you want to make a vile which includes"
+ @${ECHO_MSG} "Choose the option PERL if you want to make a vile which includes"
@${ECHO_MSG} "PERL functionality"
.endif
.if ! defined(WITH_FILTERS)
- @${ECHO_MSG} "Define WITH_FILTERS if you want to make a vile which will"
+ @${ECHO_MSG} "Choose the option FILTERS if you want to make a vile which will"
@${ECHO_MSG} "dynamically load filters as needed."
.endif
@@ -78,4 +81,4 @@ post-install:
@${ECHO_MSG} "Look in ${PREFIX}/share/doc/vile for documentation."
@${ECHO_MSG} "Look in ${PREFIX}/share/vile/macros for macros."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/vile/distinfo b/editors/vile/distinfo
index 0ccdffdfb642..78eb092d007f 100644
--- a/editors/vile/distinfo
+++ b/editors/vile/distinfo
@@ -43,3 +43,12 @@ SIZE (vile-9.5m.patch.gz) = 68864
MD5 (vile-9.5n.patch.gz) = d7d444b409d5f2efd4b3dbaffef4bf9e
SHA256 (vile-9.5n.patch.gz) = a03acbe00e51f68532c5d026caab69a54a7714293bad22accbbe4ccff29b33a0
SIZE (vile-9.5n.patch.gz) = 72458
+MD5 (vile-9.5o.patch.gz) = 786b1319cdfe8e0a145244b752c6b112
+SHA256 (vile-9.5o.patch.gz) = 465488824fcfd032534b71210ca070dff8336e583a7c0265326faed6ec0679c7
+SIZE (vile-9.5o.patch.gz) = 18113
+MD5 (vile-9.5p.patch.gz) = 37dcbe4840272a1ad7931ae8f3f8cbbf
+SHA256 (vile-9.5p.patch.gz) = 6b87da2e14ab1855349df7eb14725c5b04148153cd7f6e94b142ccd58135b0a1
+SIZE (vile-9.5p.patch.gz) = 10993
+MD5 (vile-9.5q.patch.gz) = 901827470a6b81a86b52877a4b6de4c1
+SHA256 (vile-9.5q.patch.gz) = d05f28c92a1d872f7838c107c6ed1f7675cc9eafc652e9d4e454fb06e16f855f
+SIZE (vile-9.5q.patch.gz) = 107182
diff --git a/editors/vile/files/patch-configure b/editors/vile/files/patch-configure
new file mode 100644
index 000000000000..bcff30304460
--- /dev/null
+++ b/editors/vile/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue May 29 13:09:09 2007
++++ configure Tue May 29 13:09:23 2007
+@@ -4930,7 +4930,6 @@
+ memory.h \
+ poll.h \
+ pwd.h \
+-search.h \
+ select.h \
+ setjmp.h \
+ sgtty.h \
diff --git a/editors/vile/files/patch-configure.in b/editors/vile/files/patch-configure.in
new file mode 100644
index 000000000000..6a9dcbdbee10
--- /dev/null
+++ b/editors/vile/files/patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig Tue May 29 13:09:51 2007
++++ configure.in Tue May 29 13:09:57 2007
+@@ -335,7 +335,6 @@
+ memory.h \
+ poll.h \
+ pwd.h \
+-search.h \
+ select.h \
+ setjmp.h \
+ sgtty.h \
diff --git a/editors/vile/pkg-plist b/editors/vile/pkg-plist
index adc2e35fc2c5..b1de03275177 100644
--- a/editors/vile/pkg-plist
+++ b/editors/vile/pkg-plist
@@ -53,6 +53,7 @@ lib/vile/vile-rc-filt
lib/vile/vile-rcs-filt
lib/vile/vile-rexx-filt
lib/vile/vile-rpm-filt
+lib/vile/vile-rtf-filt
lib/vile/vile-ruby-filt
lib/vile/vile-sccs-filt
lib/vile/vile-sed-filt
@@ -162,6 +163,7 @@ share/vile/rc.keywords
share/vile/rcs.keywords
share/vile/rexx.keywords
share/vile/rpm.keywords
+share/vile/rtf.keywords
share/vile/sccs.keywords
share/vile/search.rc
share/vile/sh.keywords
diff --git a/editors/vile/pkg-plist.filt b/editors/vile/pkg-plist.filt
index 4f580406f859..e3fce5e01fa0 100644
--- a/editors/vile/pkg-plist.filt
+++ b/editors/vile/pkg-plist.filt
@@ -53,6 +53,7 @@ lib/vile/vile-rc-filt.so
lib/vile/vile-rcs-filt.so
lib/vile/vile-rexx-filt.so
lib/vile/vile-rpm-filt.so
+lib/vile/vile-rtf-filt.so
lib/vile/vile-ruby-filt.so
lib/vile/vile-sccs-filt.so
lib/vile/vile-sed-filt.so
@@ -162,6 +163,7 @@ share/vile/rc.keywords
share/vile/rcs.keywords
share/vile/rexx.keywords
share/vile/rpm.keywords
+share/vile/rtf.keywords
share/vile/sccs.keywords
share/vile/search.rc
share/vile/sh.keywords
diff --git a/editors/vile/pkg-plist.perl b/editors/vile/pkg-plist.perl
index c6e1b97194fd..f650cd01b196 100644
--- a/editors/vile/pkg-plist.perl
+++ b/editors/vile/pkg-plist.perl
@@ -54,6 +54,7 @@ lib/vile/vile-rc-filt
lib/vile/vile-rcs-filt
lib/vile/vile-rexx-filt
lib/vile/vile-rpm-filt
+lib/vile/vile-rtf-filt
lib/vile/vile-ruby-filt
lib/vile/vile-sccs-filt
lib/vile/vile-sed-filt
@@ -186,6 +187,7 @@ share/vile/rc.keywords
share/vile/rcs.keywords
share/vile/rexx.keywords
share/vile/rpm.keywords
+share/vile/rtf.keywords
share/vile/sccs.keywords
share/vile/search.rc
share/vile/sh.keywords
diff --git a/editors/vile/pkg-plist.perl+filt b/editors/vile/pkg-plist.perl+filt
index 69421be435d4..5126a32b341b 100644
--- a/editors/vile/pkg-plist.perl+filt
+++ b/editors/vile/pkg-plist.perl+filt
@@ -54,6 +54,7 @@ lib/vile/vile-rc-filt.so
lib/vile/vile-rcs-filt.so
lib/vile/vile-rexx-filt.so
lib/vile/vile-rpm-filt.so
+lib/vile/vile-rtf-filt.so
lib/vile/vile-ruby-filt.so
lib/vile/vile-sccs-filt.so
lib/vile/vile-sed-filt.so
@@ -186,6 +187,7 @@ share/vile/rc.keywords
share/vile/rcs.keywords
share/vile/rexx.keywords
share/vile/rpm.keywords
+share/vile/rtf.keywords
share/vile/sccs.keywords
share/vile/search.rc
share/vile/sh.keywords