aboutsummaryrefslogtreecommitdiff
path: root/editors/vim-tiny
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2018-01-08 19:44:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2018-01-08 19:44:13 +0000
commit1c095d9d53d64e968cce23b84649d896e39c1161 (patch)
tree7e29ca1cd3d83b813e8da78483a5db651348c0d9 /editors/vim-tiny
parent34418aa70bdb705372eb21298f9adc4bb6fe56c3 (diff)
downloadports-1c095d9d53d64e968cce23b84649d896e39c1161.tar.gz
ports-1c095d9d53d64e968cce23b84649d896e39c1161.zip
Add editors/vim-tiny.
By popular request, this is a slave port that installs only the vim binary. It has no dependencies, produces a 1 MB package with a 3 MB installed footprint, and is unable to do anything except edit files. It contains no help files, no runtime files, no syntax highlighting, no filetype-specific indenting, non-US keymaps, macros, or spell-checking. vim-tiny is designed for minimal installs, and is the wrong choice for most users.
Notes
Notes: svn path=/head/; revision=458471
Diffstat (limited to 'editors/vim-tiny')
-rw-r--r--editors/vim-tiny/Makefile22
-rw-r--r--editors/vim-tiny/pkg-descr15
2 files changed, 37 insertions, 0 deletions
diff --git a/editors/vim-tiny/Makefile b/editors/vim-tiny/Makefile
new file mode 100644
index 000000000000..028e3344685f
--- /dev/null
+++ b/editors/vim-tiny/Makefile
@@ -0,0 +1,22 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -tiny
+
+COMMENT= Improved version of the vi editor (vim binary only)
+
+CONFLICTS_INSTALL= vim vim-lite
+
+TINY= yes
+MASTERDIR= ${.CURDIR}/../vim
+
+PORTDATA= # Not for -tiny
+PLIST= # Not for -tiny
+PLIST_FILES= bin/vim \
+ man/man1/vim.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/vim ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/runtime/doc/vim.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include "${MASTERDIR}/Makefile"
diff --git a/editors/vim-tiny/pkg-descr b/editors/vim-tiny/pkg-descr
new file mode 100644
index 000000000000..628f3c059f7e
--- /dev/null
+++ b/editors/vim-tiny/pkg-descr
@@ -0,0 +1,15 @@
+Vim is a highly configurable text editor built to enable efficient text editing.
+It is an improved version of the vi editor distributed with most UNIX systems.
+
+Vim is often called a "programmer's editor," and so useful for programming that
+many consider it an entire IDE. It's not just for programmers, though. Vim is
+perfect for all kinds of text editing, from composing email to editing
+configuration files.
+
+This is the "tiny" version, which is console-only and contains ONLY the vim
+binary. It contains no help files, syntax files, or any other runtime files,
+and is designed only for minimal installs. You almost always want the vim
+or vim-lite package instead.
+
+WWW: http://www.vim.org/
+WWW: https://github.com/vim/vim