aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-10 18:47:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-10 18:47:23 +0000
commit01544f6d9d457af725523175a4f9fefd2004e657 (patch)
treed5eec84dcadab1941e721e812c8b489eccbc0ad7 /editors/vim
parent881050b9ad6f12e5af763e23d0ce851aae7a636c (diff)
downloadports-01544f6d9d457af725523175a4f9fefd2004e657.tar.gz
ports-01544f6d9d457af725523175a4f9fefd2004e657.zip
Fix stage-qa of shebang with PYTHON option disabled after r522484
The error message (in poudriere) is as follows: ====> Running Q/A tests (stage-qa) Error: '/usr/local/bin/python' is an invalid shebang you need USES=shebangfix for 'share/vim/vim82/tools/demoserver.py.bak' r522484 adds a new REINPLACE_CMD check which is enabled when DEVELOPER=yes. It does not respect REINPLACE_ARGS (-i ''), thus runtime/tools/demoserver.py.bak is generated. Vim installs everything in runtime/tools [1] which fails in stage-qa for invalid shebang. This workaround uses USES=python:env. It will replace the shebang with default python (/usr/local/bin/python3.7). [1] from src/Makefile: # install the runtime tools $(INSTALL_DATA_R) $(TOOLSSOURCE)/* $(DEST_TOOLS) PR: 243961 Reported by: salvadore Submitted by: sunpoet (myself) Approved by: adamw (maintainer)
Notes
Notes: svn path=/head/; revision=525748
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 92c959645517..6d3bfa00c9ee 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -31,7 +31,6 @@ GNU_CONFIGURE= yes
PLIST_SUB= VIM_VER=${VIM_VER}
PORTDATA?= ${VIM_VER}
PORTSCOUT= ignore:1
-REINPLACE_ARGS= -i ''
SHEBANG_FILES= runtime/tools/demoserver.py runtime/tools/efm_perl.pl
VIM_VER= ${PORTNAME}${PORTVERSION:R:S|.||g}
@@ -134,6 +133,7 @@ PERL_CONFIGURE_ENABLE= perlinterp
PERL_USES= perl5
PYTHON_USES= python
+PYTHON_USES_OFF= python:env
RUBY_CONFIGURE_ENABLE= rubyinterp
RUBY_USE= RUBY=yes
@@ -167,8 +167,6 @@ post-patch:
${ECHO_CMD} '#define SYS_GVIMRC_FILE "'${ETCDIR}'/gvimrc"' >> ${WRKSRC}/src/feature.h
${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|g; s|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/src/auto/configure
-# Work around qa-check shebang error
- ${REINPLACE_CMD} -e 1d ${WRKSRC}/runtime/tools/demoserver.py
post-configure:
# Needed when devel/libsysinfo is installed: