aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2020-01-06 00:19:41 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2020-01-06 00:19:41 +0000
commit22278abb7ff8e8945abe114f9f8f302ca52c61e4 (patch)
treee43aaf14e2b698485f2a1962fe0a0457a4ca62b2 /editors/vim
parent50c7311c766e86ce5f3f19fbcc65b8a94323fc87 (diff)
downloadports-22278abb7ff8e8945abe114f9f8f302ca52c61e4.tar.gz
ports-22278abb7ff8e8945abe114f9f8f302ca52c61e4.zip
vim: Add a MAKE_JOBS option for concurrent build, default off
Most systems are able to build vim in parallel most of the time. The dependency chain in the Makefiles are a spaghetti mess and concurrency is broken with some frequency, so it just isn't feasible for it to be on by default. It does shave quite a bit of time off the build (and I have had .undef MAKE_JOBS_UNSAFE in Makefile.local for years), so now there's an option. It's off by default. PR: 243109 Reported by: glewis
Notes
Notes: svn path=/head/; revision=522175
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 4ef6ac25e3ff..3a1e7949611d 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -28,7 +28,6 @@ MAKE_ARGS= STRIP="${STRIP_CMD}" \
CPE_VERSION= ${PORTVERSION:R}
GNU_CONFIGURE= yes
-MAKE_JOBS_UNSAFE= yes
PLIST_SUB= VIM_VER=${VIM_VER}
PORTDATA?= ${VIM_VER}
PORTSCOUT= ignore:1
@@ -39,7 +38,7 @@ VIM_VER= ${PORTNAME}${PORTVERSION:R:S|.||g}
# OPTIONS
# ### Make sure any new options are excluded below in CONSOLE/TINY
OPTIONS_DEFAULT= CSCOPE DEFAULT_VIMRC CTAGS_EXUBERANT GTK3 PERL PYTHON3 RUBY
-OPTIONS_DEFINE= CSCOPE DEFAULT_VIMRC NLS XTERM_SAVE
+OPTIONS_DEFINE= CSCOPE DEFAULT_VIMRC MAKE_JOBS NLS XTERM_SAVE
OPTIONS_SINGLE= CTAGS UI
OPTIONS_SINGLE_CTAGS= CTAGS_BASE CTAGS_EXUBERANT CTAGS_UNIVERSAL
OPTIONS_SINGLE_UI= ATHENA CONSOLE GNOME GTK2 GTK3 MOTIF X11
@@ -49,14 +48,15 @@ OPTIONS_SUB= yes
.if defined(CONSOLE) || defined(TINY)
OPTIONS_SLAVE= CONSOLE
-# Exclude everything except the two options above
-OPTIONS_EXCLUDE:= ${OPTIONS_DEFINE:NDEFAULT_VIMRC} \
+# Exclude everything except CONSOLE, DEFAULT_VIMRC, MAKE_JOBS
+OPTIONS_EXCLUDE:= ${OPTIONS_DEFINE:NDEFAULT_VIMRC:NMAKE_JOBS} \
${OPTIONS_SINGLE_UI:NCONSOLE} \
${OPTIONS_GROUP_LANGBIND} \
${OPTIONS_SINGLE_CTAGS}
.endif
DEFAULT_VIMRC_DESC= Install bundled vimrc as default setting
+MAKE_JOBS_DESC= Enable parallel build
XTERM_SAVE_DESC= Restore xterm screen after exit
CTAGS_BASE_DESC= Use system ctags
@@ -81,6 +81,8 @@ CSCOPE_RUN_DEPENDS= cscope:devel/cscope
CTAGS_EXUBERANT_RUN_DEPENDS= exctags:devel/ctags
CTAGS_UNIVERSAL_RUN_DEPENDS= uctags:devel/universal-ctags
+MAKE_JOBS_VARS_OFF= MAKE_JOBS_UNSAFE=yes
+
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext