aboutsummaryrefslogtreecommitdiff
path: root/editors/vscode
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-02-19 07:37:01 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-02-19 07:37:01 +0000
commit1ed4039990527226f6b20257c078ebf62de48b32 (patch)
tree6e960e6539aaa88a51fc999e3ba5da6cb25b61b7 /editors/vscode
parent73586cd9854017428503c23061a5dd7ae3b40097 (diff)
downloadports-1ed4039990527226f6b20257c078ebf62de48b32.tar.gz
ports-1ed4039990527226f6b20257c078ebf62de48b32.zip
- Update to 1.42.1
- Add a wrapper script vscode -> code-oss Submitted by: maintainer (via Github) Closes: https://github.com/tagattie/FreeBSD-VSCode/issues/18
Notes
Notes: svn path=/head/; revision=526490
Diffstat (limited to 'editors/vscode')
-rw-r--r--editors/vscode/Makefile9
-rw-r--r--editors/vscode/distinfo22
-rw-r--r--editors/vscode/files/patch-build_lib_layersChecker.ts11
-rw-r--r--editors/vscode/files/patch-src_vs_workbench_api_browser_mainThreadTask.ts4
-rw-r--r--editors/vscode/files/patch-test_smoke_src_main.ts6
-rw-r--r--editors/vscode/files/wrapper.sh2
-rw-r--r--editors/vscode/pkg-plist72
7 files changed, 89 insertions, 37 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index 40710fb491b3..f9b6719629f0 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= vscode
-DISTVERSION= 1.41.1
+DISTVERSION= 1.42.1
CATEGORIES= editors
MASTER_SITES= https://nodejs.org/dist/v${NODE_VER}/:node_headers \
https://github.com/tagattie/FreeBSD-VSCode/releases/download/${DISTVERSION}/:yarn_cache
@@ -64,7 +64,7 @@ USES= desktop-file-utils gl gmake gnome jpeg pkgconfig \
USE_GITHUB= yes
GH_ACCOUNT= microsoft
-SOURCE_COMMIT_HASH= 26076a4de974ead31f97692a0d32f90d735645c0
+SOURCE_COMMIT_HASH= c47d83b293181d9be64f27ff093689e8e7aed054
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -75,6 +75,7 @@ USE_GNOME= atk cairo pango gdkpixbuf2 gtk30 libxml2 libxslt
USE_LDCONFIG= ${DATADIR}
+# See ${WRKSRC}/remote/.yarnrc for NODE_VER
NODE_VER= 12.4.0
SHEBANG_REGEX= ./(extensions|resources|scripts|src)/.*\.sh$$
@@ -84,6 +85,7 @@ DATADIR= ${PREFIX}/share/code-oss
TMPDIR= ${WRKDIR}
MAKE_ENV+= BUILD_SOURCEVERSION=${SOURCE_COMMIT_HASH} \
+ ELECTRON_SKIP_BINARY_DOWNLOAD=1 \
PUPPETEER_SKIP_CHROMIUM_DOWNLOAD=1 \
XDG_CACHE_HOME=${WRKDIR}/.cache
@@ -211,6 +213,7 @@ do-install:
${RM} -r ${STAGEDIR}${DATADIR}/node_headers
${RM} -r ${STAGEDIR}${DATADIR}/resources/completions
${RLN} ${STAGEDIR}${DATADIR}/bin/code-oss ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${FILESDIR}/wrapper.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
pre-test:
# setup electron dependency for unit tests
@@ -233,7 +236,7 @@ make-yarn-cache:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
yarn --frozen-lockfile --ignore-scripts
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- yarn postinstall --frozen-lockfile --ignore-scripts
+ yarn postinstall --frozen-lockfile
cd ${WRKDIR} && ${TAR} -czf \
yarn-offline-cache-${DISTVERSION}${EXTRACT_SUFX} yarn-offline-cache
diff --git a/editors/vscode/distinfo b/editors/vscode/distinfo
index 842ca0aa1bf9..2c532af6bde1 100644
--- a/editors/vscode/distinfo
+++ b/editors/vscode/distinfo
@@ -1,17 +1,9 @@
-TIMESTAMP = 1577171243
-SHA256 (vscode/node-v6.1.7-headers.tar.gz) = 3b6c9ed60fff7deded8d4dfdc246bf98958c991f36c43f927efe79cf7dcdaf99
-SIZE (vscode/node-v6.1.7-headers.tar.gz) = 193743
-SHA256 (vscode/electron-v6.1.7-linux-x64.zip) = 7fe94fc1edebe2f5645056a4300fc642c04155e55da8dd4ee058a0c0ef835ae8
-SIZE (vscode/electron-v6.1.7-linux-x64.zip) = 62394242
-SHA256 (vscode/ffmpeg-v6.1.7-linux-x64.zip) = b25bb9a685dfa5e2cd50e01a80a891d7ea9a27d90cd2bcdc172829251c4dc29a
-SIZE (vscode/ffmpeg-v6.1.7-linux-x64.zip) = 3908671
+TIMESTAMP = 1581742520
SHA256 (vscode/node-v12.4.0-headers.tar.gz) = 3a5bbb6ad1a5f3ba912981c13910d7c617bb8fa6b6ae2026d6aee2edcd590a45
SIZE (vscode/node-v12.4.0-headers.tar.gz) = 549161
-SHA256 (vscode/vscode-ripgrep-1.5.7.tgz) = 4a36021ab54964e7ec9c8a299129cc6a5776c56f6e9b6182698e96f6899c27da
-SIZE (vscode/vscode-ripgrep-1.5.7.tgz) = 5064
-SHA256 (vscode/yarn-offline-cache-1.41.1.tar.gz) = ca7b6d110dc199be532f0e2d7a41ed9b9300aad51078c84027d0d596fe5fb3c7
-SIZE (vscode/yarn-offline-cache-1.41.1.tar.gz) = 101417117
-SHA256 (vscode/vscode-marketplace-exts-1.41.1.tar.gz) = 5848b570de90424d717f00f4a992a468d11715d921586aeadd1861c67bb965aa
-SIZE (vscode/vscode-marketplace-exts-1.41.1.tar.gz) = 1603308
-SHA256 (vscode/microsoft-vscode-1.41.1_GH0.tar.gz) = 72e2ac445cc89feac606f73c263c35d97c3980e6a13059139cc82a383a2fceae
-SIZE (vscode/microsoft-vscode-1.41.1_GH0.tar.gz) = 9913231
+SHA256 (vscode/yarn-offline-cache-1.42.1.tar.gz) = 2053dd126a4c4235441f22b7b0ac16c4dd1747387ccbe7196f1d86c1bb37f9ae
+SIZE (vscode/yarn-offline-cache-1.42.1.tar.gz) = 118563800
+SHA256 (vscode/vscode-marketplace-exts-1.42.1.tar.gz) = ffefdf437361398d1cff4bbea0467c00b910fd7cdb2f2f690f421757782d8005
+SIZE (vscode/vscode-marketplace-exts-1.42.1.tar.gz) = 2553625
+SHA256 (vscode/microsoft-vscode-1.42.1_GH0.tar.gz) = f810fdf81f808700db53df977b56e7b638c22d53ea0e21b6a3be5ba7fbf4801b
+SIZE (vscode/microsoft-vscode-1.42.1_GH0.tar.gz) = 10013642
diff --git a/editors/vscode/files/patch-build_lib_layersChecker.ts b/editors/vscode/files/patch-build_lib_layersChecker.ts
new file mode 100644
index 000000000000..c41acf0a54ba
--- /dev/null
+++ b/editors/vscode/files/patch-build_lib_layersChecker.ts
@@ -0,0 +1,11 @@
+--- build/lib/layersChecker.ts.orig 2020-02-08 09:06:59 UTC
++++ build/lib/layersChecker.ts
+@@ -215,7 +215,7 @@ function checkFile(program: ts.Program, sourceFile: ts
+ function createProgram(tsconfigPath: string): ts.Program {
+ const tsConfig = ts.readConfigFile(tsconfigPath, ts.sys.readFile);
+
+- const configHostParser: ts.ParseConfigHost = { fileExists: existsSync, readDirectory: ts.sys.readDirectory, readFile: file => readFileSync(file, 'utf8'), useCaseSensitiveFileNames: process.platform === 'linux' };
++ const configHostParser: ts.ParseConfigHost = { fileExists: existsSync, readDirectory: ts.sys.readDirectory, readFile: file => readFileSync(file, 'utf8'), useCaseSensitiveFileNames: (process.platform === 'linux' || process.platform === 'freebsd') };
+ const tsConfigParsed = ts.parseJsonConfigFileContent(tsConfig.config, configHostParser, resolve(dirname(tsconfigPath)), { noEmit: true });
+
+ const compilerHost = ts.createCompilerHost(tsConfigParsed.options, true);
diff --git a/editors/vscode/files/patch-src_vs_workbench_api_browser_mainThreadTask.ts b/editors/vscode/files/patch-src_vs_workbench_api_browser_mainThreadTask.ts
index 1f7609e2f4fd..6dd9a093596d 100644
--- a/editors/vscode/files/patch-src_vs_workbench_api_browser_mainThreadTask.ts
+++ b/editors/vscode/files/patch-src_vs_workbench_api_browser_mainThreadTask.ts
@@ -1,6 +1,6 @@
---- src/vs/workbench/api/browser/mainThreadTask.ts.orig 2019-12-10 21:16:00 UTC
+--- src/vs/workbench/api/browser/mainThreadTask.ts.orig 2020-02-05 19:39:53 UTC
+++ src/vs/workbench/api/browser/mainThreadTask.ts
-@@ -588,7 +588,7 @@ export class MainThreadTask implements MainThreadTaskS
+@@ -592,7 +592,7 @@ export class MainThreadTask implements MainThreadTaskS
case 'darwin':
platform = Platform.Platform.Mac;
break;
diff --git a/editors/vscode/files/patch-test_smoke_src_main.ts b/editors/vscode/files/patch-test_smoke_src_main.ts
index 2d17bfb4efa2..a47b228dcf58 100644
--- a/editors/vscode/files/patch-test_smoke_src_main.ts
+++ b/editors/vscode/files/patch-test_smoke_src_main.ts
@@ -1,6 +1,6 @@
---- test/smoke/src/main.ts.orig 2019-12-10 21:16:00 UTC
+--- test/smoke/src/main.ts.orig 2020-02-05 19:39:53 UTC
+++ test/smoke/src/main.ts
-@@ -96,7 +96,7 @@ function getDevElectronPath(): string {
+@@ -95,7 +95,7 @@ function getDevElectronPath(): string {
switch (process.platform) {
case 'darwin':
return path.join(buildPath, 'electron', `${product.nameLong}.app`, 'Contents', 'MacOS', 'Electron');
@@ -9,7 +9,7 @@
return path.join(buildPath, 'electron', `${product.applicationName}`);
case 'win32':
return path.join(buildPath, 'electron', `${product.nameShort}.exe`);
-@@ -109,7 +109,7 @@ function getBuildElectronPath(root: string): string {
+@@ -108,7 +108,7 @@ function getBuildElectronPath(root: string): string {
switch (process.platform) {
case 'darwin':
return path.join(root, 'Contents', 'MacOS', 'Electron');
diff --git a/editors/vscode/files/wrapper.sh b/editors/vscode/files/wrapper.sh
new file mode 100644
index 000000000000..acbf08881487
--- /dev/null
+++ b/editors/vscode/files/wrapper.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec code-oss "$@"
diff --git a/editors/vscode/pkg-plist b/editors/vscode/pkg-plist
index 3347ca521eb0..92ea9c7c00a3 100644
--- a/editors/vscode/pkg-plist
+++ b/editors/vscode/pkg-plist
@@ -1,4 +1,5 @@
bin/code-oss
+bin/vscode
etc/bash_completion.d/code-oss
share/appdata/code-oss.appdata.xml
share/applications/code-oss-url-handler.desktop
@@ -279,6 +280,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/html-language-features/server/lib/cgmanifest.json
%%DATADIR%%/resources/app/extensions/html-language-features/server/lib/jquery.d.ts
%%DATADIR%%/resources/app/extensions/html-language-features/server/package.json
+%%DATADIR%%/resources/app/extensions/html/build/update-grammar.js
%%DATADIR%%/resources/app/extensions/html/language-configuration.json
%%DATADIR%%/resources/app/extensions/html/package.json
%%DATADIR%%/resources/app/extensions/html/package.nls.json
@@ -383,6 +385,43 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/merge-conflict/package.json
%%DATADIR%%/resources/app/extensions/merge-conflict/package.nls.json
%%DATADIR%%/resources/app/extensions/merge-conflict/resources/icons/merge-conflict.png
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/LICENSE.txt
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/README.md
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/package.json
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/package.nls.json
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/LICENSE
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/configure.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/connect.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/disconnect.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/node.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/open-file.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/page.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/pause.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/restart.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/resume.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/service-worker.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/stop.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/dark/worker.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/configure.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/connect.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/disconnect.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/node.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/open-file.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/page.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/pause.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/restart.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/resume.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/service-worker.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/stop.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/light/worker.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/logo.png
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/resources/logo.svg
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/src/bootloader.js
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/src/extension.js
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/src/hash.js
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/src/mappings.wasm
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/src/terminateProcess.sh
+%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-nightly/src/watchdog.js
%%DATADIR%%/resources/app/extensions/ms-vscode.node-debug/LICENSE.txt
%%DATADIR%%/resources/app/extensions/ms-vscode.node-debug/ThirdPartyNotices.txt
%%DATADIR%%/resources/app/extensions/ms-vscode.node-debug/dist/debugInjection.js
@@ -781,6 +820,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/ms-vscode.references-view/media/icon.png
%%DATADIR%%/resources/app/extensions/ms-vscode.references-view/package.json
%%DATADIR%%/resources/app/extensions/ms-vscode.references-view/vscode.d.ts
+%%DATADIR%%/resources/app/extensions/ms-vscode.references-view/vscode.proposed.d.ts
%%DATADIR%%/resources/app/extensions/ms-vscode.references-view/webpack.config.js
%%DATADIR%%/resources/app/extensions/node_modules/typescript/AUTHORS.md
%%DATADIR%%/resources/app/extensions/node_modules/typescript/CODE_OF_CONDUCT.md
@@ -1033,6 +1073,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/search-result/src/media/refresh-dark.svg
%%DATADIR%%/resources/app/extensions/search-result/src/media/refresh-light.svg
%%DATADIR%%/resources/app/extensions/search-result/src/typings/refs.d.ts
+%%DATADIR%%/resources/app/extensions/search-result/syntaxes/generateTMLanguage.js
%%DATADIR%%/resources/app/extensions/search-result/syntaxes/searchResult.tmLanguage.json
%%DATADIR%%/resources/app/extensions/search-result/tsconfig.json
%%DATADIR%%/resources/app/extensions/search-result/yarn.lock
@@ -1121,6 +1162,14 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/typescript-language-features/dist/nls.metadata.json
%%DATADIR%%/resources/app/extensions/typescript-language-features/icon.png
%%DATADIR%%/resources/app/extensions/typescript-language-features/language-configuration.json
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/LICENSE.txt
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/README.md
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/lib/constants.d.ts
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/lib/constants.js
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/lib/index.d.ts
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/lib/index.js
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/package.json
+%%DATADIR%%/resources/app/extensions/typescript-language-features/node_modules/typescript-vscode-sh-plugin/yarn.lock
%%DATADIR%%/resources/app/extensions/typescript-language-features/package.json
%%DATADIR%%/resources/app/extensions/typescript-language-features/package.nls.json
%%DATADIR%%/resources/app/extensions/typescript-language-features/schemas/jsconfig.schema.json
@@ -1131,6 +1180,12 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/vb/package.nls.json
%%DATADIR%%/resources/app/extensions/vb/snippets/vb.json
%%DATADIR%%/resources/app/extensions/vb/syntaxes/asp-vb-net.tmlanguage.json
+%%DATADIR%%/resources/app/extensions/vscode-account/dist/extension.js
+%%DATADIR%%/resources/app/extensions/vscode-account/extension.webpack.config.js
+%%DATADIR%%/resources/app/extensions/vscode-account/media/auth.css
+%%DATADIR%%/resources/app/extensions/vscode-account/media/auth.html
+%%DATADIR%%/resources/app/extensions/vscode-account/package.json
+%%DATADIR%%/resources/app/extensions/vscode-account/yarn.lock
%%DATADIR%%/resources/app/extensions/xml/package.json
%%DATADIR%%/resources/app/extensions/xml/package.nls.json
%%DATADIR%%/resources/app/extensions/xml/syntaxes/xml.tmLanguage.json
@@ -1168,6 +1223,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/base/browser/ui/codiconLabel/codicon/codicon-animations.css
%%DATADIR%%/resources/app/out/vs/base/browser/ui/codiconLabel/codicon/codicon.css
%%DATADIR%%/resources/app/out/vs/base/browser/ui/codiconLabel/codicon/codicon.ttf
+%%DATADIR%%/resources/app/out/vs/base/browser/ui/menu/menu.svg
%%DATADIR%%/resources/app/out/vs/base/browser/ui/tree/media/loading-dark.svg
%%DATADIR%%/resources/app/out/vs/base/browser/ui/tree/media/loading-hc.svg
%%DATADIR%%/resources/app/out/vs/base/browser/ui/tree/media/loading.svg
@@ -1222,10 +1278,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/editor/contrib/find/images/replace-light.svg
%%DATADIR%%/resources/app/out/vs/editor/standalone/browser/iPadShowKeyboard/keyboard-dark.svg
%%DATADIR%%/resources/app/out/vs/editor/standalone/browser/iPadShowKeyboard/keyboard-light.svg
-%%DATADIR%%/resources/app/out/vs/editor/standalone/browser/quickOpen/symbol-sprite.svg
%%DATADIR%%/resources/app/out/vs/loader.js
-%%DATADIR%%/resources/app/out/vs/platform/auth/common/auth.css
-%%DATADIR%%/resources/app/out/vs/platform/auth/common/auth.html
%%DATADIR%%/resources/app/out/vs/platform/driver/node/driver.js
%%DATADIR%%/resources/app/out/vs/platform/extensionManagement/common/media/defaultIcon.png
%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/nsfw/watcherApp.js
@@ -1241,14 +1294,6 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/editor/media/letterpress-dark.svg
%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/editor/media/letterpress-hc.svg
%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/editor/media/letterpress.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-close-dark.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-close.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-maximize-dark.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-maximize.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-minimize-dark.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-minimize.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-restore-dark.svg
-%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/titlebar/media/chrome-restore.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/callHierarchy/browser/media/action-call-from-dark.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/callHierarchy/browser/media/action-call-from.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/debug/browser/media/continue-tb.png
@@ -1269,10 +1314,9 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/workbench/contrib/output/common/outputLinkComputer.js
%%DATADIR%%/resources/app/out/vs/workbench/contrib/preferences/browser/media/preferences-editor-dark.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/preferences/browser/media/preferences-editor-light.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/terminal/browser/media/configure-dark.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/terminal/browser/media/configure-hc.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/terminal/browser/media/configure-light.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/update/browser/media/code-icon.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/userDataSync/browser/media/check-dark.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/userDataSync/browser/media/check-light.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/fake.html
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/host.js
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/index.html