aboutsummaryrefslogtreecommitdiff
path: root/editors/vscode
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2020-08-11 02:18:32 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2020-08-11 02:18:32 +0000
commit4b07eaffcbe9586231ec25249488beb850a791b8 (patch)
treee39aafca9d0d0d19f1481f2c684a6490684ebed4 /editors/vscode
parentb2497d1dce8e41c5034ca4be7acf19323c23c16d (diff)
downloadports-4b07eaffcbe9586231ec25249488beb850a791b8.tar.gz
ports-4b07eaffcbe9586231ec25249488beb850a791b8.zip
editors/vscode: Resolve dependency confliction on node10 and 12
vscode has direct build dependency on npm-node10. And also has build dependency on devel/electron7. devel/electron7 depends on npm-node12. As a result, editors/vscode has dependency on both npm-node10 and npm-node12 however they conflicts each other. This confliction of dependency prevent this port building. PR: 248071 Submitted by: meta (myself) Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=544659
Diffstat (limited to 'editors/vscode')
-rw-r--r--editors/vscode/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index b454b63a88a0..8a989ba51596 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -21,8 +21,8 @@ ONLY_FOR_ARCHS= amd64
BUILD_DEPENDS= zip:archivers/zip \
electron${ELECTRON_VER_MAJOR}:devel/electron${ELECTRON_VER_MAJOR} \
rg:textproc/ripgrep \
- npm-node10>0:www/npm-node10 \
- yarn-node10>0:www/yarn-node10
+ npm-node${NODE_VER_MAJOR}>0:www/npm-node${NODE_VER_MAJOR} \
+ yarn-node${NODE_VER_MAJOR}>0:www/yarn-node${NODE_VER_MAJOR}
LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-atk \
libatspi.so:accessibility/at-spi2-core \
libsnappy.so:archivers/snappy \
@@ -74,6 +74,7 @@ USE_LDCONFIG= ${DATADIR}
# See ${WRKSRC}/remote/.yarnrc for NODE_VER
NODE_VER= 12.4.0
+NODE_VER_MAJOR= ${NODE_VER:C/\..*$//}
SHEBANG_REGEX= ./(extensions|resources|scripts|src)/.*\.sh$$
PATHFIX_FILES= src/vs/workbench/contrib/debug/node/terminals.ts