aboutsummaryrefslogtreecommitdiff
path: root/editors/vscode
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2019-12-30 10:59:42 +0000
committerBen Woods <woodsb02@FreeBSD.org>2019-12-30 10:59:42 +0000
commitcc1dd8761f473c1e9ce103302d2fb5687355d478 (patch)
tree6d43e4a2dfb3562dd1708fdf024a5e992885a5af /editors/vscode
parentbaeee6846fb98a763e007704aeed0c4d1dd60210 (diff)
downloadports-cc1dd8761f473c1e9ce103302d2fb5687355d478.tar.gz
ports-cc1dd8761f473c1e9ce103302d2fb5687355d478.zip
editors/vscode: add warning for build Error: EMFILE: too many open files
PR: 242871 Suggested by: Hiroki Tagato <tagattie@yandex.com> Reported by: woodsb02 Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=521479
Diffstat (limited to 'editors/vscode')
-rw-r--r--editors/vscode/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index f660b258fb23..e932537f93cb 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -100,6 +100,15 @@ POUDRIERE_EXTRACT_ONLY= yarn-offline-cache-${DISTVERSION}${EXTRACT_SUFX} \
vscode-marketplace-exts-${DISTVERSION}${EXTRACT_SUFX}
POUDRIERE_EXTRA_PATCHES= ${FILESDIR}/extra-patch-build_gulpfile.extensions.js
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "The limit imposed by poudriere(8) for the maximum number of files allowed to be"
+ @${ECHO_MSG} "opened by a jail (default 1024) is exceeded during the build of ${PORTNAME}."
+ @${ECHO_MSG} "To successfully build ${PORTNAME} with poudriere(8), you must add the following"
+ @${ECHO_MSG} "line to poudriere.conf:"
+ @${ECHO_MSG} "MAX_FILES_${PORTNAME}=4096"
+ @${ECHO_MSG} ""
+
post-extract:
${MKDIR} ${WRKDIR}/vscode-ripgrep
${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/vscode-ripgrep-${VSCODE_RIPGREP_VER}.tgz \