aboutsummaryrefslogtreecommitdiff
path: root/editors/wordgrinder
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-11-07 16:19:04 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-11-07 16:19:04 +0000
commit40ef725b66539462e22e402405a656715f919ded (patch)
tree2ab51bc8f0e56f7658d27951997134008a79ee04 /editors/wordgrinder
parentddf1f16d658eb31ca546ddc45bc92f01412023b9 (diff)
downloadports-40ef725b66539462e22e402405a656715f919ded.tar.gz
ports-40ef725b66539462e22e402405a656715f919ded.zip
- Update to version 0.6, now hosted on GitHub
- Add X11 option, on by default - Refresh pkg-descr, new project homepage Changelog: https://github.com/davidgiven/wordgrinder/releases/tag/0.6 PR: 203984 Submitted by: VItaly Magerya (maintainer)
Notes
Notes: svn path=/head/; revision=401004
Diffstat (limited to 'editors/wordgrinder')
-rw-r--r--editors/wordgrinder/Makefile44
-rw-r--r--editors/wordgrinder/distinfo4
-rw-r--r--editors/wordgrinder/pkg-descr16
3 files changed, 43 insertions, 21 deletions
diff --git a/editors/wordgrinder/Makefile b/editors/wordgrinder/Makefile
index 7e4901d670c3..2e88373fc0b3 100644
--- a/editors/wordgrinder/Makefile
+++ b/editors/wordgrinder/Makefile
@@ -2,23 +2,34 @@
# $FreeBSD$
PORTNAME= wordgrinder
-PORTVERSION= 0.5.2
+PORTVERSION= 0.6
CATEGORIES= editors
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= vmagerya@gmail.com
-COMMENT= Simple Unicode-aware console-based word processor
-
-LICENSE= MIT
+COMMENT= Simple Unicode-aware console and X11-based word processor
RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:${PORTSDIR}/devel/luafilesystem
-USES= lua:52 tar:bzip2 gmake
+USE_GITHUB= yes
+GH_ACCOUNT= davidgiven
+
+USES= gmake lua:52
PLIST_FILES= bin/wordgrinder \
share/doc/wordgrinder/README.wg \
man/man1/wordgrinder.1.gz
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT=X11
+
+X11_DESC= Support running in an X window in addition to console
+X11_PLIST_FILES=bin/xwordgrinder
+X11_USE= xorg=x11,xft
+X11_USES= pkgconfig
+X11_ALL_TARGET_OFF=unix
+
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} \
-e '/hide = /s/@//' \
@@ -29,14 +40,27 @@ post-patch:
-e 's|$$(hide)lua|$$(hide)${LUA_CMD}|' \
-e '/PREFIX = /d' \
-e '/install /s|$$(PRE|$$(DESTDIR)$$(PRE|' \
- -e '/install /s|-D||' \
-e '/install /s|share/man/man1|man/man1|' \
+ -e '/NCURSES_CFLAGS :=/s|=.*|=|' \
+ -e '/NCURSES_LIB :=/s|=.*|= -lncursesw|' \
+ -e '/X11_CFLAGS :=/s|=.*|= $$(shell pkg-config --cflags x11 xft)|' \
+ -e '/X11_LIB :=/s|=.*|= $$(shell pkg-config --libs x11 xft)|' \
${WRKSRC}/Makefile
-
-pre-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/wordgrinder
+ ${REINPLACE_CMD} \
+ -e '/#include <Xft/s|<|<X11/|' \
+ ${WRKSRC}/src/c/arch/unix/x11/x11.h
+.if ! ${PORT_OPTIONS:MX11}
+ # This is not strictly speaking required, but it cuts
+ # down on some unnecessary work and error messages.
+ ${REINPLACE_CMD} \
+ -e '/$$(eval $$(build-wordgrinder-x11))/d' \
+ ${WRKSRC}/Makefile
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/wordgrinder
+.if ${PORT_OPTIONS:MX11}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/xwordgrinder ${STAGEDIR}${PREFIX}/bin
+.endif
.include <bsd.port.mk>
diff --git a/editors/wordgrinder/distinfo b/editors/wordgrinder/distinfo
index 1d94aee26f48..9da6dc6b2293 100644
--- a/editors/wordgrinder/distinfo
+++ b/editors/wordgrinder/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wordgrinder-0.5.2.tar.bz2) = b8da422ebeb31ebace5d174fed1d959f942af0c2704e6f064c8f31b3bd7e7774
-SIZE (wordgrinder-0.5.2.tar.bz2) = 644852
+SHA256 (davidgiven-wordgrinder-0.6_GH0.tar.gz) = 3459cab32ca89d8585aa96ef0b9db2ac3802773223786991e48b3c62e2ee7eed
+SIZE (davidgiven-wordgrinder-0.6_GH0.tar.gz) = 1628087
diff --git a/editors/wordgrinder/pkg-descr b/editors/wordgrinder/pkg-descr
index e24e58417a6a..a06aba029978 100644
--- a/editors/wordgrinder/pkg-descr
+++ b/editors/wordgrinder/pkg-descr
@@ -1,11 +1,9 @@
-WordGrinder is a simple, Unicode-aware word processor that runs on the
-console. It's designed to get the hell out of your way and let you write;
-it does very little, but what it does it does well.
+WordGrinder is an ultra-clean and uncluttered word processor
+that runs in a terminal or an X11 window.
-It supports basic paragraph styles, basic character styles, basic screen
-markup, a menu interface that means you don't have to remember complex
-key sequences, HTML import and export, and some other useful features.
+The author made WordGrinder to have something to write novels
+on. It supports just enough character and paragraph style support
+to let you get the job done, while not enough to let you waste
+time configuring them.
-WordGrinder does not require X. It runs in a terminal.
-
-WWW: http://wordgrinder.sf.net
+WWW: http://cowlark.com/wordgrinder/