aboutsummaryrefslogtreecommitdiff
path: root/editors/xcoral
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-02-12 20:06:21 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-02-12 20:06:21 +0000
commit48c84969d1ca1928c4b45f3af17a8a03a3dcc94a (patch)
tree2a10067d04f0cb779fe14a73445be30f98ce0b74 /editors/xcoral
parentb96216a850b0be83dbe9cfd5075ff9e89464fec6 (diff)
downloadports-48c84969d1ca1928c4b45f3af17a8a03a3dcc94a.tar.gz
ports-48c84969d1ca1928c4b45f3af17a8a03a3dcc94a.zip
Update to 3.44
PR: 93238 Submitted by: Ports fury
Notes
Notes: svn path=/head/; revision=155842
Diffstat (limited to 'editors/xcoral')
-rw-r--r--editors/xcoral/Makefile21
-rw-r--r--editors/xcoral/distinfo6
-rw-r--r--editors/xcoral/files/patch-regex38
-rw-r--r--editors/xcoral/pkg-plist80
4 files changed, 61 insertions, 84 deletions
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index 2259b8bc355f..36f4f52db347 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xcoral
-PORTVERSION= 3.42b
+PORTVERSION= 3.44
CATEGORIES= editors
MASTER_SITES= http://xcoral.free.fr/
@@ -16,7 +16,22 @@ COMMENT= A multiwindow mouse-based text editor for X
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
-PLIST_SUB+= PORTVERSION=${PORTVERSION:S/b//}
+CONFIGURE_ENV= LIBS="-lgnuregex"
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 502010
+GNU_REGEX_H= gnu/regex.h
+.else
+GNU_REGEX_H= gnuregex.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's| regex\.c | |g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|"regex\.h"|<${GNU_REGEX_H}>|g' ${WRKSRC}/bm_search.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xcoral ${PREFIX}/bin
@@ -27,4 +42,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/xcoral/distinfo b/editors/xcoral/distinfo
index 86dd82a6bb54..e39b3c637c44 100644
--- a/editors/xcoral/distinfo
+++ b/editors/xcoral/distinfo
@@ -1,3 +1,3 @@
-MD5 (xcoral-3.42b.tar.gz) = 070249fb6ba8eb37014a78d487d7e517
-SHA256 (xcoral-3.42b.tar.gz) = d6a668aafb4c77ea8e90141fe98d8b2b57ac1bc3e19d1eb28a462c123a829183
-SIZE (xcoral-3.42b.tar.gz) = 1915720
+MD5 (xcoral-3.44.tar.gz) = 2c640813fb01c3c0b66738c198aa14ef
+SHA256 (xcoral-3.44.tar.gz) = f5e20b8026d89d7b73720758dd8f97d1127d2fafd7291fa80e67793ac929cdbb
+SIZE (xcoral-3.44.tar.gz) = 1916169
diff --git a/editors/xcoral/files/patch-regex b/editors/xcoral/files/patch-regex
deleted file mode 100644
index 61632f1e5393..000000000000
--- a/editors/xcoral/files/patch-regex
+++ /dev/null
@@ -1,38 +0,0 @@
-This patch makes xcoral use the standard GNU regular expression library,
-installed on FreeBSD as -lgnuregex, instead of compiling its own (of the
-same version).
-
- -mi
-
---- Makefile.in Thu Nov 15 16:29:49 2001
-+++ Makefile.in Tue Apr 8 19:06:20 2003
-@@ -15,5 +15,5 @@
- @SET_MAKE@
-
--LDOPTIONS = @LDFLAGS@
-+LDOPTIONS = @LDFLAGS@ -lgnuregex
-
- XCORALLIBDIR = \"$(XC_LIBDIR)\"
-@@ -32,5 +32,5 @@
- file_dict.c proc_dict.c gen.tab.c lex.yy.c ie_func.c mode.c \
- input_str.c process.c warn_box.c dial_box.c fs_box.c list_box.c \
-- man_box.c justify.c macros.c ctr_version.c color_area.c regex.c \
-+ man_box.c justify.c macros.c ctr_version.c color_area.c \
- selection.c tool_bar.c buttons_bits.c tbox.c
-
-@@ -44,5 +44,5 @@
- global_dict.o file_dict.o proc_dict.o ie_func.o mode.o \
- input_str.o process.o warn_box.o dial_box.o fs_box.o list_box.o \
-- man_box.o justify.o macros.o ctr_version.o color_area.o regex.o \
-+ man_box.o justify.o macros.o ctr_version.o color_area.o \
- selection.o tool_bar.o buttons_bits.o tbox.o @ALLOCA@
-
---- bm_search.c Sun Sep 20 12:49:08 1998
-+++ bm_search.c Tue Apr 8 19:04:23 2003
-@@ -58,5 +58,5 @@
- #include <sys/types.h>
- #define const
--#include "regex.h"
-+#include <gnuregex.h>
-
- #include "main_text.h"
diff --git a/editors/xcoral/pkg-plist b/editors/xcoral/pkg-plist
index 92ebdd97768a..c9f5c8e690b8 100644
--- a/editors/xcoral/pkg-plist
+++ b/editors/xcoral/pkg-plist
@@ -1,41 +1,41 @@
bin/xcoral
-%%PORTDOCS%%share/doc/xcoral/xcoral-%%PORTVERSION%%.ps
-%%PORTDOCS%%share/doc/xcoral/xcoral-card.ps
-share/xcoral/DEPEND
-share/xcoral/README
-share/xcoral/cmd.sc
-share/xcoral/color.sc
-share/xcoral/comments.sc
-share/xcoral/compare-win.sc
-share/xcoral/complete-word.sc
-share/xcoral/describe.sc
-share/xcoral/edir.sc
-share/xcoral/edt.sc
-share/xcoral/example.sc
-share/xcoral/french.sc
-share/xcoral/hack-filename.sc
-share/xcoral/hanoi.sc
-share/xcoral/head.sc
-share/xcoral/html.sc
-share/xcoral/java.sc
-share/xcoral/keydef-ext.sc
-share/xcoral/latex-macros.sc
-share/xcoral/latex.sc
-share/xcoral/lex.sc
-share/xcoral/man.dtex
-share/xcoral/misc-commands.sc
-share/xcoral/mode-ext.sc
-share/xcoral/mode.sc
-share/xcoral/mouse.sc
-share/xcoral/rcs.sc
-share/xcoral/save.sc
-share/xcoral/shell-script.sc
-share/xcoral/sun-keydef.sc
-share/xcoral/title.sc
-share/xcoral/top-ten.sc
-share/xcoral/utilities.sc
-share/xcoral/version.sc
-share/xcoral/window-utilities.sc
-share/xcoral/xcoralrc.lf
-@dirrm share/xcoral
-%%PORTDOCS%%@dirrm share/doc/xcoral
+%%PORTDOCS%%%%DOCSDIR%%/xcoral-%%VERSION%%.ps
+%%PORTDOCS%%%%DOCSDIR%%/xcoral-card.ps
+%%DATADIR%%/DEPEND
+%%DATADIR%%/README
+%%DATADIR%%/cmd.sc
+%%DATADIR%%/color.sc
+%%DATADIR%%/comments.sc
+%%DATADIR%%/compare-win.sc
+%%DATADIR%%/complete-word.sc
+%%DATADIR%%/describe.sc
+%%DATADIR%%/edir.sc
+%%DATADIR%%/edt.sc
+%%DATADIR%%/example.sc
+%%DATADIR%%/french.sc
+%%DATADIR%%/hack-filename.sc
+%%DATADIR%%/hanoi.sc
+%%DATADIR%%/head.sc
+%%DATADIR%%/html.sc
+%%DATADIR%%/java.sc
+%%DATADIR%%/keydef-ext.sc
+%%DATADIR%%/latex-macros.sc
+%%DATADIR%%/latex.sc
+%%DATADIR%%/lex.sc
+%%DATADIR%%/man.dtex
+%%DATADIR%%/misc-commands.sc
+%%DATADIR%%/mode-ext.sc
+%%DATADIR%%/mode.sc
+%%DATADIR%%/mouse.sc
+%%DATADIR%%/rcs.sc
+%%DATADIR%%/save.sc
+%%DATADIR%%/shell-script.sc
+%%DATADIR%%/sun-keydef.sc
+%%DATADIR%%/title.sc
+%%DATADIR%%/top-ten.sc
+%%DATADIR%%/utilities.sc
+%%DATADIR%%/version.sc
+%%DATADIR%%/window-utilities.sc
+%%DATADIR%%/xcoralrc.lf
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%