aboutsummaryrefslogtreecommitdiff
path: root/editors/xcoral
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2020-12-31 20:21:52 +0000
committerMikhail Teterin <mi@FreeBSD.org>2020-12-31 20:21:52 +0000
commite7321bbe776f897469272dbd35e5f98c52b59679 (patch)
tree46b3482eca9bee0b8dc1e540cf971843ed9ee3ae /editors/xcoral
parentb55d47cf5e52be677a6900d67559b3fe7d179be6 (diff)
downloadports-e7321bbe776f897469272dbd35e5f98c52b59679.tar.gz
ports-e7321bbe776f897469272dbd35e5f98c52b59679.zip
Start searching for headers and libraries under ${LOCALBASE}/ --
in case newer implementations of anything are installed there. When compiling on 13.x or above, insist on libgnuregex version above 5 -- earlier FreeBSD releases came with libgnuregex.so.5, but that's now gone and replaced by the devel/libgnuregex port, which currently installs libgnuregex.so.6. PR: 252252 252250 252245 Submitted by: kevans Sponsored by: United Marsupials
Notes
Notes: svn path=/head/; revision=559774
Diffstat (limited to 'editors/xcoral')
-rw-r--r--editors/xcoral/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index 7c65aa8e8ecd..ee90e3353ecc 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -20,12 +20,20 @@ USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
LIBS+= -lgnuregex
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -isystem ${LOCALBASE}/include
EXTRACT_AFTER_ARGS= --exclude BR_Parser.[ch]
PLIST_SUB= VERSION="${PORTVERSION}"
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 1300000
+LIB_DEPENDS+= libgnuregex.so.[6-9]:devel/libgnuregex
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| regex\.[co] | |g ; \
s| -g | |g' ${WRKSRC}/Makefile.in
@@ -37,4 +45,4 @@ do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Doc/* ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>