aboutsummaryrefslogtreecommitdiff
path: root/editors/xed
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-17 10:37:04 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-17 10:37:04 +0000
commit5cd11e903f2d8dfc2e9882d70c69492466933156 (patch)
treecb3697204629374aa948804997f58aaa155d5e35 /editors/xed
parentaf9f2293a07688bf25ef5ef8f8fb0456c37f8b6e (diff)
downloadports-5cd11e903f2d8dfc2e9882d70c69492466933156.tar.gz
ports-5cd11e903f2d8dfc2e9882d70c69492466933156.zip
- Update to version 2.8.4, add `gnome' to CATEGORIES
- Provide more descriptive COMMENT, fix RUN_DEPENDS - Add DOCS option which installs API documentation - Amend the port description based on the README.md PR: 252300 (based on) Submitted by: Charlie Li
Notes
Notes: svn path=/head/; revision=561808
Diffstat (limited to 'editors/xed')
-rw-r--r--editors/xed/Makefile20
-rw-r--r--editors/xed/distinfo6
-rw-r--r--editors/xed/pkg-descr11
-rw-r--r--editors/xed/pkg-plist39
4 files changed, 65 insertions, 11 deletions
diff --git a/editors/xed/Makefile b/editors/xed/Makefile
index 1d3443a9fd2d..15d7e0d33583 100644
--- a/editors/xed/Makefile
+++ b/editors/xed/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= xed
-PORTVERSION= 2.6.2
-PORTREVISION= 1
-CATEGORIES= editors
+PORTVERSION= 2.8.4
+CATEGORIES= editors gnome
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Small and lightweight graphical text editor
+COMMENT= Small but powerful graphical text editor
LICENSE= GPLv2+
@@ -17,13 +16,15 @@ BUILD_DEPENDS= intltool-merge:textproc/intltool \
itstool:textproc/itstool
LIB_DEPENDS= libpeas-1.0.so:devel/libpeas \
libxapp.so:x11/xapp
-RUN_DEPENDS= ${LOCALBASE}/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml:devel/gsettings-desktop-schemas
+RUN_DEPENDS= ${LOCALBASE}/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml:devel/gsettings-desktop-schemas \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:devel/py-libpeas@${PY_FLAVOR} \
+ yelp:x11/yelp
USES= compiler:c++11-lang desktop-file-utils gettext-tools gnome meson \
- pkgconfig xorg
+ pkgconfig python:3.6+,run xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview3 \
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview4 \
introspection pango
USE_LDCONFIG= yes
USE_XORG= x11
@@ -32,10 +33,13 @@ GLIB_SCHEMAS= org.x.editor.gschema.xml \
org.x.editor.plugins.time.gschema.xml \
org.x.editor.plugins.wordcompletion.gschema.xml
-OPTIONS_DEFINE= GSPELL
+OPTIONS_DEFINE= DOCS GSPELL
OPTIONS_DEFAULT= GSPELL
GSPELL_DESC= Spell checking support via gspell
+DOCS_BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
+DOCS_MESON_ON= -Ddocs=true
+
GSPELL_LIB_DEPENDS= libgspell-1.so:textproc/gspell
GSPELL_MESON_OFF= -Denable_spell=false
GSPELL_PLIST_FILES= lib/xed/plugins/libspell.so \
diff --git a/editors/xed/distinfo b/editors/xed/distinfo
index 0f8736993bc9..82cb06372300 100644
--- a/editors/xed/distinfo
+++ b/editors/xed/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592999116
-SHA256 (linuxmint-xed-2.6.2_GH0.tar.gz) = 357ef0e07b942878344c141b3494a960e6fbd6d9b12c9dab1e4e49d523d763f6
-SIZE (linuxmint-xed-2.6.2_GH0.tar.gz) = 4842633
+TIMESTAMP = 1609608994
+SHA256 (linuxmint-xed-2.8.4_GH0.tar.gz) = 76e8e46d3d47384fa61eb47502cdd3800563d87c0e2ee352338a196077b44a43
+SIZE (linuxmint-xed-2.8.4_GH0.tar.gz) = 4880543
diff --git a/editors/xed/pkg-descr b/editors/xed/pkg-descr
index 4f655022a69a..b3babad5a7b9 100644
--- a/editors/xed/pkg-descr
+++ b/editors/xed/pkg-descr
@@ -2,4 +2,15 @@ xed is a small and lightweight text editor, which supports most standard
editing features, plus several not typically found in one's average text
editor (plugins being the most notable of these).
+Although new features are always under development, currently xed has:
+
+ * Complete support for UTF-8 text
+ * Syntax highlighting for many languages
+ * Support for editing remote files
+ * Search and replace
+ * Printing and print previewing support
+ * File revert
+ * Complete preferences interface
+ * Configurable Python-based plugin system
+
WWW: https://github.com/linuxmint/xed
diff --git a/editors/xed/pkg-plist b/editors/xed/pkg-plist
index 3709f88f62c4..50d2def8cff9 100644
--- a/editors/xed/pkg-plist
+++ b/editors/xed/pkg-plist
@@ -21,6 +21,8 @@ include/xed/xed-window-activatable.h
include/xed/xed-window.h
lib/xed/girepository-1.0/Xed-1.0.typelib
lib/xed/libxed.so
+lib/xed/plugins/bracket-complete/bracketcompletion.plugin
+lib/xed/plugins/bracket-complete/bracketcompletion.py
lib/xed/plugins/docinfo.plugin
lib/xed/plugins/filebrowser.plugin
lib/xed/plugins/joinlines.plugin
@@ -50,6 +52,42 @@ libdata/pkgconfig/xed.pc
man/man1/xed.1.gz
share/applications/xed.desktop
share/dbus-1/services/org.x.editor.service
+%%PORTDOCS%%share/gtk-doc/html/xed/XedApp.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedAppActivatable.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedMessage.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedMessageBus.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedMessageType.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedPrintJob.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedProgressInfoBar.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedStatusbar.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedViewActivatable.html
+%%PORTDOCS%%share/gtk-doc/html/xed/XedWindowActivatable.html
+%%PORTDOCS%%share/gtk-doc/html/xed/annotation-glossary.html
+%%PORTDOCS%%share/gtk-doc/html/xed/api-index-full.html
+%%PORTDOCS%%share/gtk-doc/html/xed/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/xed/home.png
+%%PORTDOCS%%share/gtk-doc/html/xed/index.html
+%%PORTDOCS%%share/gtk-doc/html/xed/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/xed/left.png
+%%PORTDOCS%%share/gtk-doc/html/xed/object-tree.html
+%%PORTDOCS%%share/gtk-doc/html/xed/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/xed/right.png
+%%PORTDOCS%%share/gtk-doc/html/xed/style.css
+%%PORTDOCS%%share/gtk-doc/html/xed/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/xed/up.png
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-XedEncodingsOptionMenu.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-debug.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-document.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-file-chooser-dialog.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-help.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-notebook.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-panel.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-print-job-preview.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-tab.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-utils.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-view.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-window.html
+%%PORTDOCS%%share/gtk-doc/html/xed/xed.devhelp2
share/help/C/xed/figures/xed_format_bold.png
share/help/C/xed/figures/xed_format_italic.png
share/help/C/xed/figures/xed_format_strikethrough.png
@@ -344,6 +382,7 @@ share/locale/ur/LC_MESSAGES/xed.mo
share/locale/vi/LC_MESSAGES/xed.mo
share/locale/wa/LC_MESSAGES/xed.mo
share/locale/xh/LC_MESSAGES/xed.mo
+share/locale/zgh/LC_MESSAGES/xed.mo
share/locale/zh_CN/LC_MESSAGES/xed.mo
share/locale/zh_HK/LC_MESSAGES/xed.mo
share/locale/zh_TW/LC_MESSAGES/xed.mo