aboutsummaryrefslogtreecommitdiff
path: root/editors/xi-core
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-06-21 16:30:48 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-06-21 16:30:48 +0000
commit4e381d85163c8a7cf5feacd5a61b4b7a871c2605 (patch)
treeed818ae99d55eb7a7f899725116a7de6deeaf3e2 /editors/xi-core
parent773791da0614e7e8405cb6db6105fda283293d83 (diff)
downloadports-4e381d85163c8a7cf5feacd5a61b4b7a871c2605.tar.gz
ports-4e381d85163c8a7cf5feacd5a61b4b7a871c2605.zip
New port: editors/xi-core
The xi editor project is an attempt to build a high quality text editor, using modern software engineering techniques. Goals include: - Incredibly high performance. All editing operations should commit and paint in under 16ms. The editor should never make you wait for anything. - Beauty. The editor should fit well on a modern desktop, and not look like a throwback from the '80s or '90s. Text drawing should be done with the best technology available (Core Text on Mac, DirectWrite on Windows, etc.), and support Unicode fully. - Reliability. Crashing, hanging, or losing work should never happen. - Developer friendliness. It should be easy to customize xi editor, whether by adding plug-ins or hacking on the core. WWW: https://github.com/google/xi-editor Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D11162
Notes
Notes: svn path=/head/; revision=444039
Diffstat (limited to 'editors/xi-core')
-rw-r--r--editors/xi-core/Makefile45
-rw-r--r--editors/xi-core/distinfo43
-rw-r--r--editors/xi-core/pkg-descr16
3 files changed, 104 insertions, 0 deletions
diff --git a/editors/xi-core/Makefile b/editors/xi-core/Makefile
new file mode 100644
index 000000000000..e9860916c55b
--- /dev/null
+++ b/editors/xi-core/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= xi-core
+PORTVERSION= g20170612
+DISTVERSIONPREFIX= v
+CATEGORIES= editors
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Modern editor backend written in Rust
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+USES= cargo
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GH_PROJECT= xi-editor
+GH_TAGNAME= 3164cb6
+
+WRKSRC_SUBDIR= rust
+
+PLIST_FILES= bin/xi-core
+
+CARGO_CRATES= bytecount-0.1.6 \
+ crossbeam-0.2.10 \
+ dtoa-0.4.1 \
+ itoa-0.3.1 \
+ kernel32-sys-0.2.2 \
+ libc-0.2.23 \
+ memchr-1.0.1 \
+ num-traits-0.1.37 \
+ quote-0.3.15 \
+ redox_syscall-0.1.17 \
+ serde-1.0.2 \
+ serde_derive-1.0.2 \
+ serde_derive_internals-0.15.0 \
+ serde_json-1.0.1 \
+ syn-0.11.11 \
+ synom-0.11.3 \
+ time-0.1.37 \
+ unicode-xid-0.0.4 \
+ winapi-0.2.8 \
+ winapi-build-0.1.1
+
+.include <bsd.port.mk>
diff --git a/editors/xi-core/distinfo b/editors/xi-core/distinfo
new file mode 100644
index 000000000000..8c3e8bbc9a40
--- /dev/null
+++ b/editors/xi-core/distinfo
@@ -0,0 +1,43 @@
+TIMESTAMP = 1497447050
+SHA256 (rust/crates/bytecount-0.1.6.tar.gz) = 1e8f09fbc8c6726a4b616dcfbd4f54491068d6bb1b93ac03c78ac18ff9a5924a
+SIZE (rust/crates/bytecount-0.1.6.tar.gz) = 9435
+SHA256 (rust/crates/crossbeam-0.2.10.tar.gz) = 0c5ea215664ca264da8a9d9c3be80d2eaf30923c259d03e870388eb927508f97
+SIZE (rust/crates/crossbeam-0.2.10.tar.gz) = 32993
+SHA256 (rust/crates/dtoa-0.4.1.tar.gz) = 80c8b71fd71146990a9742fc06dcbbde19161a267e0ad4e572c35162f4578c90
+SIZE (rust/crates/dtoa-0.4.1.tar.gz) = 73264
+SHA256 (rust/crates/itoa-0.3.1.tar.gz) = eb2f404fbc66fd9aac13e998248505e7ecb2ad8e44ab6388684c5fb11c6c251c
+SIZE (rust/crates/itoa-0.3.1.tar.gz) = 73340
+SHA256 (rust/crates/kernel32-sys-0.2.2.tar.gz) = 7507624b29483431c0ba2d82aece8ca6cdba9382bff4ddd0f7490560c056098d
+SIZE (rust/crates/kernel32-sys-0.2.2.tar.gz) = 24537
+SHA256 (rust/crates/libc-0.2.23.tar.gz) = e7eb6b826bfc1fdea7935d46556250d1799b7fe2d9f7951071f4291710665e3e
+SIZE (rust/crates/libc-0.2.23.tar.gz) = 153939
+SHA256 (rust/crates/memchr-1.0.1.tar.gz) = 1dbccc0e46f1ea47b9f17e6d67c5a96bd27030519c519c9c91327e31275a47b4
+SIZE (rust/crates/memchr-1.0.1.tar.gz) = 8221
+SHA256 (rust/crates/num-traits-0.1.37.tar.gz) = e1cbfa3781f3fe73dc05321bed52a06d2d491eaa764c52335cf4399f046ece99
+SIZE (rust/crates/num-traits-0.1.37.tar.gz) = 20492
+SHA256 (rust/crates/quote-0.3.15.tar.gz) = 7a6e920b65c65f10b2ae65c831a81a073a89edd28c7cce89475bff467ab4167a
+SIZE (rust/crates/quote-0.3.15.tar.gz) = 12041
+SHA256 (rust/crates/redox_syscall-0.1.17.tar.gz) = 29dbdfd4b9df8ab31dec47c6087b7b13cbf4a776f335e4de8efba8288dda075b
+SIZE (rust/crates/redox_syscall-0.1.17.tar.gz) = 11683
+SHA256 (rust/crates/serde-1.0.2.tar.gz) = 3b46a59dd63931010fdb1d88538513f3279090d88b5c22ef4fe8440cfffcc6e3
+SIZE (rust/crates/serde-1.0.2.tar.gz) = 58548
+SHA256 (rust/crates/serde_derive-1.0.2.tar.gz) = 6c06b68790963518008b8ae0152d48be4bbbe77015d2c717f6282eea1824be9a
+SIZE (rust/crates/serde_derive-1.0.2.tar.gz) = 23633
+SHA256 (rust/crates/serde_derive_internals-0.15.0.tar.gz) = 021c338d22c7e30f957a6ab7e388cb6098499dda9fd4ba1661ee074ca7a180d1
+SIZE (rust/crates/serde_derive_internals-0.15.0.tar.gz) = 16382
+SHA256 (rust/crates/serde_json-1.0.1.tar.gz) = 1c62115693d0a9ed8c32d1c760f0fdbe7d4b05cb13c135b9b54137ac0d59fccb
+SIZE (rust/crates/serde_json-1.0.1.tar.gz) = 55365
+SHA256 (rust/crates/syn-0.11.11.tar.gz) = d3b891b9015c88c576343b9b3e41c2c11a51c219ef067b264bd9c8aa9b441dad
+SIZE (rust/crates/syn-0.11.11.tar.gz) = 63309
+SHA256 (rust/crates/synom-0.11.3.tar.gz) = a393066ed9010ebaed60b9eafa373d4b1baac186dd7e008555b0f702b51945b6
+SIZE (rust/crates/synom-0.11.3.tar.gz) = 17120
+SHA256 (rust/crates/time-0.1.37.tar.gz) = ffd7ccbf969a892bf83f1e441126968a07a3941c24ff522a26af9f9f4585d1a3
+SIZE (rust/crates/time-0.1.37.tar.gz) = 28346
+SHA256 (rust/crates/unicode-xid-0.0.4.tar.gz) = 8c1f860d7d29cf02cb2f3f359fd35991af3d30bac52c57d265a3c461074cb4dc
+SIZE (rust/crates/unicode-xid-0.0.4.tar.gz) = 16034
+SHA256 (rust/crates/winapi-0.2.8.tar.gz) = 167dc9d6949a9b857f3451275e911c3f44255842c1f7a76f33c55103a909087a
+SIZE (rust/crates/winapi-0.2.8.tar.gz) = 455145
+SHA256 (rust/crates/winapi-build-0.1.1.tar.gz) = 2d315eee3b34aca4797b2da6b13ed88266e6d612562a0c46390af8299fc699bc
+SIZE (rust/crates/winapi-build-0.1.1.tar.gz) = 669
+SHA256 (google-xi-editor-vg20170612-3164cb6_GH0.tar.gz) = d1a29be0ee2e69191cc250bcd0ba51600887c956b76f58ef94e6eba76fcd6c04
+SIZE (google-xi-editor-vg20170612-3164cb6_GH0.tar.gz) = 811394
diff --git a/editors/xi-core/pkg-descr b/editors/xi-core/pkg-descr
new file mode 100644
index 000000000000..a94fdaba4fec
--- /dev/null
+++ b/editors/xi-core/pkg-descr
@@ -0,0 +1,16 @@
+The xi editor project is an attempt to build a high quality text
+editor, using modern software engineering techniques.
+
+Goals include:
+- Incredibly high performance. All editing operations should commit
+ and paint in under 16ms. The editor should never make you wait for
+ anything.
+- Beauty. The editor should fit well on a modern desktop, and not look
+ like a throwback from the '80s or '90s. Text drawing should be done
+ with the best technology available (Core Text on Mac, DirectWrite on
+ Windows, etc.), and support Unicode fully.
+- Reliability. Crashing, hanging, or losing work should never happen.
+- Developer friendliness. It should be easy to customize xi editor,
+ whether by adding plug-ins or hacking on the core.
+
+WWW: https://github.com/google/xi-editor