aboutsummaryrefslogtreecommitdiff
path: root/editors/xmlcopyeditor
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-13 17:14:53 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-13 17:14:53 +0000
commit42cea4feca97175ce7fe8e01cef19ba73b69c476 (patch)
treedb7d60e9baca3e8f203bee4b35e80db32ed1fe56 /editors/xmlcopyeditor
parent31c9fcf7327a4faf7e0c2a77beaef9643cdd87a4 (diff)
downloadports-42cea4feca97175ce7fe8e01cef19ba73b69c476.tar.gz
ports-42cea4feca97175ce7fe8e01cef19ba73b69c476.zip
- Fix build after iconv change [1]
- Fix build with clang/libc++ ([2] for graphics/ipe) While here for databases/spatialite: - Trim Makefile headers - Remove check for unsupported FreeBSD versions Submitted by: marino [1] Reported by: swills, antoine [1] Submitted by: bsam [2] Approved by: portmgr (bapt, implicit)
Notes
Notes: svn path=/head/; revision=327168
Diffstat (limited to 'editors/xmlcopyeditor')
-rw-r--r--editors/xmlcopyeditor/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index 983fea120c2d..82d7844dd094 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -16,7 +16,7 @@ USE_WX= 2.8+
WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
WX_UNICODE= yes
-USES= gettext
+USES= gettext iconv
USE_DOS2UNIX= yes
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
@@ -32,6 +32,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/libxml2 ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} ${ICONV_LIB}
.include <bsd.port.mk>