aboutsummaryrefslogtreecommitdiff
path: root/editors/xmlcopyeditor
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2012-12-05 23:27:09 +0000
committerBarbara Guida <bar@FreeBSD.org>2012-12-05 23:27:09 +0000
commitc652b3fdc781d49d6465ca677358b0f8f0f07fd1 (patch)
tree56b3d615dfaeedb47fb94b17d1c14c37140525d8 /editors/xmlcopyeditor
parent3717ccbe4ded6d89ecce96171adce053701b0c41 (diff)
downloadports-c652b3fdc781d49d6465ca677358b0f8f0f07fd1.tar.gz
ports-c652b3fdc781d49d6465ca677358b0f8f0f07fd1.zip
- Update to 1.2.0.9
- Change LIB_DEPENDS from textproc/xerces-c2 to textproc/xerces-c3 - Remove obsolete patches - Trim Makefile headers - Remove ABI version from LIB_DEPENDS - Add LICENSE PR: ports/174062 Submitted by: bar Approved by: Jose Garcia Juanino <jjuanino@gmail.com> (maint.), rene (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=308354
Diffstat (limited to 'editors/xmlcopyeditor')
-rw-r--r--editors/xmlcopyeditor/Makefile34
-rw-r--r--editors/xmlcopyeditor/distinfo4
-rw-r--r--editors/xmlcopyeditor/files/patch-src_Makefile.in.diff42
-rw-r--r--editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff26
-rw-r--r--editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff10
-rw-r--r--editors/xmlcopyeditor/pkg-plist219
6 files changed, 231 insertions, 104 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index bdf082249761..feb0330a2a84 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -1,41 +1,35 @@
-# New ports collection makefile for: xmlcopyeditor
-# Date created: 6 December 2007
-# Whom: José García Juanino <jjuanino@gmail.com>
-#
+# Created by: José García Juanino <jjuanino@gmail.com>
# $FreeBSD$
-#
PORTNAME= xmlcopyeditor
-PORTVERSION= 1.2.0.4
-PORTREVISION= 7
+PORTVERSION= 1.2.0.9
CATEGORIES= editors
MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${PORTVERSION}
MAINTAINER= jjuanino@gmail.com
COMMENT= Fast validating XML editor
+LICENSE= GPLv2
+
USE_WX= 2.8+
WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
WX_UNICODE= yes
USE_GETTEXT= yes
USE_DOS2UNIX= src/templates/DTD.dtd \
- src/help/html/generic.css \
- src/help/xmlcopyeditor.hhp \
- src/rulesets/ruleset.css \
- src/rng/tei_all.rnc \
- src/rng/docbook.rnc \
- src/rng/tei_minimal.rnc \
+ src/templates/OpenLearn_document.xml \
src/rng/docbookxi.rnc \
- src/po/en_us/messages.po
+ src/rng/tei_all.rnc \
+ src/rng/xhtml-strict.rng \
+ src/rng/xhtml.rng
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
- xslt.2:${PORTSDIR}/textproc/libxslt \
- aspell.16:${PORTSDIR}/textproc/aspell \
- pcre.1:${PORTSDIR}/devel/pcre \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= xerces-c:${PORTSDIR}/textproc/xerces-c3 \
+ xslt:${PORTSDIR}/textproc/libxslt \
+ aspell:${PORTSDIR}/textproc/aspell \
+ pcre:${PORTSDIR}/devel/pcre \
+ xml2:${PORTSDIR}/textproc/libxml2 \
+ expat:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/editors/xmlcopyeditor/distinfo b/editors/xmlcopyeditor/distinfo
index 3649d762362f..ff0400fbcb59 100644
--- a/editors/xmlcopyeditor/distinfo
+++ b/editors/xmlcopyeditor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmlcopyeditor-1.2.0.4.tar.gz) = 252e08be52f0849faae36ee3a9d6e593f2bb1cb79a3c0d66430360b5811f9de2
-SIZE (xmlcopyeditor-1.2.0.4.tar.gz) = 2484860
+SHA256 (xmlcopyeditor-1.2.0.9.tar.gz) = 850df750f3561320f6ab1b612e00cd2b9ecc2bed49ab1dcc261af78d0a28b7f7
+SIZE (xmlcopyeditor-1.2.0.9.tar.gz) = 1815995
diff --git a/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff b/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
index de0ea14e7441..fc3843d70a9c 100644
--- a/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
+++ b/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
@@ -1,21 +1,33 @@
---- src/Makefile.in.orig 2009-04-14 11:38:17.000000000 -0500
-+++ src/Makefile.in 2010-10-02 16:22:21.000000000 -0500
-@@ -228,4 +228,4 @@
+--- src/Makefile.in.orig 2012-10-07 15:20:23.000000000 +0200
++++ src/Makefile.in 2012-12-02 17:24:51.000000000 +0100
+@@ -260,8 +260,8 @@
+ # these are the headers for your project
+ noinst_HEADERS = $(srcdir)/*.h
xmlcopyeditordir = ${prefix}/share/xmlcopyeditor
-pixmapdir = /usr/share/pixmaps
-applicationsdir = /usr/share/applications
+pixmapdir = ${prefix}/share/pixmaps
+applicationsdir = ${prefix}/share/applications
-@@ -269,11 +269,2 @@
- help/*.* help/html/*.* \
-- copying/*.txt copying/boost_shared_ptr/* \
-- copying/Expat/* copying/libxml2/* copying/libxslt/* \
-- copying/PCRE/* copying/Scintilla/* \
-- copying/wxStyledTextCtrl/* \
-- copying/wxStEditor/* \
-- copying/xmlcopyeditor/* \
-- copying/Aspell/* \
-- copying/Apache/LICENSE-2.0 \
-- copying/Apache/LICENSE-2_files/* \
- po/sk/messages.mo \
+ # the application source, library search path, and link libraries
+ xmlcopyeditor_SOURCES = xmlcopyeditor.cpp associatedialog.cpp casehandler.cpp \
+@@ -287,19 +287,6 @@
+ -lexpat -lxslt -lxml2 -lpcre -lxerces-c $(ASPELL_LIBS) $(ENCHANT_LIBS)
+
+ nobase_dist_xmlcopyeditor_DATA = $(srcdir)/catalog/catalog \
+- $(srcdir)/copying/*.txt \
+- $(srcdir)/copying/Apache/LICENSE-2.0 \
+- $(srcdir)/copying/Apache/LICENSE-2_files/* \
+- $(srcdir)/copying/Aspell/* \
+- $(srcdir)/copying/boost_shared_ptr/* \
+- $(srcdir)/copying/Expat/* \
+- $(srcdir)/copying/libxml2/* \
+- $(srcdir)/copying/libxslt/* \
+- $(srcdir)/copying/PCRE/* \
+- $(srcdir)/copying/Scintilla/* \
+- $(srcdir)/copying/wxStEditor/* \
+- $(srcdir)/copying/wxStyledTextCtrl/* \
+- $(srcdir)/copying/xmlcopyeditor/* \
+ $(srcdir)/dtd/*.* \
+ $(srcdir)/dtd/dita/*.* \
+ $(srcdir)/dtd/docbook/4.4/*.* \
diff --git a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff
deleted file mode 100644
index 903010c61ccf..000000000000
--- a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/xmlcopyeditor.cpp.orig
-+++ src/xmlcopyeditor.cpp
-@@ -3002,10 +3002,7 @@
-
- nconv = iconv (
- cd,
--#ifdef __WXMSW__
-- ( const char ** )
--#endif
-- &docBuffer,
-+ ICONV_CHAR_CAST(&docBuffer),
- &docBufferLeft,
- &iconvBuffer,
- &iconvBufferLeft );
-@@ -4617,10 +4614,7 @@
-
- nconv = iconv (
- cd,
--#ifdef __WXMSW__
-- ( const char ** )
--#endif
-- &utf8BufferPtr,
-+ ICONV_CHAR_CAST(&utf8BufferPtr),
- &utf8BufferLeft,
- &iconvBuffer,
- &iconvBufferLeft );
diff --git a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff
deleted file mode 100644
index b16e464409dc..000000000000
--- a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/xmlcopyeditor.h.orig
-+++ src/xmlcopyeditor.h
-@@ -21,6 +21,7 @@
- #define XMLCOPYEDITOR_H
-
- #define NEWFINDREPLACE 1
-+#define ICONV_CHAR_CAST(x) ((ICONV_CONST char **)(x))
-
- #include <wx/wx.h>
- #include <wx/fdrepdlg.h>
diff --git a/editors/xmlcopyeditor/pkg-plist b/editors/xmlcopyeditor/pkg-plist
index df8096943e43..be9dbbf8a031 100644
--- a/editors/xmlcopyeditor/pkg-plist
+++ b/editors/xmlcopyeditor/pkg-plist
@@ -2,7 +2,141 @@
bin/xmlcopyeditor
share/applications/xmlcopyeditor.desktop
share/pixmaps/xmlcopyeditor.png
-%%DATADIR%%/help/Table of Contents.hhc
+%%DATADIR%%/catalog/catalog
+%%DATADIR%%/dtd/NewsML_1.2.dtd
+%%DATADIR%%/dtd/OUGenericFull.dtd
+%%DATADIR%%/dtd/dita/catalog-dita.txt
+%%DATADIR%%/dtd/dita/catalog-dita.xml
+%%DATADIR%%/dtd/dita/concept.dtd
+%%DATADIR%%/dtd/dita/concept.mod
+%%DATADIR%%/dtd/dita/ditabase.dtd
+%%DATADIR%%/dtd/dita/highlight-domain.ent
+%%DATADIR%%/dtd/dita/highlight-domain.mod
+%%DATADIR%%/dtd/dita/map.dtd
+%%DATADIR%%/dtd/dita/map.mod
+%%DATADIR%%/dtd/dita/mapgroup.ent
+%%DATADIR%%/dtd/dita/mapgroup.mod
+%%DATADIR%%/dtd/dita/meta_xml.mod
+%%DATADIR%%/dtd/dita/meta_xml.mod.old
+%%DATADIR%%/dtd/dita/programming-domain.ent
+%%DATADIR%%/dtd/dita/programming-domain.mod
+%%DATADIR%%/dtd/dita/reference.dtd
+%%DATADIR%%/dtd/dita/reference.mod
+%%DATADIR%%/dtd/dita/software-domain.ent
+%%DATADIR%%/dtd/dita/software-domain.mod
+%%DATADIR%%/dtd/dita/task.dtd
+%%DATADIR%%/dtd/dita/task.mod
+%%DATADIR%%/dtd/dita/tbl_xml.mod
+%%DATADIR%%/dtd/dita/topic.dtd
+%%DATADIR%%/dtd/dita/topic.mod
+%%DATADIR%%/dtd/dita/topic_class.ent
+%%DATADIR%%/dtd/dita/topic_defn.ent
+%%DATADIR%%/dtd/dita/ui-domain.ent
+%%DATADIR%%/dtd/dita/ui-domain.mod
+%%DATADIR%%/dtd/dita/utilities-domain.ent
+%%DATADIR%%/dtd/dita/utilities-domain.mod
+%%DATADIR%%/dtd/docbook.dtd
+%%DATADIR%%/dtd/docbook/4.4/calstblx.dtd
+%%DATADIR%%/dtd/docbook/4.4/catalog.xml
+%%DATADIR%%/dtd/docbook/4.4/dbcentx.mod
+%%DATADIR%%/dtd/docbook/4.4/dbgenent.mod
+%%DATADIR%%/dtd/docbook/4.4/dbhierx.mod
+%%DATADIR%%/dtd/docbook/4.4/dbnotnx.mod
+%%DATADIR%%/dtd/docbook/4.4/dbpoolx.mod
+%%DATADIR%%/dtd/docbook/4.4/docbook.cat
+%%DATADIR%%/dtd/docbook/4.4/docbookx.dtd
+%%DATADIR%%/dtd/docbook/4.4/ent/isoamsa.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isoamsb.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isoamsc.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isoamsn.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isoamso.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isoamsr.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isobox.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isocyr1.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isocyr2.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isodia.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isogrk1.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isogrk2.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isogrk3.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isogrk4.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isolat1.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isolat2.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isonum.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isopub.ent
+%%DATADIR%%/dtd/docbook/4.4/ent/isotech.ent
+%%DATADIR%%/dtd/docbook/4.4/htmltblx.mod
+%%DATADIR%%/dtd/docbook/4.4/soextblx.dtd
+%%DATADIR%%/dtd/docbook/5.0b/docbook.dtd
+%%DATADIR%%/dtd/lzx.dtd
+%%DATADIR%%/dtd/moodle_glossary.dtd
+%%DATADIR%%/dtd/moodle_xml.dtd
+%%DATADIR%%/dtd/rss2.dtd
+%%DATADIR%%/dtd/tei/p4/catalog.tei
+%%DATADIR%%/dtd/tei/p4/dummy.dtd
+%%DATADIR%%/dtd/tei/p4/index.xml
+%%DATADIR%%/dtd/tei/p4/tei2.dtd
+%%DATADIR%%/dtd/tei/p4/teiana2.dtd
+%%DATADIR%%/dtd/tei/p4/teiana2.ent
+%%DATADIR%%/dtd/tei/p4/teiback2.dtd
+%%DATADIR%%/dtd/tei/p4/teicatalog.xml
+%%DATADIR%%/dtd/tei/p4/teicert2.dtd
+%%DATADIR%%/dtd/tei/p4/teiclas2.ent
+%%DATADIR%%/dtd/tei/p4/teicore2.dtd
+%%DATADIR%%/dtd/tei/p4/teicorp2.dtd
+%%DATADIR%%/dtd/tei/p4/teidict2.dtd
+%%DATADIR%%/dtd/tei/p4/teidict2.ent
+%%DATADIR%%/dtd/tei/p4/teidram2.dtd
+%%DATADIR%%/dtd/tei/p4/teidram2.ent
+%%DATADIR%%/dtd/tei/p4/teifig2.dtd
+%%DATADIR%%/dtd/tei/p4/teifig2.ent
+%%DATADIR%%/dtd/tei/p4/teifron2.dtd
+%%DATADIR%%/dtd/tei/p4/teifs2.dtd
+%%DATADIR%%/dtd/tei/p4/teifsd2.dtd
+%%DATADIR%%/dtd/tei/p4/teigen2.dtd
+%%DATADIR%%/dtd/tei/p4/teigis2.ent
+%%DATADIR%%/dtd/tei/p4/teihdr2.dtd
+%%DATADIR%%/dtd/tei/p4/teikey2.ent
+%%DATADIR%%/dtd/tei/p4/teilink2.dtd
+%%DATADIR%%/dtd/tei/p4/teilink2.ent
+%%DATADIR%%/dtd/tei/p4/teilite.dec
+%%DATADIR%%/dtd/tei/p4/teilitex.dtd
+%%DATADIR%%/dtd/tei/p4/teilitex.ent
+%%DATADIR%%/dtd/tei/p4/teimix2.dtd
+%%DATADIR%%/dtd/tei/p4/teind2.dtd
+%%DATADIR%%/dtd/tei/p4/teind2.ent
+%%DATADIR%%/dtd/tei/p4/teinet2.dtd
+%%DATADIR%%/dtd/tei/p4/teipl2.dtd
+%%DATADIR%%/dtd/tei/p4/teipros2.dtd
+%%DATADIR%%/dtd/tei/p4/teisgml.dec
+%%DATADIR%%/dtd/tei/p4/teishd2.dtd
+%%DATADIR%%/dtd/tei/p4/teispok2.dtd
+%%DATADIR%%/dtd/tei/p4/teispok2.ent
+%%DATADIR%%/dtd/tei/p4/teistr2.dtd
+%%DATADIR%%/dtd/tei/p4/teitc2.dtd
+%%DATADIR%%/dtd/tei/p4/teitc2.ent
+%%DATADIR%%/dtd/tei/p4/teite2f.dtd
+%%DATADIR%%/dtd/tei/p4/teite2n.dtd
+%%DATADIR%%/dtd/tei/p4/teiterm2.dtd
+%%DATADIR%%/dtd/tei/p4/teiterm2.ent
+%%DATADIR%%/dtd/tei/p4/teitran2.dtd
+%%DATADIR%%/dtd/tei/p4/teitran2.ent
+%%DATADIR%%/dtd/tei/p4/teitsd2.dtd
+%%DATADIR%%/dtd/tei/p4/teivers2.dtd
+%%DATADIR%%/dtd/tei/p4/teivers2.ent
+%%DATADIR%%/dtd/tei/p4/teiwsd2.dtd
+%%DATADIR%%/dtd/tei/p4/teixlite.dec
+%%DATADIR%%/dtd/tei/p5/tei_all.dtd
+%%DATADIR%%/dtd/xhtml-lat1.ent
+%%DATADIR%%/dtd/xhtml-special.ent
+%%DATADIR%%/dtd/xhtml-symbol.ent
+%%DATADIR%%/dtd/xhtml1-frameset.dtd
+%%DATADIR%%/dtd/xhtml1-strict.dtd
+%%DATADIR%%/dtd/xhtml1-transitional.dtd
+%%DATADIR%%/dtd/xliff.dtd
+%%DATADIR%%/dtd/xslt10.dtd
+%%DATADIR%%/dtd/xtm1.dtd
+%%DATADIR%%/dtd/xtm2.dtd
+%%DATADIR%%/help/Table_of_Contents.hhc
%%DATADIR%%/help/html/appendix.html
%%DATADIR%%/help/html/association.html
%%DATADIR%%/help/html/attribute_hiding.html
@@ -63,10 +197,12 @@ share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/png/stock_spellcheck.png
%%DATADIR%%/png/stock_undo-16.png
%%DATADIR%%/png/stock_undo.png
+%%DATADIR%%/po/ca/messages.mo
%%DATADIR%%/po/de/messages.mo
-%%DATADIR%%/po/en_us/messages.po
%%DATADIR%%/po/es/messages.mo
%%DATADIR%%/po/fr/messages.mo
+%%DATADIR%%/po/it/messages.mo
+%%DATADIR%%/po/nl/messages.mo
%%DATADIR%%/po/ru/messages.mo
%%DATADIR%%/po/sk/messages.mo
%%DATADIR%%/po/sv/messages.mo
@@ -124,52 +260,52 @@ share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/rulesets/American.xml
%%DATADIR%%/rulesets/Commonwealth.xml
%%DATADIR%%/rulesets/Contractions.xml
-%%DATADIR%%/rulesets/Default dictionary and style.xml
-%%DATADIR%%/rulesets/Default dictionary.xml
-%%DATADIR%%/rulesets/Default style.xml
+%%DATADIR%%/rulesets/Default_dictionary.xml
+%%DATADIR%%/rulesets/Default_dictionary_and_style.xml
+%%DATADIR%%/rulesets/Default_style.xml
%%DATADIR%%/rulesets/Disability.xml
%%DATADIR%%/rulesets/Diversity.xml
%%DATADIR%%/rulesets/Ethnicity.xml
%%DATADIR%%/rulesets/Gender.xml
%%DATADIR%%/rulesets/Hyphenation.xml
%%DATADIR%%/rulesets/Ise.xml
-%%DATADIR%%/rulesets/Ize and yse.xml
%%DATADIR%%/rulesets/Ize.xml
+%%DATADIR%%/rulesets/Ize_and_yse.xml
%%DATADIR%%/rulesets/Postcolonial.xml
%%DATADIR%%/rulesets/Punctuation.xml
%%DATADIR%%/rulesets/Query.xml
%%DATADIR%%/rulesets/Religion.xml
%%DATADIR%%/rulesets/Repetition.xml
-%%DATADIR%%/rulesets/White space.xml
+%%DATADIR%%/rulesets/White_space.xml
%%DATADIR%%/rulesets/ruleset.css
%%DATADIR%%/rulesets/ruleset.ctm
%%DATADIR%%/rulesets/ruleset.rld
%%DATADIR%%/rulesets/ruleset.xsd
-%%DATADIR%%/templates/Custom rule set.xml
-%%DATADIR%%/templates/DITA Concept.xml
-%%DATADIR%%/templates/DITA Map.xml
-%%DATADIR%%/templates/DITA Task.xml
-%%DATADIR%%/templates/DITA Topic.xml
+%%DATADIR%%/templates/Custom_rule_set.xml
+%%DATADIR%%/templates/DITA_Concept.xml
+%%DATADIR%%/templates/DITA_Map.xml
+%%DATADIR%%/templates/DITA_Task.xml
+%%DATADIR%%/templates/DITA_Topic.xml
%%DATADIR%%/templates/DTD.dtd
-%%DATADIR%%/templates/DocBook 4.4 article.xml
-%%DATADIR%%/templates/DocBook 4.4 book.xml
-%%DATADIR%%/templates/DocBook 5.0b article.xml
-%%DATADIR%%/templates/DocBook 5.0b book.xml
-%%DATADIR%%/templates/Moodle glossary.xml
-%%DATADIR%%/templates/Moodle quiz.xml
-%%DATADIR%%/templates/NewsML 1.2.xml
+%%DATADIR%%/templates/DocBook_4.4_article.xml
+%%DATADIR%%/templates/DocBook_4.4_book.xml
+%%DATADIR%%/templates/DocBook_5.0b_article.xml
+%%DATADIR%%/templates/DocBook_5.0b_book.xml
+%%DATADIR%%/templates/Moodle_glossary.xml
+%%DATADIR%%/templates/Moodle_quiz.xml
+%%DATADIR%%/templates/NewsML_1.2.xml
%%DATADIR%%/templates/OpenLaszlo.lzx
-%%DATADIR%%/templates/OpenLearn document.xml
-%%DATADIR%%/templates/RELAX NG grammar.rng
-%%DATADIR%%/templates/RSS 2.0.rss
-%%DATADIR%%/templates/TEI document.xml
-%%DATADIR%%/templates/WordprocessingML document.xml
-%%DATADIR%%/templates/XHTML 1.0 Strict document.html
-%%DATADIR%%/templates/XLIFF document.xlf
-%%DATADIR%%/templates/XML Schema.xsd
-%%DATADIR%%/templates/XML Topic Map 1.0.xtm
-%%DATADIR%%/templates/XML Topic Map 2.0.xtm
-%%DATADIR%%/templates/XSL stylesheet.xsl
+%%DATADIR%%/templates/OpenLearn_document.xml
+%%DATADIR%%/templates/RELAX_NG_grammar.rng
+%%DATADIR%%/templates/RSS_2.0.rss
+%%DATADIR%%/templates/TEI_document.xml
+%%DATADIR%%/templates/WordprocessingML_document.xml
+%%DATADIR%%/templates/XHTML_1.0_Strict_document.html
+%%DATADIR%%/templates/XLIFF_document.xlf
+%%DATADIR%%/templates/XML_Schema.xsd
+%%DATADIR%%/templates/XML_Topic_Map_1.0.xtm
+%%DATADIR%%/templates/XML_Topic_Map_2.0.xtm
+%%DATADIR%%/templates/XSL_stylesheet.xsl
%%DATADIR%%/xpm/appicon.xpm
%%DATADIR%%/xpm/stock_copy_16.xpm
%%DATADIR%%/xpm/stock_cut_16.xpm
@@ -193,6 +329,15 @@ share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/xpm/stock_spellcheck.xpm
%%DATADIR%%/xpm/stock_spellcheck_16.xpm
%%DATADIR%%/xpm/stock_undo_16.xpm
+%%DATADIR%%/xsl/openlearn2daisyhtml/heading.xsl
+%%DATADIR%%/xsl/openlearn2daisyhtml/inline.xsl
+%%DATADIR%%/xsl/openlearn2daisyhtml/item.xsl
+%%DATADIR%%/xsl/openlearn2daisyhtml/lang.xsl
+%%DATADIR%%/xsl/openlearn2daisyhtml/object.xsl
+%%DATADIR%%/xsl/openlearn2daisyhtml/openlearn2daisyhtml.xsl
+%%DATADIR%%/xsl/openlearn2daisyhtml/structure.xsl
+@dirrm %%DATADIR%%/xsl/openlearn2daisyhtml
+@dirrm %%DATADIR%%/xsl
@dirrm %%DATADIR%%/xpm
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/rulesets
@@ -205,14 +350,26 @@ share/pixmaps/xmlcopyeditor.png
@dirrm %%DATADIR%%/po/sv
@dirrm %%DATADIR%%/po/sk
@dirrm %%DATADIR%%/po/ru
+@dirrm %%DATADIR%%/po/nl
+@dirrm %%DATADIR%%/po/it
@dirrm %%DATADIR%%/po/fr
-@dirrm %%DATADIR%%/po/en_us
@dirrm %%DATADIR%%/po/es
@dirrm %%DATADIR%%/po/de
+@dirrm %%DATADIR%%/po/ca
@dirrm %%DATADIR%%/po
@dirrm %%DATADIR%%/png
@dirrm %%DATADIR%%/help/html
@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%/dtd/tei/p5
+@dirrm %%DATADIR%%/dtd/tei/p4
+@dirrm %%DATADIR%%/dtd/tei
+@dirrm %%DATADIR%%/dtd/docbook/5.0b
+@dirrm %%DATADIR%%/dtd/docbook/4.4/ent
+@dirrm %%DATADIR%%/dtd/docbook/4.4
+@dirrm %%DATADIR%%/dtd/docbook
+@dirrm %%DATADIR%%/dtd/dita
+@dirrm %%DATADIR%%/dtd
+@dirrm %%DATADIR%%/catalog
@dirrm %%DATADIR%%
@dirrmtry share/pixmaps
@dirrmtry share/applications