aboutsummaryrefslogtreecommitdiff
path: root/editors/xvile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2007-05-29 16:55:40 +0000
committerGary Jennejohn <gj@FreeBSD.org>2007-05-29 16:55:40 +0000
commit43d7545b843b8577c5f1df32c2499c5a09ada55a (patch)
treee4c1b8970874196013941011c4b2c5a30088d352 /editors/xvile
parent58ea5067de36c5f73eb285ff1dd766471bda6159 (diff)
downloadports-43d7545b843b8577c5f1df32c2499c5a09ada55a.tar.gz
ports-43d7545b843b8577c5f1df32c2499c5a09ada55a.zip
Update to version 9.5q.
Use OPTIONS.
Notes
Notes: svn path=/head/; revision=192320
Diffstat (limited to 'editors/xvile')
-rw-r--r--editors/xvile/Makefile30
-rw-r--r--editors/xvile/distinfo9
-rw-r--r--editors/xvile/files/patch-configure10
-rw-r--r--editors/xvile/files/patch-configure.in10
-rw-r--r--editors/xvile/pkg-plist2
-rw-r--r--editors/xvile/pkg-plist.filt2
-rw-r--r--editors/xvile/pkg-plist.perl2
-rw-r--r--editors/xvile/pkg-plist.perl+filt2
8 files changed, 53 insertions, 14 deletions
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index e5b8967e854d..3e4de703fd8f 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xvile
-PORTVERSION= 9.5n
-PORTREVISION= 1
+PORTVERSION= 9.5q
CATEGORIES= editors
MASTER_SITES= ftp://invisible-island.net/vile/ \
ftp://dickey.his.com/vile/ \
@@ -29,7 +28,10 @@ PATCHFILES= vile-9.5a.patch.gz \
vile-9.5k.patch.gz \
vile-9.5l.patch.gz \
vile-9.5m.patch.gz \
- vile-9.5n.patch.gz
+ vile-9.5n.patch.gz \
+ vile-9.5o.patch.gz \
+ vile-9.5p.patch.gz \
+ vile-9.5q.patch.gz
MAINTAINER= gj@FreeBSD.org
COMMENT= VI Like Emacs, X11 version -- a fully "X aware" vi work-alike
@@ -46,26 +48,26 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--x-libraries=${X11BASE}/lib
MAN1= xvile.1
-.if defined(WITH_ALL)
-WITH_FILTERS=1
-WITH_MENUS=1
-WITH_PERL=1
-WITH_XAW3D=1
-.endif
+OPTIONS= FILTERS "Add support for loadable filters" OFF
+OPTIONS+= MENUS "Add support for menus" OFF
+OPTIONS+= PERL "Add support for perl functions" OFF
+OPTIONS+= XAW3D "Use XAW3D to get a 3D effect" OFF
+
+.include <bsd.port.pre.mk>
pre-configure:
.if ! defined(WITH_MENUS)
- @${ECHO_MSG} "To use xvile with menus, set the environment variable WITH_MENUS,"
+ @${ECHO_MSG} "To use xvile with menus, choose the option MENUS,"
@${ECHO_MSG} "which will also turn on Xaw. If you have Xaw3d, you can use it"
- @${ECHO_MSG} "by also settting the environment variable WITH_XAW3D."
+ @${ECHO_MSG} "by also choosing the option XAW3D."
.endif
.if ! defined(WITH_PERL)
- @${ECHO_MSG} "To use xvile with PERL, set the environment variable WITH_PERL."
+ @${ECHO_MSG} "To use xvile with PERL, choose the option PERL."
.endif
.if ! defined(WITH_FILTERS)
- @${ECHO_MSG} "Define WITH_FILTERS if you want to make an xvile which will"
+ @${ECHO_MSG} "Choose the option FILTERS if you want to make an xvile which will"
@${ECHO_MSG} "dynamically load filters as needed."
.endif
@@ -105,4 +107,4 @@ post-install:
@${ECHO_MSG} "Look in ${PREFIX}/share/doc/xvile for documentation."
@${ECHO_MSG} "Look in ${PREFIX}/share/xvile/macros for macros."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/xvile/distinfo b/editors/xvile/distinfo
index 0ccdffdfb642..78eb092d007f 100644
--- a/editors/xvile/distinfo
+++ b/editors/xvile/distinfo
@@ -43,3 +43,12 @@ SIZE (vile-9.5m.patch.gz) = 68864
MD5 (vile-9.5n.patch.gz) = d7d444b409d5f2efd4b3dbaffef4bf9e
SHA256 (vile-9.5n.patch.gz) = a03acbe00e51f68532c5d026caab69a54a7714293bad22accbbe4ccff29b33a0
SIZE (vile-9.5n.patch.gz) = 72458
+MD5 (vile-9.5o.patch.gz) = 786b1319cdfe8e0a145244b752c6b112
+SHA256 (vile-9.5o.patch.gz) = 465488824fcfd032534b71210ca070dff8336e583a7c0265326faed6ec0679c7
+SIZE (vile-9.5o.patch.gz) = 18113
+MD5 (vile-9.5p.patch.gz) = 37dcbe4840272a1ad7931ae8f3f8cbbf
+SHA256 (vile-9.5p.patch.gz) = 6b87da2e14ab1855349df7eb14725c5b04148153cd7f6e94b142ccd58135b0a1
+SIZE (vile-9.5p.patch.gz) = 10993
+MD5 (vile-9.5q.patch.gz) = 901827470a6b81a86b52877a4b6de4c1
+SHA256 (vile-9.5q.patch.gz) = d05f28c92a1d872f7838c107c6ed1f7675cc9eafc652e9d4e454fb06e16f855f
+SIZE (vile-9.5q.patch.gz) = 107182
diff --git a/editors/xvile/files/patch-configure b/editors/xvile/files/patch-configure
new file mode 100644
index 000000000000..bcff30304460
--- /dev/null
+++ b/editors/xvile/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue May 29 13:09:09 2007
++++ configure Tue May 29 13:09:23 2007
+@@ -4930,7 +4930,6 @@
+ memory.h \
+ poll.h \
+ pwd.h \
+-search.h \
+ select.h \
+ setjmp.h \
+ sgtty.h \
diff --git a/editors/xvile/files/patch-configure.in b/editors/xvile/files/patch-configure.in
new file mode 100644
index 000000000000..6a9dcbdbee10
--- /dev/null
+++ b/editors/xvile/files/patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig Tue May 29 13:09:51 2007
++++ configure.in Tue May 29 13:09:57 2007
+@@ -335,7 +335,6 @@
+ memory.h \
+ poll.h \
+ pwd.h \
+-search.h \
+ select.h \
+ setjmp.h \
+ sgtty.h \
diff --git a/editors/xvile/pkg-plist b/editors/xvile/pkg-plist
index ca5d1f65c9b5..7bd82effba8e 100644
--- a/editors/xvile/pkg-plist
+++ b/editors/xvile/pkg-plist
@@ -54,6 +54,7 @@ lib/xvile/vile-rc-filt
lib/xvile/vile-rcs-filt
lib/xvile/vile-rexx-filt
lib/xvile/vile-rpm-filt
+lib/xvile/vile-rtf-filt
lib/xvile/vile-ruby-filt
lib/xvile/vile-sccs-filt
lib/xvile/vile-sed-filt
@@ -158,6 +159,7 @@ share/xvile/vile/rc.keywords
share/xvile/vile/rcs.keywords
share/xvile/vile/rexx.keywords
share/xvile/vile/rpm.keywords
+share/xvile/vile/rtf.keywords
share/xvile/vile/sccs.keywords
share/xvile/vile/sh.keywords
share/xvile/vile/sml.keywords
diff --git a/editors/xvile/pkg-plist.filt b/editors/xvile/pkg-plist.filt
index 5738428871d2..577f2b959c5b 100644
--- a/editors/xvile/pkg-plist.filt
+++ b/editors/xvile/pkg-plist.filt
@@ -57,6 +57,7 @@ lib/xvile/vile-rc-filt.so
lib/xvile/vile-rcs-filt.so
lib/xvile/vile-rexx-filt.so
lib/xvile/vile-rpm-filt.so
+lib/xvile/vile-rtf-filt.so
lib/xvile/vile-sccs-filt.so
lib/xvile/vile-sh-filt.so
lib/xvile/vile-sml-filt.so
@@ -160,6 +161,7 @@ share/xvile/vile/rc.keywords
share/xvile/vile/rcs.keywords
share/xvile/vile/rexx.keywords
share/xvile/vile/rpm.keywords
+share/xvile/vile/rtf.keywords
share/xvile/vile/sccs.keywords
share/xvile/vile/sh.keywords
share/xvile/vile/sml.keywords
diff --git a/editors/xvile/pkg-plist.perl b/editors/xvile/pkg-plist.perl
index f56358d5da7d..647fba2db109 100644
--- a/editors/xvile/pkg-plist.perl
+++ b/editors/xvile/pkg-plist.perl
@@ -55,6 +55,7 @@ lib/xvile/vile-rc-filt
lib/xvile/vile-rcs-filt
lib/xvile/vile-rexx-filt
lib/xvile/vile-rpm-filt
+lib/xvile/vile-rtf-filt
lib/xvile/vile-ruby-filt
lib/xvile/vile-sccs-filt
lib/xvile/vile-sed-filt
@@ -184,6 +185,7 @@ share/xvile/vile/rc.keywords
share/xvile/vile/rcs.keywords
share/xvile/vile/rexx.keywords
share/xvile/vile/rpm.keywords
+share/xvile/vile/rtf.keywords
share/xvile/vile/sccs.keywords
share/xvile/vile/sh.keywords
share/xvile/vile/sml.keywords
diff --git a/editors/xvile/pkg-plist.perl+filt b/editors/xvile/pkg-plist.perl+filt
index e0ac6f273624..69f9ac044cdf 100644
--- a/editors/xvile/pkg-plist.perl+filt
+++ b/editors/xvile/pkg-plist.perl+filt
@@ -58,6 +58,7 @@ lib/xvile/vile-rc-filt.so
lib/xvile/vile-rcs-filt.so
lib/xvile/vile-rexx-filt.so
lib/xvile/vile-rpm-filt.so
+lib/xvile/vile-rtf-filt.so
lib/xvile/vile-sccs-filt.so
lib/xvile/vile-sh-filt.so
lib/xvile/vile-sml-filt.so
@@ -184,6 +185,7 @@ share/xvile/vile/rc.keywords
share/xvile/vile/rcs.keywords
share/xvile/vile/rexx.keywords
share/xvile/vile/rpm.keywords
+share/xvile/vile/rtf.keywords
share/xvile/vile/sccs.keywords
share/xvile/vile/sh.keywords
share/xvile/vile/sml.keywords