aboutsummaryrefslogtreecommitdiff
path: root/editors/xvile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2010-02-01 11:25:44 +0000
committerGary Jennejohn <gj@FreeBSD.org>2010-02-01 11:25:44 +0000
commita37435a71304c1d91a47731e384e5e95bbf62eb5 (patch)
treecc47f17cc6080e57980f3d82982eb5bbcf8cf4f5 /editors/xvile
parent9d55040bef81181c89c35357d8033bc09587e2aa (diff)
downloadports-a37435a71304c1d91a47731e384e5e95bbf62eb5.tar.gz
ports-a37435a71304c1d91a47731e384e5e95bbf62eb5.zip
Update to 9.7za.
Remove patch-x11.c, which is now in the upstream source.
Notes
Notes: svn path=/head/; revision=249019
Diffstat (limited to 'editors/xvile')
-rw-r--r--editors/xvile/Makefile7
-rw-r--r--editors/xvile/distinfo6
-rw-r--r--editors/xvile/files/patch-x11.c21
3 files changed, 10 insertions, 24 deletions
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index 9e36faf87e60..d56e976116bd 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xvile
-PORTVERSION= 9.7y
-PORTREVISION= 1
+PORTVERSION= 9.7za
CATEGORIES= editors
MASTER_SITES= ftp://invisible-island.net/vile/ \
ftp://dickey.his.com/vile/ \
@@ -40,7 +39,9 @@ PATCHFILES= vile-9.7a.patch.gz \
vile-9.7v.patch.gz \
vile-9.7w.patch.gz \
vile-9.7x.patch.gz \
- vile-9.7y.patch.gz
+ vile-9.7y.patch.gz \
+ vile-9.7z.patch.gz \
+ vile-9.7za.patch.gz
MAINTAINER= gj@FreeBSD.org
COMMENT= VI Like Emacs, X11 version -- a fully "X aware" vi work-alike
diff --git a/editors/xvile/distinfo b/editors/xvile/distinfo
index 7ce3371c5a3c..9fd4d2413242 100644
--- a/editors/xvile/distinfo
+++ b/editors/xvile/distinfo
@@ -76,3 +76,9 @@ SIZE (vile-9.7x.patch.gz) = 278840
MD5 (vile-9.7y.patch.gz) = 61b5b747c70070f7ac6a694f80290e2d
SHA256 (vile-9.7y.patch.gz) = 6322f133a75211d0b1f99a963de9a18afe25d606c80616c91f23bca6b9ecbfa0
SIZE (vile-9.7y.patch.gz) = 245332
+MD5 (vile-9.7z.patch.gz) = c079dd909b80b8bc013fe701197db531
+SHA256 (vile-9.7z.patch.gz) = f922f0bf16b8ca7c02365991739e2fcd90effe17ca671e8e55063136f919cea0
+SIZE (vile-9.7z.patch.gz) = 104271
+MD5 (vile-9.7za.patch.gz) = a74e5fbacb2e0b09ef311b44388d13df
+SHA256 (vile-9.7za.patch.gz) = fde2cb0fa09e4077c8bac85df18e23f29d5ea42427c5536e83d303dac9ea53c1
+SIZE (vile-9.7za.patch.gz) = 86143
diff --git a/editors/xvile/files/patch-x11.c b/editors/xvile/files/patch-x11.c
deleted file mode 100644
index 260f846ba038..000000000000
--- a/editors/xvile/files/patch-x11.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- x11.c.orig 2009-12-31 14:32:20.000000000 +0100
-+++ x11.c 2009-12-31 14:33:53.000000000 +0100
-@@ -2180,10 +2180,15 @@
- static GC
- get_color_gc(int n, Boolean normal)
- {
-- ColorGC *data = (normal
-- ? &(cur_win->fore_color[n])
-- : &(cur_win->back_color[n]));
-+ ColorGC *data;
-
-+ assert(n >= 0 && n < NCOLORS);
-+
-+ if (n < 0 || n > NCOLORS)
-+ n = 0; /* shouldn't happen */
-+ data = (normal
-+ ? &(cur_win->fore_color[n])
-+ : &(cur_win->back_color[n]));
- if (cur_win->screen_depth == 1) {
- data->gc = (normal
- ? cur_win->textgc