aboutsummaryrefslogtreecommitdiff
path: root/editors/xvile
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-31 06:17:41 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-31 06:17:41 +0000
commitab94c5fe2f17652f84e7052c8144c7dda2b02221 (patch)
treec1420df3501cfd76202ff155f9c6e3af2f3b1a9f /editors/xvile
parentc4a6eaf9337b0c9c46c97475b798dcf18e1896c1 (diff)
downloadports-ab94c5fe2f17652f84e7052c8144c7dda2b02221.tar.gz
ports-ab94c5fe2f17652f84e7052c8144c7dda2b02221.zip
- Update to 9.8u
- Add LICENSE_FILE PR: 246586 Submitted by: Thomas E. Dickey <dickey@invisible-island.net> (maintainer) Approved by: mentors (implicit) Changelog: https://invisible-island.net/vile/CHANGES.html#v9_8u
Notes
Notes: svn path=/head/; revision=537120
Diffstat (limited to 'editors/xvile')
-rw-r--r--editors/xvile/Makefile6
-rw-r--r--editors/xvile/distinfo6
-rw-r--r--editors/xvile/files/patch-configure11
-rw-r--r--editors/xvile/files/patch-x11menu.c5
-rw-r--r--editors/xvile/files/patch-x11vile.h5
-rw-r--r--editors/xvile/pkg-plist62
6 files changed, 55 insertions, 40 deletions
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index ecf0fdcfed9c..05a9c92665b4 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vile
-PORTVERSION= 9.8t
+PORTVERSION= 9.8u
CATEGORIES= editors
MASTER_SITES= ftp://dickey.his.com/vile/current/ \
ftp://ftp.invisible-island.net/vile/current/ \
@@ -16,6 +16,7 @@ MAINTAINER= dickey@invisible-island.net
COMMENT= VI Like Emacs -- X11 version
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= reflex:textproc/reflex
@@ -80,9 +81,6 @@ post-patch:
s|$$(datadir)/html|$$(docdir)/html| ; \
s|\($$(DOCDIR)\) \($$(MANDIR)\)|\1 $$(HTMLDIR) \2|' \
${WRKSRC}/makefile.in
- @${REINPLACE_CMD} -e \
- '/^Categories/s|Application;||' \
- ${WRKSRC}/macros/*.desktop
post-install:
(cd ${WRKSRC}/macros && ${INSTALL_DATA} *.desktop \
diff --git a/editors/xvile/distinfo b/editors/xvile/distinfo
index 78b8880c0e2b..d715b66f6acd 100644
--- a/editors/xvile/distinfo
+++ b/editors/xvile/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546254826
-SHA256 (vile-9.8t.tgz) = 60b288432cfd32b7149c4cd662844e2694c5ab92bc469b282f33ded5110f6ded
-SIZE (vile-9.8t.tgz) = 2352119
+TIMESTAMP = 1589844782
+SHA256 (vile-9.8u.tgz) = 31a82833fe4fef5a60043bcc3278d1a875a1028b1b2577c9e0fa3a179cff165e
+SIZE (vile-9.8u.tgz) = 2375989
diff --git a/editors/xvile/files/patch-configure b/editors/xvile/files/patch-configure
new file mode 100644
index 000000000000..2629cabfd82b
--- /dev/null
+++ b/editors/xvile/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2020-03-29 21:46:05 UTC
++++ configure
+@@ -32100,7 +32100,7 @@ if test "x$CLANG_COMPILER" = "xyes"
+ then
+ { echo "$as_me:32101: WARNING: clang only pretends to honor gcc -rdynamic option" >&5
+ echo "$as_me: WARNING: clang only pretends to honor gcc -rdynamic option" >&2;}
+- cf_cv_gcc_opt_rdynamic=no
++ # cf_cv_gcc_opt_rdynamic=no
+ else
+
+ echo "$as_me:32106: checking if $CC has -rdynamic option" >&5
diff --git a/editors/xvile/files/patch-x11menu.c b/editors/xvile/files/patch-x11menu.c
index 9fb4adf1d89c..02e9e35fc407 100644
--- a/editors/xvile/files/patch-x11menu.c
+++ b/editors/xvile/files/patch-x11menu.c
@@ -1,6 +1,6 @@
--- x11menu.c.orig 2013-12-07 16:26:12 UTC
+++ x11menu.c
-@@ -29,12 +29,21 @@
+@@ -29,11 +29,20 @@
#endif
#if ATHENA_WIDGETS
@@ -17,8 +17,7 @@
#include <X11/Xaw/MenuButton.h>
#include <X11/Xaw/SmeLine.h>
#include <X11/Xaw/SmeBSB.h>
- #endif
+#endif
+ #endif
#define Nval(name,value) name, (XtArgVal)(value)
- #define Sval(name,value) name, (value)
diff --git a/editors/xvile/files/patch-x11vile.h b/editors/xvile/files/patch-x11vile.h
index 5209c5412cf5..602c3ededc52 100644
--- a/editors/xvile/files/patch-x11vile.h
+++ b/editors/xvile/files/patch-x11vile.h
@@ -1,6 +1,6 @@
--- x11vile.h.orig 2013-04-14 19:09:08 UTC
+++ x11vile.h
-@@ -282,11 +282,19 @@
+@@ -282,10 +282,18 @@
#if OPT_MENUS
#if ATHENA_WIDGETS
@@ -15,8 +15,7 @@
#include <X11/Xaw/Box.h>
#include <X11/Xaw/Form.h>
#include <X11/Xaw/Paned.h>
- #endif
+#endif
+ #endif
#if MOTIF_WIDGETS
#include <Xm/RowColumn.h>
- #endif
diff --git a/editors/xvile/pkg-plist b/editors/xvile/pkg-plist
index fd285a77c23c..429bee112568 100644
--- a/editors/xvile/pkg-plist
+++ b/editors/xvile/pkg-plist
@@ -54,9 +54,11 @@ lib/vile/vile-manfilt
lib/vile/vile-mcrl-filt%%SO_EXT%%
lib/vile/vile-midl-filt%%SO_EXT%%
lib/vile/vile-mms-filt%%SO_EXT%%
+lib/vile/vile-nmake-filt%%SO_EXT%%
lib/vile/vile-nr-filt%%SO_EXT%%
lib/vile/vile-pas-filt%%SO_EXT%%
lib/vile/vile-perl-filt%%SO_EXT%%
+lib/vile/vile-perl6-filt%%SO_EXT%%
lib/vile/vile-php-filt%%SO_EXT%%
lib/vile/vile-pot-filt%%SO_EXT%%
lib/vile/vile-ps-filt%%SO_EXT%%
@@ -82,6 +84,7 @@ lib/vile/vile-tc-filt%%SO_EXT%%
lib/vile/vile-tcl-filt%%SO_EXT%%
lib/vile/vile-texi-filt%%SO_EXT%%
lib/vile/vile-ti-filt%%SO_EXT%%
+lib/vile/vile-tpu-filt%%SO_EXT%%
lib/vile/vile-txt-filt%%SO_EXT%%
lib/vile/vile-vile-filt%%SO_EXT%%
lib/vile/vile-vlog-filt%%SO_EXT%%
@@ -157,6 +160,7 @@ share/pixmaps/vile.xpm
%%DATADIR%%/fdl.keywords
%%DATADIR%%/filters.rc
%%DATADIR%%/gnugpg.rc
+%%DATADIR%%/go.keywords
%%DATADIR%%/hs.keywords
%%DATADIR%%/html.keywords
%%DATADIR%%/imake.keywords
@@ -180,40 +184,15 @@ share/pixmaps/vile.xpm
%%DATADIR%%/midl.keywords
%%DATADIR%%/modes.rc
%%DATADIR%%/mvn.keywords
+%%DATADIR%%/nmake.keywords
%%DATADIR%%/nr.keywords
%%DATADIR%%/nsis.keywords
%%DATADIR%%/objc.keywords
%%DATADIR%%/palettes.rc
%%DATADIR%%/pas.keywords
%%DATADIR%%/pc.keywords
-%%DATADIR%%/rust.keywords
-%%DATADIR%%/vcproj.keywords
-%%DATADIR%%/vcxproj.keywords
-%%DATADIR%%/yaml.keywords
-%%PERL%%%%DATADIR%%/perl/Breadcrumbs.pm
-%%PERL%%%%DATADIR%%/perl/CaptHook.pm
-%%PERL%%%%DATADIR%%/perl/Glob2re.pm
-%%PERL%%%%DATADIR%%/perl/Help.pm
-%%PERL%%%%DATADIR%%/perl/Vile/Exporter.pm
-%%PERL%%%%DATADIR%%/perl/Vile/Manual.pm
-%%PERL%%%%DATADIR%%/perl/Vile.pm
-%%PERL%%%%DATADIR%%/perl/Vileserv.pm
-%%PERL%%%%DATADIR%%/perl/Visit.pm
-%%PERL%%%%DATADIR%%/perl/capture.pm
-%%PERL%%%%DATADIR%%/perl/dict.pm
-%%PERL%%%%DATADIR%%/perl/directory.pm
-%%PERL%%%%DATADIR%%/perl/dirlist.pm
-%%PERL%%%%DATADIR%%/perl/gdb.pm
-%%PERL%%%%DATADIR%%/perl/hgrep.pm
-%%PERL%%%%DATADIR%%/perl/lock.pm
-%%PERL%%%%DATADIR%%/perl/man.pm
-%%PERL%%%%DATADIR%%/perl/mime.pl
-%%PERL%%%%DATADIR%%/perl/plugins.pl
-%%PERL%%%%DATADIR%%/perl/search.pm
-%%PERL%%%%DATADIR%%/perl/shell.pm
-%%PERL%%%%DATADIR%%/perl/spell.pm
-%%PERL%%%%DATADIR%%/perl/winops.pm
%%DATADIR%%/perl.keywords
+%%DATADIR%%/perl6.keywords
%%DATADIR%%/php.keywords
%%DATADIR%%/pictmode.rc
%%DATADIR%%/pot.keywords
@@ -228,6 +207,7 @@ share/pixmaps/vile.xpm
%%DATADIR%%/rpm.keywords
%%DATADIR%%/rtf.keywords
%%DATADIR%%/ruby.keywords
+%%DATADIR%%/rust.keywords
%%DATADIR%%/sccs.keywords
%%DATADIR%%/scheme.keywords
%%DATADIR%%/search.rc
@@ -245,9 +225,13 @@ share/pixmaps/vile.xpm
%%DATADIR%%/tex.keywords
%%DATADIR%%/texi.keywords
%%DATADIR%%/ti.keywords
+%%DATADIR%%/tpu.keywords
+%%DATADIR%%/ts.keywords
%%DATADIR%%/vb.keywords
%%DATADIR%%/vb6.keywords
%%DATADIR%%/vbs.keywords
+%%DATADIR%%/vcproj.keywords
+%%DATADIR%%/vcxproj.keywords
%%DATADIR%%/vile.hlp
%%DATADIR%%/vile.keywords
%%DATADIR%%/vileinit.rc
@@ -263,4 +247,28 @@ share/pixmaps/vile.xpm
%%DATADIR%%/xs.keywords
%%DATADIR%%/xsl.keywords
%%DATADIR%%/yacc.keywords
+%%DATADIR%%/yaml.keywords
%%DATADIR%%/zsh.keywords
+%%PERL%%%%DATADIR%%/perl/Breadcrumbs.pm
+%%PERL%%%%DATADIR%%/perl/CaptHook.pm
+%%PERL%%%%DATADIR%%/perl/Glob2re.pm
+%%PERL%%%%DATADIR%%/perl/Help.pm
+%%PERL%%%%DATADIR%%/perl/Vile.pm
+%%PERL%%%%DATADIR%%/perl/Vile/Exporter.pm
+%%PERL%%%%DATADIR%%/perl/Vile/Manual.pm
+%%PERL%%%%DATADIR%%/perl/Vileserv.pm
+%%PERL%%%%DATADIR%%/perl/Visit.pm
+%%PERL%%%%DATADIR%%/perl/capture.pm
+%%PERL%%%%DATADIR%%/perl/dict.pm
+%%PERL%%%%DATADIR%%/perl/directory.pm
+%%PERL%%%%DATADIR%%/perl/dirlist.pm
+%%PERL%%%%DATADIR%%/perl/gdb.pm
+%%PERL%%%%DATADIR%%/perl/hgrep.pm
+%%PERL%%%%DATADIR%%/perl/lock.pm
+%%PERL%%%%DATADIR%%/perl/man.pm
+%%PERL%%%%DATADIR%%/perl/mime.pl
+%%PERL%%%%DATADIR%%/perl/plugins.pl
+%%PERL%%%%DATADIR%%/perl/search.pm
+%%PERL%%%%DATADIR%%/perl/shell.pm
+%%PERL%%%%DATADIR%%/perl/spell.pm
+%%PERL%%%%DATADIR%%/perl/winops.pm