aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-10-18 07:18:33 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-10-18 07:18:33 +0000
commit092a9a3d11218667d7bd5427aad7cb57eda53a24 (patch)
tree98f28049a84b400cab261c085de02249d8c57601 /editors
parent3e0febf33b30ad03820d7c1b19223eb98a35fc80 (diff)
downloadports-092a9a3d11218667d7bd5427aad7cb57eda53a24.tar.gz
ports-092a9a3d11218667d7bd5427aad7cb57eda53a24.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit-plugins/Makefile1
-rw-r--r--editors/gedit-plugins/files/patch-plugins::diff::diff.c30
2 files changed, 31 insertions, 0 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 3766b80b5c5b..378365ac58b7 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gedit-plugins
PORTVERSION= 2.3.5
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.3
diff --git a/editors/gedit-plugins/files/patch-plugins::diff::diff.c b/editors/gedit-plugins/files/patch-plugins::diff::diff.c
new file mode 100644
index 000000000000..6a2c8f1146c6
--- /dev/null
+++ b/editors/gedit-plugins/files/patch-plugins::diff::diff.c
@@ -0,0 +1,30 @@
+--- plugins/diff/diff.c.orig Sat Oct 18 16:02:21 2003
++++ plugins/diff/diff.c Sat Oct 18 16:05:51 2003
+@@ -56,7 +56,6 @@
+ #include <gedit/gedit-mdi.h>
+ #include <gedit/gedit-output-window.h>
+
+-
+ #define DIFF_BASE_KEY "/apps/gedit-2/plugins/diff"
+ #define DIFF_LOCATION_KEY "/diff-program-location"
+ #define UNIFIED_FORMAT_KEY "/use-unified-format"
+@@ -438,7 +437,7 @@
+
+ case GTK_RESPONSE_HELP:
+ /* FIXME: choose a better link id */
+- gnome_help_display ("gedit.xml", "gedit-use-plugins", &error);
++ gnome_help_display ("gedit.xml", "gedit-compare-files-plugin", &error);
+
+ if (error != NULL)
+ {
+@@ -959,7 +958,9 @@
+
+ temp = gedit_plugin_locate_program (DIFF_PROGRAM_NAME,
+ plugin_name,
+- parent);
++ parent,
++ DIFF_BASE_KEY DIFF_LOCATION_KEY,
++ "gedit-compare-files-configure");
+
+ if (temp != NULL)
+ {