aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-06-24 15:23:56 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-06-24 15:23:56 +0000
commit0b807d701e7d7ec656a5ed93864ddfc6d725d18c (patch)
tree5e0e4387bd571251c5086d46aef60780b8350a6f /editors
parente1e4af98b860400edad9f08552e5d826d497e4e4 (diff)
downloadports-0b807d701e7d7ec656a5ed93864ddfc6d725d18c.tar.gz
ports-0b807d701e7d7ec656a5ed93864ddfc6d725d18c.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/lazarus/Makefile91
1 files changed, 2 insertions, 89 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 75a898f7bfaf..e37167446108 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lazarus
PORTVERSION= 0.9.24
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors devel
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S/$/-0/}
@@ -16,91 +16,19 @@ DIST_SUBDIR= freepascal
MAINTAINER= acm@FreeBSD.org
COMMENT= A portable Delphi-like IDE for the FreePascal compiler
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- fpcmake:${PORTSDIR}/lang/fpc-utils
-
ONLY_FOR_ARCHS= i386
USE_ICONV= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= #
+WANT_FPC_ALL= yes
MAKE_ENV= OPT="-Sgic -Fu${UNITSDIR}/* -Fl${LOCALBASE}/lib" LCL_PLATFORM=${LCL_PLATFORM}
MAN1= lazbuild.1
PLIST= ${WRKDIR}/pkg-plist
WRKSRC= ${WRKDIR}/${PORTNAME}
-BUILDNAME= ${ARCH}-freebsd
-FPC_MINVER= 2.2.0
-UNITSDIR= ${LOCALBASE}/lib/fpc/${FPC_MINVER}/units/${BUILDNAME}
-BASE_UNITS= GDBINT GRAPH IBASE LIBASYNC HASH HTTPD MYSQL NETDB ODBC ORACLE \
- PASJPEG PASZLIB PTHREADS POSTGRES REGEXPR SQLITE
-ALL_UNITS= ${BASE_UNITS} BFD CAIRO FCL-BASE FCL-DB FCL-FPCUNIT FCL-IMAGE \
- FCL-NET FCL-PASSRC FCL-REGISTRY FCL-WEB FCL-XML FFTW FPMKUNIT \
- FORMS FPGTK FV GCONF GDBM GGI GNOME GTK GTK2 IMLIB LIBCURL \
- LIBGD LIBPNG NCURSES OPENGL OPENSSL PCAP SVGALIB SYSLOG TCL \
- UNZIP UTMP X11 ZLIB ZVT
-
-# Base units
-GDBINT_UNIT= devel/fpc-gdbint
-GRAPH_UNIT= graphics/fpc-graph
-IBASE_UNIT= databases/fpc-ibase
-LIBASYNC_UNIT= net/fpc-libasync
-HASH_UNIT= security/fpc-hash
-HTTPD_UNIT= www/fpc-httpd
-MYSQL_UNIT= databases/fpc-mysql
-NETDB_UNIT= net/fpc-netdb
-ODBC_UNIT= databases/fpc-odbc
-ORACLE_UNIT= databases/fpc-oracle
-PASJPEG_UNIT= graphics/fpc-pasjpeg
-PASZLIB_UNIT= archivers/fpc-paszlib
-PTHREADS_UNIT= devel/fpc-pthreads
-POSTGRES_UNIT= databases/fpc-postgres
-REGEXPR_UNIT= devel/fpc-regexpr
-SQLITE_UNIT= databases/fpc-sqlite
-
-# Extra units
-BFD_UNIT= devel/fpc-bfd
-CAIRO_UNIT= graphics/fpc-cairo
-FCL_BASE_UNIT= devel/fpc-fcl-base
-FCL_DB_UNIT= devel/fpc-fcl-db
-FCL_FPCUNIT_UNIT= devel/fpc-fcl-fpcunit
-FCL_IMAGE_UNIT= devel/fpc-fcl-image
-FCL_NET_UNIT= devel/fpc-fcl-net
-FCL_PASSRC_UNIT= devel/fpc-fcl-passrc
-FCL_REGISTRY_UNIT= devel/fpc-fcl-registry
-FCL_WEB_UNIT= devel/fpc-fcl-web
-FCL_XML_UNIT= devel/fpc-fcl-xml
-FFTW_UNIT= math/fpc-fftw
-FPMKUNIT_UNIT= devel/fpc-fpmkunit
-FORMS_UNIT= x11-toolkits/fpc-forms
-FPGTK_UNIT= graphics/fpc-fpgtk
-FV_UNIT= devel/fpc-fv
-GCONF_UNIT= devel/fpc-gconf
-GDBM_UNIT= databases/fpc-gdbm
-GGI_UNIT= graphics/fpc-ggi
-GNOME_UNIT= x11-toolkits/fpc-gnome
-GTK_UNIT= x11-toolkits/fpc-gtk
-GTK2_UNIT= x11-toolkits/fpc-gtk2
-HTTPD_UNIT= www/fpc-httpd
-IMLIB_UNIT= graphics/fpc-imlib
-LIBCURL_UNIT= ftp/fpc-libcurl
-LIBGD_UNIT= graphics/fpc-libgd
-LIBPNG_UNIT= graphics/fpc-libpng
-NCURSES_UNIT= graphics/fpc-ncurses
-OPENGL_UNIT= graphics/fpc-opengl
-OPENSSL_UNIT= security/fpc-openssl
-PCAP_UNIT= net/fpc-pcap
-SVGALIB_UNIT= graphics/fpc-svgalib
-SYSLOG_UNIT= sysutils/fpc-syslog
-TCL_UNIT= lang/fpc-tcl
-UNZIP_UNIT= archivers/fpc-unzip
-UTMP_UNIT= sysutils/fpc-utmp
-X11_UNIT= x11/fpc-x11
-ZLIB_UNIT= devel/fpc-zlib
-ZVT_UNIT= x11-toolkits/fpc-zvt
-
OPTIONS= GTK2 "Use gtk20 interface instead of gtk12" off \
BIGIDE "Compile additional components" off
@@ -118,21 +46,6 @@ LCL_PLATFORM= gtk
LAZARUS_TARGET= bigide lazbuilder
.endif
-.for OPTUNIT in ${ALL_UNITS}
-BUILD_DEPENDS+= ${UNITSDIR}/${OPTUNIT:L:S/httpd/httpd-1.3/}/Package.fpc:${PORTSDIR}/${${OPTUNIT:S/-/_/}_UNIT}
-.endfor
-
-post-depends:
-.if exists(${LOCALBASE}/bin/fpc)
-FPC_VER!= ${LOCALBASE}/bin/fpc -i -v | ${SED} -n -e 's/^Free Pascal Compiler version //' -e '1p'
-FPC_DIR= ${LOCALBASE}/lib/fpc/${FPC_VER}
-FPC_REQVER!= ${ECHO_CMD} $$(expr ${FPC_VER:C/^[^\.]*\.//} \>= ${FPC_MINVER:C/^[^\.]*\.//})
-
-.if (${FPC_REQVER} != 1)
-IGNORE= requires fpc ${FPC_MINVER} or above. Please upgrade
-.endif
-.endif
-
post-extract:
@${MKDIR} ${WRKDIR}/man1
@${MV} ${WRKSRC}/docs/lazbuild.1 ${WRKDIR}/man1