aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-08-03 19:16:15 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-08-03 19:16:15 +0000
commit1772ed437eecfdfd52db4f73481fafad52a85810 (patch)
tree2f152febac4f6b0bf22c6c1e90f3711269cb485e /editors
parent60d0d9867a9f313f0f4c1bee646315c7c7519054 (diff)
downloadports-1772ed437eecfdfd52db4f73481fafad52a85810.tar.gz
ports-1772ed437eecfdfd52db4f73481fafad52a85810.zip
A better way to respect $CC.
Notes
Notes: svn path=/head/; revision=115356
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile1
-rw-r--r--editors/vim/files/patch-019
2 files changed, 9 insertions, 1 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 8fd5d5737434..cb144c1d9ba5 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -42,7 +42,6 @@ WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}/src
PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --batch --forward --quiet -E ${PATCH_DIST_STRIP}
# consider
#PATCH_DIST_ARGS= -t
-MAKE_ARGS+= CC="${CC}"
MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib ${CSCOPE_ARG}"
ALL_TARGET= #
_DATADIR= ${DISTNAME:S/-//g:S/.//g}
diff --git a/editors/vim/files/patch-01 b/editors/vim/files/patch-01
index 8075cb77b31a..b0da2e79e2e4 100644
--- a/editors/vim/files/patch-01
+++ b/editors/vim/files/patch-01
@@ -1,5 +1,14 @@
--- Makefile.orig Sun Jun 1 06:18:29 2003
+++ Makefile Sat Nov 1 15:39:09 2003
+@@ -256,7 +256,7 @@
+ #DO NOT CHANGE the next line, we need it for configure to find the compiler
+ #instead of using the default from the "make" program.
+ #Use a line further down to change the value for CC.
+-CC=
++#CC=
+
+ # Change and use these defines if configure cannot find your Motif stuff.
+ # Unfortunately there is no "standard" location for Motif. {{{
@@ -288,6 +288,7 @@
# of make, will buid Vim.