aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-01-10 08:15:44 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-01-10 08:16:01 +0000
commit1b819e486953bae191a4b8f0da175b55cb6c3070 (patch)
treea9eaa8ecd25eb764dc4e27a877027d0df0a52ac1 /editors
parenteadd5953495b96817fa81d9e0465583108ab227b (diff)
downloadports-1b819e486953bae191a4b8f0da175b55cb6c3070.tar.gz
ports-1b819e486953bae191a4b8f0da175b55cb6c3070.zip
Diffstat (limited to 'editors')
-rw-r--r--editors/chexedit/Makefile2
-rw-r--r--editors/hnb/Makefile5
-rw-r--r--editors/jedit/Makefile3
-rw-r--r--editors/jedit/pkg-plist2
-rw-r--r--editors/lazarus-devel/Makefile5
-rw-r--r--editors/lazarus/Makefile6
-rw-r--r--editors/le/Makefile2
-rw-r--r--editors/nvi2/Makefile13
-rw-r--r--editors/vim/Makefile2
9 files changed, 22 insertions, 18 deletions
diff --git a/editors/chexedit/Makefile b/editors/chexedit/Makefile
index 93fdc0552b0f..98b8b8757bdb 100644
--- a/editors/chexedit/Makefile
+++ b/editors/chexedit/Makefile
@@ -24,6 +24,6 @@ CFLAGS+= -fcommon
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/hexedit ${STAGEDIR}${PREFIX}/bin/chexedit
- ${INSTALL_MAN} ${WRKSRC}/docs/hexedit.1 ${STAGEDIR}${MAN1PREFIX}/share/man/man1/chexedit.1
+ ${INSTALL_MAN} ${WRKSRC}/docs/hexedit.1 ${STAGEDIR}${PREFIX}/share/man/man1/chexedit.1
.include <bsd.port.mk>
diff --git a/editors/hnb/Makefile b/editors/hnb/Makefile
index 4c33da92e283..d12cf45760ee 100644
--- a/editors/hnb/Makefile
+++ b/editors/hnb/Makefile
@@ -1,5 +1,6 @@
PORTNAME= hnb
PORTVERSION= 1.9.18
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -18,7 +19,7 @@ GH_ACCOUNT= fraggerfox
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME} \
- man/man1/${PORTNAME}.1.gz
+ share/man/man1/${PORTNAME}.1.gz
PORTDOCS= *
PORTEXAMPLES= *
@@ -26,7 +27,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/hnb ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/hnb.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/hnb.1 ${STAGEDIR}${PREFIX}/share/man/man1
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/editors/jedit/Makefile b/editors/jedit/Makefile
index 1f22e23bb6fd..4042c40079a7 100644
--- a/editors/jedit/Makefile
+++ b/editors/jedit/Makefile
@@ -1,5 +1,6 @@
PORTNAME= jedit
PORTVERSION= 5.6.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= editors java
MASTER_SITES= SF
@@ -50,6 +51,6 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/jedit.sh ${STAGEDIR}${PREFIX}/bin/jedit
${INSTALL_DATA} ${STAGEDIR}${DATADIR}/doc/jedit.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
- ${INSTALL_MAN} ${WRKDIR}/jedit.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/jedit.1 ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/editors/jedit/pkg-plist b/editors/jedit/pkg-plist
index c95b93949ddf..bb6308dcf0f1 100644
--- a/editors/jedit/pkg-plist
+++ b/editors/jedit/pkg-plist
@@ -1,5 +1,5 @@
bin/jedit
-man/man1/jedit.1.gz
+share/man/man1/jedit.1.gz
share/java/jedit/jars/QuickNotepad.jar
share/java/jedit/jedit.jar
share/java/jedit/keymaps/Alan_keys.props
diff --git a/editors/lazarus-devel/Makefile b/editors/lazarus-devel/Makefile
index d039ed6176c4..8d1cdae94f3f 100644
--- a/editors/lazarus-devel/Makefile
+++ b/editors/lazarus-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= lazarus
DISTVERSION= 3.1.0.20231222
+PORTREVISION= 1
PKGNAMESUFFIX?= -gtk2-devel
PORTREVISION?= 0
CATEGORIES= editors devel
@@ -98,7 +99,7 @@ pre-install:
@${ECHO_CMD} ${FILE} >> ${PLIST}
. endfor
. for m in ${MAN1S}
- @${ECHO_CMD} man/man1/${m}.gz >> ${PLIST}
+ @${ECHO_CMD} share/man/man1/${m}.gz >> ${PLIST}
. endfor
@${ECHO_CMD} "%%DATADIR%%/docs" >> ${PLIST}
@@ -172,7 +173,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/lazarus-wrapper ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/Makefile* ${WRKSRC}/fpmake* ${STAGEDIR}${DATADIR}
.for FILE in ${MAN1S}
- ${INSTALL_MAN} ${WRKDIR}/man1/${FILE} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/man1/${FILE} ${STAGEDIR}${PREFIX}/share/man/man1
.endfor
${LN} -sf ${DATADIR}/lazbuild ${STAGEDIR}${PREFIX}/bin/lazbuild
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 78b89d082342..9541be4b1d0d 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -1,7 +1,7 @@
PORTNAME= lazarus
DISTVERSION= 3.0.0
PKGNAMESUFFIX?= -gtk2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= editors devel
DIST_SUBDIR= freepascal
@@ -100,7 +100,7 @@ pre-install:
@${ECHO_CMD} ${FILE} >> ${PLIST}
. endfor
. for m in ${MAN1S}
- @${ECHO_CMD} man/man1/${m}.gz >> ${PLIST}
+ @${ECHO_CMD} share/man/man1/${m}.gz >> ${PLIST}
. endfor
@${ECHO_CMD} "%%DATADIR%%/docs" >> ${PLIST}
@@ -174,7 +174,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/lazarus-wrapper ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/Makefile* ${WRKSRC}/fpmake* ${STAGEDIR}${DATADIR}
.for FILE in ${MAN1S}
- ${INSTALL_MAN} ${WRKDIR}/man1/${FILE} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/man1/${FILE} ${STAGEDIR}${PREFIX}/share/man/man1
.endfor
${LN} -sf ${DATADIR}/lazbuild ${STAGEDIR}${PREFIX}/bin/lazbuild
diff --git a/editors/le/Makefile b/editors/le/Makefile
index c2b2c65d5bd5..7c9babade19d 100644
--- a/editors/le/Makefile
+++ b/editors/le/Makefile
@@ -21,7 +21,7 @@ MAKE_JOBS_UNSAFE= yes
derp-do-install:
@${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/src && ${INSTALL_PROGRAM} le ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/doc && ${INSTALL_MAN} le.1 ${STAGEDIR}${MAN1PREFIX}/man/man1)
+ (cd ${WRKSRC}/doc && ${INSTALL_MAN} le.1 ${STAGEDIR}${PREFIX}/man/man1)
.for file in ${STAGEDIR}${MISC_DATA}
(cd ${WRKSRC}/misc && ${INSTALL_DATA} ${file} ${STAGEDIR}${DATADIR})
.endfor
diff --git a/editors/nvi2/Makefile b/editors/nvi2/Makefile
index d680a3b65e6a..462c8fe293f9 100644
--- a/editors/nvi2/Makefile
+++ b/editors/nvi2/Makefile
@@ -1,5 +1,6 @@
PORTNAME= nvi2
PORTVERSION= 2.2.1
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -30,9 +31,9 @@ WIDECHAR_CMAKE_BOOL= ENABLE_WIDECHAR
PLIST_FILES= bin/nex \
bin/nvi \
bin/nview \
- man/man1/nex.1.gz \
- man/man1/nvi.1.gz \
- man/man1/nview.1.gz
+ share/man/man1/nex.1.gz \
+ share/man/man1/nvi.1.gz \
+ share/man/man1/nview.1.gz
post-patch:
${REINPLACE_CMD} -e \
@@ -44,8 +45,8 @@ do-install:
${LN} ${STAGEDIR}${PREFIX}/bin/nvi ${STAGEDIR}${PREFIX}/bin/nex
${LN} ${STAGEDIR}${PREFIX}/bin/nvi ${STAGEDIR}${PREFIX}/bin/nview
${INSTALL_MAN} ${WRKSRC}/man/vi.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1/nvi.1
- ${LN} -sf nvi.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/nex.1
- ${LN} -sf nvi.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/nview.1
+ ${STAGEDIR}${PREFIX}/share/man/man1/nvi.1
+ ${LN} -sf nvi.1 ${STAGEDIR}${PREFIX}/share/man/man1/nex.1
+ ${LN} -sf nvi.1 ${STAGEDIR}${PREFIX}/share/man/man1/nview.1
.include <bsd.port.mk>
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 7f50e5c22107..cab527cfb476 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -183,7 +183,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/vim ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/runtime/defaults.vim ${STAGEDIR}${DATADIR}/${VIM_VER}
${INSTALL_DATA} ${FILESDIR}/defaults_freebsd.vim ${STAGEDIR}${DATADIR}/${VIM_VER}
- ${INSTALL_MAN} ${WRKSRC}/runtime/doc/vim.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/runtime/doc/vim.1 ${STAGEDIR}${PREFIX}/man/man1
.else # flavor != tiny
post-install: