aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2019-02-05 17:46:03 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2019-02-05 17:46:03 +0000
commit32aaea1ed3a3e9f9aee34631825198edb72e506b (patch)
tree933b6aa7ad0b664e32366ea85ffcb7e453b7447b /editors
parentd565b27163db6960fd811304b42d78b8278418ea (diff)
downloadports-32aaea1ed3a3e9f9aee34631825198edb72e506b.tar.gz
ports-32aaea1ed3a3e9f9aee34631825198edb72e506b.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice/files/patch-powerpc (renamed from editors/libreoffice/files/patch-powerpc64)61
2 files changed, 54 insertions, 9 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index f94a94fe0794..4c1ee2a9d260 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -279,6 +279,8 @@ CXXFLAGS_WARN= -Woverloaded-virtual -Wno-unused-parameter -Wno-unused-local-type
CXXFLAGS_WARN= -Wshadow -Woverloaded-virtual
.endif
+CXXFLAGS_powerpcspe= -D__NO_FPRS
+
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/shell/source/unix/exec/shellexec.cxx
diff --git a/editors/libreoffice/files/patch-powerpc64 b/editors/libreoffice/files/patch-powerpc
index 5cf86c6f7599..dca40d1a03b8 100644
--- a/editors/libreoffice/files/patch-powerpc64
+++ b/editors/libreoffice/files/patch-powerpc
@@ -1,20 +1,25 @@
---- configure.ac.orig
-+++ configure.ac
-@@ -4189,6 +4189,11 @@
- CPUNAME=X86_64
+--- configure.ac.old 2018-12-30 15:36:04.692353000 -0600
++++ configure.ac 2018-12-30 15:37:39.225930000 -0600
+@@ -3981,6 +3981,16 @@
RTL_ARCH=X86_64
PLATFORMID=freebsd_x86_64
-+ ;;
+ ;;
+ powerpc64)
+ CPUNAME=POWERPC64
+ RTL_ARCH=PowerPC_64
+ PLATFORMID=freebsd_powerpc64
- ;;
++ ;;
++ powerpc|powerpcspe)
++ CPUNAME=POWERPC
++ RTL_ARCH=PowerPC
++ PLATFORMID=freebsd_powerpc
++ ;;
*)
AC_MSG_ERROR([Unsupported host_cpu $host_cpu for host_os $host_os])
---- configure.orig
-+++ configure
-@@ -10936,6 +10936,11 @@
+ ;;
+--- configure.old 2018-12-30 15:33:12.582597000 -0600
++++ configure 2018-12-30 15:35:48.424447000 -0600
+@@ -11511,6 +11511,16 @@
RTL_ARCH=X86_64
PLATFORMID=freebsd_x86_64
;;
@@ -23,9 +28,28 @@
+ RTL_ARCH=PowerPC_64
+ PLATFORMID=freebsd_powerpc64
+ ;;
++ powerpc|powerpcspe)
++ CPUNAME=POWERPC
++ RTL_ARCH=PowerPC
++ PLATFORMID=freebsd_powerpc
++ ;;
*)
as_fn_error $? "Unsupported host_cpu $host_cpu for host_os $host_os" "$LINENO" 5
;;
+--- bridges/source/cpp_uno/gcc3_linux_powerpc/uno2cpp.cxx.orig
++++ bridges/source/cpp_uno/gcc3_linux_powerpc/uno2cpp.cxx
+@@ -18,7 +18,11 @@
+ */
+
+
++#if defined (FREEBSD) || defined(NETBSD) || defined(OPENBSD) || defined(DRAGONFLY)
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+
+ #include <com/sun/star/uno/genfunc.hxx>
+ #include <uno/data.h>
--- bridges/source/cpp_uno/gcc3_linux_powerpc64/uno2cpp.cxx.orig
+++ bridges/source/cpp_uno/gcc3_linux_powerpc64/uno2cpp.cxx
@@ -18,7 +18,11 @@
@@ -57,6 +81,25 @@
# endif
#elif defined AIX
--- /dev/null
++++ solenv/gbuild/platform/FREEBSD_POWERPC_GCC.mk
+@@ -0,0 +1,16 @@
++# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
++#
++# This file is part of the LibreOffice project.
++#
++# This Source Code Form is subject to the terms of the Mozilla Public
++# License, v. 2.0. If a copy of the MPL was not distributed with this
++# file, You can obtain one at http://mozilla.org/MPL/2.0/.
++#
++
++#please make generic modifications to unxgcc.mk or linux.mk
++gb_CPUDEFS += -DPPC -DPOWERPC
++gb_COMPILERDEFAULTOPTFLAGS := -O2
++
++include $(GBUILDDIR)/platform/unxgcc.mk
++
++# vim: set noet sw=4:
+--- /dev/null
+++ solenv/gbuild/platform/FREEBSD_POWERPC64_GCC.mk
@@ -0,0 +1,17 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-