aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 06:49:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 06:49:35 +0000
commit4ab73fde6eb5fc46fecfc39aec07fdcefbeff324 (patch)
tree3b8d48aa271eba0bfcc38ae208c7dc331ca94217 /editors
parent8b330db9e10e1e3e9b78358da8c509d0586697b6 (diff)
downloadports-4ab73fde6eb5fc46fecfc39aec07fdcefbeff324.tar.gz
ports-4ab73fde6eb5fc46fecfc39aec07fdcefbeff324.zip
Convert from USE_MOTIF to USES=motif
Notes
Notes: svn path=/head/; revision=322620
Diffstat (limited to 'editors')
-rw-r--r--editors/asedit/Makefile3
-rw-r--r--editors/emacs-devel/Makefile2
-rw-r--r--editors/emacs/Makefile5
-rw-r--r--editors/emacs23/Makefile2
-rw-r--r--editors/nedit/Makefile10
-rw-r--r--editors/ted/Makefile2
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/xemacs-devel-mule/Makefile6
-rw-r--r--editors/xemacs-devel/Makefile12
-rw-r--r--editors/xemacs/Makefile6
-rw-r--r--editors/xemacs21-mule/Makefile6
-rw-r--r--editors/xvile/Makefile2
12 files changed, 25 insertions, 33 deletions
diff --git a/editors/asedit/Makefile b/editors/asedit/Makefile
index 888d9fbd12f4..85b69bf2ce73 100644
--- a/editors/asedit/Makefile
+++ b/editors/asedit/Makefile
@@ -12,8 +12,7 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Text editor for X/Motif
-USES= imake
-USE_MOTIF= yes
+USES= imake motif
USE_XORG= ice sm x11 xext xmu xp xt
XMKMF= xmkmf
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index d510acd093a9..bfed3fb7c7fd 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -105,7 +105,7 @@ CONFIGURE_ARGS+= --with-x-toolkit=athena
USE_XORG= xaw
CONFIGURE_ARGS+= --with-x-toolkit=athena --without-xaw3d
.elif ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
CONFIGURE_ARGS+= --with-x-toolkit=motif
.endif
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 5df92d86ceb9..6bb568ea41a7 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -22,8 +22,7 @@ CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
EMACS_VER= 24.3
GNU_CONFIGURE= yes
-USES= ncurses
-USE_GMAKE= yes
+USES= ncurses gmake
USE_XZ= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -113,7 +112,7 @@ CONFIGURE_ARGS+= --with-x-toolkit=athena
USE_XORG= xaw
CONFIGURE_ARGS+= --with-x-toolkit=athena --without-xaw3d
.elif ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
CONFIGURE_ARGS+= --with-x-toolkit=motif
.endif
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 194b068e0708..923f178aa252 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -98,7 +98,7 @@ CONFIGURE_ARGS+= --with-x-toolkit=athena
USE_XORG= xaw
CONFIGURE_ARGS+= --with-x-toolkit=athena --without-xaw3d
.elif ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
CONFIGURE_ARGS+= --with-x-toolkit=motif
.endif
diff --git a/editors/nedit/Makefile b/editors/nedit/Makefile
index 346076aee2a6..5eeb2e2e08ac 100644
--- a/editors/nedit/Makefile
+++ b/editors/nedit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nedit
-# Date created: 7 April 1996
-# Whom: Daniel Eischen <deischen@freebsd.org>
-#
+# Created by: Daniel Eischen <deischen@freebsd.org>
# $FreeBSD$
-#
PORTNAME= nedit
PORTVERSION= 5.5
@@ -23,11 +19,11 @@ DISTFILES= nedit-5.5-src.tar.bz2 nedit.app-defaults
EXTRACT_ONLY= nedit-5.5-src.tar.bz2
MAINTAINER= deischen@FreeBSD.org
-COMMENT= An X11/Motif GUI text editor for programs and plain text files
+COMMENT= X11/Motif GUI text editor for programs and plain text files
LICENSE= GPLv1
+USES= motif
USE_BZIP2= yes
-USE_MOTIF= yes
USE_XORG= xpm
MAN1= nclient.1 nedit.1
ALL_TARGET= freebsd
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index f5add35fa439..67e0f96682d1 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -50,7 +50,7 @@ INDDIR= ${DATADIR}/dfa
USE_GNOME= gtk20
CONFIGURE_ARGS+=--with-GTK
.else
-USE_MOTIF= yes
+USES+= motif
CONFIGURE_ARGS+=--with-MOTIF
.endif
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 61043b071053..0d631fba5981 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -160,7 +160,7 @@ USE_XORG+= xt glproto
. endif
. if ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\""
MAKE_ARGS+= MOTIFHOME=${LOCALBASE}
. endif
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index 244c49669f1d..62762855bcca 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -120,7 +120,7 @@ PKGDIR= ${.CURDIR}/../../editors/xemacs-devel-mule
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} >= 900000
BROKEN= does not build on FreeBSD 9.X
@@ -145,7 +145,7 @@ CONFIGURE_ARGS+= --with-x11=no
@${ECHO_MSG} "which will force the use of athena widgets for dialogs."
.endif
CONFIGURE_ARGS+=--with-jpeg=yes --with-png=yes --with-tiff=yes --with-xface=yes
-USE_MOTIF= yes
+USES= motif
# hack to avoid shipping binaries linked with Motif
.if defined(MOTIF_STATIC)
@@ -259,4 +259,4 @@ post-install:
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index ca1a34a4b2be..9093786853a3 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: X-Emacs
-# Date created: 25 Oct 2001
-# Whom: Gary Jennejohn (gj@FreeBSD.org)
-#
+# Created by: Gary Jennejohn <gj@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xemacs-devel
PORTVERSION= ${XEMACS_VER:S/-/./}
@@ -79,10 +75,10 @@ ALL_TARGET= all dist
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libXm.so)
-USE_MOTIF= yes
+USES+= motif
HAVE_MOTIF= yes
.endif
@@ -157,4 +153,4 @@ post-install::
# @${ECHO_MSG} "to ${PORTNAME}${PKGNAMESUFFIX}-${XEMACS_VER}."
#.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index 7d8dbfcaa7df..3ea9d247e7fa 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -60,7 +60,7 @@ ALL_TARGET= all dist
PLIST_SUB+= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Undump and malloc do not behave on amd64 at the moment
.if ${ARCH} == amd64
@@ -95,7 +95,7 @@ CONFIGURE_ARGS+= --with-png --with-jpeg --with-tiff
USE_XORG= xpm x11 xbitmaps xaw
CFLAGS+= -I${LOCALBASE}/include/libpng15
.if !defined(WITHOUT_MOTIF) && !defined(MOTIF_STATIC)
-USE_MOTIF= yes
+USES+= motif
WITH_SCROLLBARS= --with-scrollbars=motif
WITH_DIALOGS= --with-dialogs=motif
WITH_WIDGETS= --with-widgets=motif
@@ -113,6 +113,8 @@ CONFIGURE_ARGS+= --with-athena=3d
CONFIGURE_ARGS+= --without-x11
.endif
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_X11) && ${HAVE_GNOME:Mgnomehier}!=""
USE_GNOME+= gnomehier
PLIST_SUB+= DESKTOP=""
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index c97100a666cf..660ba9478a44 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -90,7 +90,7 @@ PKGDIR= ${.CURDIR}/../../editors/xemacs21-mule
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Undump and malloc do not behave on amd64 at the moment
.if ${ARCH} == "amd64"
@@ -112,7 +112,7 @@ pre-fetch:
@${ECHO_MSG} "In this case, set the environment variable MOTIF_STATIC and recompile, "
@${ECHO_MSG} "which will force the use of athena widgets for dialogs."
.endif
-USE_MOTIF= yes
+USES+= motif
# hack to avoid shipping binaries linked with Motif
.if defined(MOTIF_STATIC)
@@ -215,4 +215,4 @@ post-install::
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index 1765780ab1fa..6f5bf03b67b0 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -74,7 +74,7 @@ CONFIGURE_ARGS+= --with-screen=x11
.endif
.if ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
CONFIGURE_ARGS+= --with-screen=motif
.endif