aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2021-04-12 18:34:22 +0000
committerJason E. Hale <jhale@FreeBSD.org>2021-04-12 19:36:26 +0000
commit6ba4287ee0dcfbc1db119e672dc0936511db665b (patch)
treeeba659a8cda38600737aaf538ede379635cbfd2e /editors
parenta4e10bc5c02f54ea28c3050aa4f6ff46adc60227 (diff)
downloadports-6ba4287ee0dcfbc1db119e672dc0936511db665b.tar.gz
ports-6ba4287ee0dcfbc1db119e672dc0936511db665b.zip
editors/mp: Update to 5.48
Diffstat (limited to 'editors')
-rw-r--r--editors/mp/Makefile2
-rw-r--r--editors/mp/distinfo6
-rw-r--r--editors/mp/files/patch-mpv__qt4.cpp13
3 files changed, 17 insertions, 4 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index e59f1b0ef25e..3dd460a8a7e8 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -1,7 +1,7 @@
# Created by: Mark Pulford <mark@kyne.com.au>
PORTNAME= mp
-DISTVERSION= 5.47
+DISTVERSION= 5.48
CATEGORIES= editors
MAINTAINER= jhale@FreeBSD.org
diff --git a/editors/mp/distinfo b/editors/mp/distinfo
index 3a260a7242bd..b6c752f63f58 100644
--- a/editors/mp/distinfo
+++ b/editors/mp/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1615814934
-SHA256 (ttcdt-mp-5.x-5.47_GH0.tar.gz) = cb2d209141ed30801b273bf49310863a9f5c546ba75a6a4320a98f5bad88b215
-SIZE (ttcdt-mp-5.x-5.47_GH0.tar.gz) = 235276
+TIMESTAMP = 1617739645
+SHA256 (ttcdt-mp-5.x-5.48_GH0.tar.gz) = ff0ceb44b47a99ebdf41656b92c425d1c69d7ebdd4b5f4bf006125b78b07856f
+SIZE (ttcdt-mp-5.x-5.48_GH0.tar.gz) = 229335
SHA256 (ttcdt-mpdm-2.72_GH0.tar.gz) = eca91ca7549cab93931a806c7434fff9efa122f29ba787c670ab25fec24ecfbf
SIZE (ttcdt-mpdm-2.72_GH0.tar.gz) = 144909
SHA256 (ttcdt-mpsl-2.62_GH0.tar.gz) = 3e12bbbb8504bc9ebba31a5753c60e5280a1d7d9f3f0d5199ff0f1f3f241879a
diff --git a/editors/mp/files/patch-mpv__qt4.cpp b/editors/mp/files/patch-mpv__qt4.cpp
new file mode 100644
index 000000000000..e8ef3659ce85
--- /dev/null
+++ b/editors/mp/files/patch-mpv__qt4.cpp
@@ -0,0 +1,13 @@
+Fix forgotten renamed variable.
+
+--- mpv_qt4.cpp.orig 2021-04-06 20:21:29 UTC
++++ mpv_qt4.cpp
+@@ -518,7 +518,7 @@ static mpdm_t qt4_drv_idle(mpdm_t a, mpdm_t ctxt)
+
+ window->area->timer->stop();
+
+- if (msecs)
++ if (idle_msecs)
+ window->area->timer->start(idle_msecs);
+
+ return NULL;