aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-02-17 15:06:12 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-02-17 15:06:12 +0000
commit7406bd2ea1fde3c301342a4dabe895fdc3d49e28 (patch)
treed9671d30608b7e4bc7b498e4f6ef41492777330b /editors
parent9b6bd3693695b9a96131acc6ddc8de7519f0be9b (diff)
downloadports-7406bd2ea1fde3c301342a4dabe895fdc3d49e28.tar.gz
ports-7406bd2ea1fde3c301342a4dabe895fdc3d49e28.zip
editors/libreoffice: resurrect deleted by mistake patch for qt5-cairo engine to fix CJK fonts rendering in menus and dialogs
PR: 253371, 253579 MFH: 2021Q1 Pointy hat to: fluffy
Notes
Notes: svn path=/head/; revision=565507
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx35
2 files changed, 36 insertions, 1 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 75985324f384..3712209346c9 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -1,5 +1,5 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
.include "${.CURDIR}/Makefile.common"
diff --git a/editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx b/editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx
new file mode 100644
index 000000000000..aad13b769fb4
--- /dev/null
+++ b/editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx
@@ -0,0 +1,35 @@
+--- vcl/qt5/Qt5Instance.cxx.orig 2020-05-13 11:19:20 UTC
++++ vcl/qt5/Qt5Instance.cxx
+@@ -261,7 +261,13 @@ SalFrame* Qt5Instance::CreateChildFrame(SystemParentDa
+ SalFrame* Qt5Instance::CreateFrame(SalFrame* pParent, SalFrameStyleFlags nStyle)
+ {
+ assert(!pParent || dynamic_cast<Qt5Frame*>(pParent));
+- return new Qt5Frame(static_cast<Qt5Frame*>(pParent), nStyle, m_bUseCairo);
++ SalFrame* pRet(nullptr);
++ bool bUseCairo = m_bUseCairo;
++ RunInMainThread([&pRet, pParent, nStyle, bUseCairo]() {
++ pRet = new Qt5Frame(static_cast<Qt5Frame*>(pParent), nStyle, bUseCairo);
++ });
++ assert(pRet);
++ return pRet;
+ }
+
+ void Qt5Instance::DestroyFrame(SalFrame* pFrame)
+@@ -420,7 +426,7 @@ Qt5Instance::createPicker(css::uno::Reference<css::uno
+ {
+ SolarMutexGuard g;
+ Qt5FilePicker* pPicker;
+- RunInMainThread([&, this]() { pPicker = createPicker(context, eMode); });
++ RunInMainThread([&pPicker, this, context, eMode]() { pPicker = createPicker(context, eMode); });
+ assert(pPicker);
+ return pPicker;
+ }
+@@ -624,7 +630,7 @@ std::unique_ptr<QApplication> Qt5Instance::CreateQAppl
+ extern "C" {
+ VCLPLUG_QT5_PUBLIC SalInstance* create_SalInstance()
+ {
+- static const bool bUseCairo = (nullptr != getenv("SAL_VCL_QT5_USE_CAIRO"));
++ static const bool bUseCairo = true; // (nullptr != getenv("SAL_VCL_QT5_USE_CAIRO"));
+
+ std::unique_ptr<char* []> pFakeArgv;
+ std::unique_ptr<int> pFakeArgc;