aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-01 14:55:02 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-01 14:55:02 +0000
commit7593c71367dffc32d976701b9e0f2601b1e34806 (patch)
tree2225125e90c840b2a7f3ad9cd2dd142db2af00f6 /editors
parent5c6bf4be6e262311ddc06b3dc0a1062d0d036cea (diff)
downloadports-7593c71367dffc32d976701b9e0f2601b1e34806.tar.gz
ports-7593c71367dffc32d976701b9e0f2601b1e34806.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/kak-lsp/Makefile2
-rw-r--r--editors/kak-lsp/files/patch-kak-lsp.toml10
2 files changed, 9 insertions, 3 deletions
diff --git a/editors/kak-lsp/Makefile b/editors/kak-lsp/Makefile
index f7f7d2804597..02aff448d3de 100644
--- a/editors/kak-lsp/Makefile
+++ b/editors/kak-lsp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kak-lsp
DISTVERSIONPREFIX= v
DISTVERSION= 6.0.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors
MAINTAINER= tobik@FreeBSD.org
diff --git a/editors/kak-lsp/files/patch-kak-lsp.toml b/editors/kak-lsp/files/patch-kak-lsp.toml
index 6fdf81bd962b..98814f46e3f0 100644
--- a/editors/kak-lsp/files/patch-kak-lsp.toml
+++ b/editors/kak-lsp/files/patch-kak-lsp.toml
@@ -1,6 +1,6 @@
--- kak-lsp.toml.orig 2019-01-14 07:08:28 UTC
+++ kak-lsp.toml
-@@ -52,11 +52,16 @@ filetypes = ["python"]
+@@ -52,11 +52,22 @@ filetypes = ["python"]
roots = ["requirements.txt", "setup.py", ".git", ".hg"]
command = "pyls"
@@ -17,10 +17,16 @@
-args = ["--init={\"cacheDirectory\":\"/tmp/cquery\"}"]
+roots = ["compile_commands.json", ".ccls", ".git"]
+command = "ccls"
++# With completion.detailedLabel turned on ccls embeds type
++# signatures and other metadata in completion entries. Kak-lsp
++# does not filter them, so they appear alongside the selected entry,
++# which is not very convenient. It is recommended that you disable
++# it.
++args = ["--init={\"completion\":{\"detailedLabel\":false}}"]
[language.haskell]
filetypes = ["haskell"]
-@@ -64,11 +69,17 @@ roots = ["Setup.hs", "stack.yaml", "*.cabal"]
+@@ -64,11 +75,17 @@ roots = ["Setup.hs", "stack.yaml", "*.cabal"]
command = "hie"
args = ["--lsp"]