aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-20 10:27:08 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-20 10:27:08 +0000
commit88302347d41efe9b5a192ed9ff8a3a5cd6f1f02a (patch)
tree8446e750189b916e95726c8a75b8543a8969d387 /editors
parent21a670cd3d875c900f7802540f55ba21d97e4091 (diff)
downloadports-88302347d41efe9b5a192ed9ff8a3a5cd6f1f02a.tar.gz
ports-88302347d41efe9b5a192ed9ff8a3a5cd6f1f02a.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/p5-Padre/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index b95745d93024..ec11d3948356 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -66,7 +66,7 @@ BUILD_DEPENDS= p5-JSON-XS>=2.29:${PORTSDIR}/converters/p5-JSON-XS \
p5-Wx-Perl-ProcessStream>=0.25:${PORTSDIR}/x11-toolkits/p5-Wx-Perl-ProcessStream
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gettext perl5
+USES= compiler:c++11-lib gettext perl5
USE_PERL5= configure
USE_WX= 3.0
WX_COMPS= wx
@@ -101,6 +101,7 @@ IGNORE= needs a threaded Perl, build with enabling THREADS option and try again
post-patch:
@${REINPLACE_CMD} -e \
'/my /s|wx-config|${WX_CONFIG:T}|g' \
+ -e '/ret/ s|urn .flags;|urn $$flags . " -std=c++11";|' \
${WRKDIR}/${WXSC_DISTNAME}/inc/Module/Build/Scintilla.pm
@${REINPLACE_CMD} -e \
's|_scintilla-|_scintilla| ; \
@@ -109,6 +110,7 @@ post-patch:
s|-lgtk-x11-2.0.*-lpangoft2-1.0|-lm| ; \
/-lgobject-2.0/d ; \
/-lglib-2.0/d ; \
+ s|{ccflags}|{ccflags} . " -std=c++11"| ; \
s|\\$$ORIGIN|${SITE_ARCH}/auto/Wx/Scintilla|' \
${WRKDIR}/${WXSC_DISTNAME}/inc/Module/Build/Scintilla/GTK.pm