aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2021-03-15 14:41:40 +0000
committerJason E. Hale <jhale@FreeBSD.org>2021-03-15 14:41:40 +0000
commita25ab1fd80178a79251d19b33cecc1bd28f3b8a4 (patch)
tree1c6e0691c241b6683f835f12ea08d222f120be4d /editors
parent8efbe89c6e4be1b4643516b5fd510b3e93bacf73 (diff)
downloadports-a25ab1fd80178a79251d19b33cecc1bd28f3b8a4.tar.gz
ports-a25ab1fd80178a79251d19b33cecc1bd28f3b8a4.zip
editors/mp: Update to 5.47
Notes
Notes: svn path=/head/; revision=568462
Diffstat (limited to 'editors')
-rw-r--r--editors/mp/Makefile4
-rw-r--r--editors/mp/distinfo14
-rw-r--r--editors/mp/files/patch-mpdm_mpdm__f.c19
3 files changed, 18 insertions, 19 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index d32d50192878..9181e406aa71 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mp
-DISTVERSION= 5.46
+DISTVERSION= 5.47
CATEGORIES= editors
MAINTAINER= jhale@FreeBSD.org
@@ -16,7 +16,7 @@ USES= gmake iconv
USE_GITHUB= yes
GH_ACCOUNT= ttcdt
GH_PROJECT= mp-5.x mpdm:mpdm mpsl:mpsl
-GH_TAGNAME= 2.70:mpdm 2.61:mpsl
+GH_TAGNAME= 2.72:mpdm 2.62:mpsl
GH_SUBDIR= mpdm:mpdm mpsl:mpsl
HAS_CONFIGURE= yes
diff --git a/editors/mp/distinfo b/editors/mp/distinfo
index 1553db93d835..3a260a7242bd 100644
--- a/editors/mp/distinfo
+++ b/editors/mp/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1612381167
-SHA256 (ttcdt-mp-5.x-5.46_GH0.tar.gz) = 492cbba7108d00ff41fc88429912fd5489d1afd97a3fdcd4be90968cca0ab1bc
-SIZE (ttcdt-mp-5.x-5.46_GH0.tar.gz) = 225040
-SHA256 (ttcdt-mpdm-2.70_GH0.tar.gz) = d3c6269ef2151071d60a736b328ac33040a8afe2a808ccbe56cfa5686198c48a
-SIZE (ttcdt-mpdm-2.70_GH0.tar.gz) = 142016
-SHA256 (ttcdt-mpsl-2.61_GH0.tar.gz) = 1d360ca31bdc04dee7338442fc3a0996eab87ceb22d5f76f6843f9469d4be45b
-SIZE (ttcdt-mpsl-2.61_GH0.tar.gz) = 70207
+TIMESTAMP = 1615814934
+SHA256 (ttcdt-mp-5.x-5.47_GH0.tar.gz) = cb2d209141ed30801b273bf49310863a9f5c546ba75a6a4320a98f5bad88b215
+SIZE (ttcdt-mp-5.x-5.47_GH0.tar.gz) = 235276
+SHA256 (ttcdt-mpdm-2.72_GH0.tar.gz) = eca91ca7549cab93931a806c7434fff9efa122f29ba787c670ab25fec24ecfbf
+SIZE (ttcdt-mpdm-2.72_GH0.tar.gz) = 144909
+SHA256 (ttcdt-mpsl-2.62_GH0.tar.gz) = 3e12bbbb8504bc9ebba31a5753c60e5280a1d7d9f3f0d5199ff0f1f3f241879a
+SIZE (ttcdt-mpsl-2.62_GH0.tar.gz) = 69393
diff --git a/editors/mp/files/patch-mpdm_mpdm__f.c b/editors/mp/files/patch-mpdm_mpdm__f.c
index dd8880cb00de..b78a42da4e68 100644
--- a/editors/mp/files/patch-mpdm_mpdm__f.c
+++ b/editors/mp/files/patch-mpdm_mpdm__f.c
@@ -1,5 +1,12 @@
-mpdm_f.c:1947:9: error: use of undeclared identifier 'environ'
- environ = (char **) calloc(sizeof(char *), mpdm_size(v) + 1);
+mpdm_f.c:2395:24: error: variable has incomplete type 'struct sockaddr_in'
+ struct sockaddr_in host;
+ ^
+mpdm_f.c:2395:12: note: forward declaration of 'struct sockaddr_in'
+ struct sockaddr_in host;
+ ^
+mpdm_f.c:2417:23: warning: implicit declaration of function 'htons' is invalid in C99 [-Wimplicit-function-declaration]
+ host.sin_port = htons(p);
+ ^
--- mpdm/mpdm_f.c.orig 2020-11-22 08:58:48 UTC
+++ mpdm/mpdm_f.c
@@ -12,11 +19,3 @@ mpdm_f.c:1947:9: error: use of undeclared identifier 'environ'
#include "mpdm.h"
#ifdef CONFOPT_ICONV
-@@ -1974,6 +1976,7 @@ static int sysdep_popen(mpdm_t v, char *prg, int rw)
-
- /* build the environment for the subprocess */
- v = mpdm_join(mpdm_get_wcs(mpdm_root(), L"ENV"), MPDM_S(L"="));
-+ extern char **environ;
- environ = (char **) calloc(sizeof(char *), mpdm_size(v) + 1);
-
- mpdm_ref(v);