aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-01-31 13:58:43 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-01-31 13:58:43 +0000
commitaf8b56bb00cb1067f6db169c2dc942d92e3fc7dd (patch)
tree900cf0609ca3af5d36fe34a0cbfe648292582b30 /editors
parentf0b20f01594d7d65e95f9affb271edff74e09c1b (diff)
downloadports-af8b56bb00cb1067f6db169c2dc942d92e3fc7dd.tar.gz
ports-af8b56bb00cb1067f6db169c2dc942d92e3fc7dd.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/xed/Makefile33
-rw-r--r--editors/xed/distinfo3
-rw-r--r--editors/xed/pkg-descr5
-rw-r--r--editors/xed/pkg-plist361
5 files changed, 403 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 20d5e518144b..f28c603c4e76 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -254,6 +254,7 @@
SUBDIR += wordgrinder
SUBDIR += wxhexeditor
SUBDIR += xcoral
+ SUBDIR += xed
SUBDIR += xi-core
SUBDIR += xi-term
SUBDIR += xmlcopyeditor
diff --git a/editors/xed/Makefile b/editors/xed/Makefile
new file mode 100644
index 000000000000..42864ead633e
--- /dev/null
+++ b/editors/xed/Makefile
@@ -0,0 +1,33 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xed
+PORTVERSION= 2.4.2
+CATEGORIES= editors
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Small and lightweight graphical text editor
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= intltool-merge:textproc/intltool \
+ itstool:textproc/itstool
+LIB_DEPENDS= libpeas-1.0.so:devel/libpeas \
+ libxapp.so:x11/xapps
+RUN_DEPENDS= ${LOCALBASE}/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml:devel/gsettings-desktop-schemas
+
+USES= desktop-file-utils gettext-tools gnome meson pkgconfig xorg
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview3 \
+ introspection pango
+USE_XORG= x11
+GLIB_SCHEMAS= org.x.editor.gschema.xml \
+ org.x.editor.plugins.filebrowser.gschema.xml \
+ org.x.editor.plugins.time.gschema.xml \
+ org.x.editor.plugins.wordcompletion.gschema.xml
+
+# XXX: should become OPTIONs
+MESON_ARGS= -Denable_spell=false
+
+.include <bsd.port.mk>
diff --git a/editors/xed/distinfo b/editors/xed/distinfo
new file mode 100644
index 000000000000..66cc992f8a9b
--- /dev/null
+++ b/editors/xed/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1576075791
+SHA256 (linuxmint-xed-2.4.2_GH0.tar.gz) = ead304447e23be359f979d8d74c083f1369e2799c84955c71263aacf4228f1a9
+SIZE (linuxmint-xed-2.4.2_GH0.tar.gz) = 4029991
diff --git a/editors/xed/pkg-descr b/editors/xed/pkg-descr
new file mode 100644
index 000000000000..4f655022a69a
--- /dev/null
+++ b/editors/xed/pkg-descr
@@ -0,0 +1,5 @@
+xed is a small and lightweight text editor, which supports most standard
+editing features, plus several not typically found in one's average text
+editor (plugins being the most notable of these).
+
+WWW: https://github.com/linuxmint/xed
diff --git a/editors/xed/pkg-plist b/editors/xed/pkg-plist
new file mode 100644
index 000000000000..3a9ac4032998
--- /dev/null
+++ b/editors/xed/pkg-plist
@@ -0,0 +1,361 @@
+bin/xed
+include/xed/xed-app-activatable.h
+include/xed/xed-app.h
+include/xed/xed-commands.h
+include/xed/xed-debug.h
+include/xed/xed-document.h
+include/xed/xed-encodings-combo-box.h
+include/xed/xed-file-chooser-dialog.h
+include/xed/xed-message-bus.h
+include/xed/xed-message-type.h
+include/xed/xed-message.h
+include/xed/xed-notebook.h
+include/xed/xed-panel.h
+include/xed/xed-progress-info-bar.h
+include/xed/xed-searchbar.h
+include/xed/xed-statusbar.h
+include/xed/xed-tab.h
+include/xed/xed-view-activatable.h
+include/xed/xed-view.h
+include/xed/xed-window-activatable.h
+include/xed/xed-window.h
+lib/xed/girepository-1.0/Xed-1.0.typelib
+lib/xed/libxed.so
+lib/xed/plugins/docinfo.plugin
+lib/xed/plugins/filebrowser.plugin
+lib/xed/plugins/libdocinfo.so
+lib/xed/plugins/libfilebrowser.so
+lib/xed/plugins/libmodelines.so
+lib/xed/plugins/libsort.so
+lib/xed/plugins/libtaglist.so
+lib/xed/plugins/libtime.so
+lib/xed/plugins/libtrailsave.so
+lib/xed/plugins/libwordcompletion.so
+lib/xed/plugins/modelines.plugin
+lib/xed/plugins/open-uri-context-menu/COPYING
+lib/xed/plugins/open-uri-context-menu/open-uri-context-menu.plugin
+lib/xed/plugins/open-uri-context-menu/open-uri-context-menu.py
+lib/xed/plugins/sort.plugin
+lib/xed/plugins/taglist.plugin
+lib/xed/plugins/textsize.plugin
+lib/xed/plugins/textsize/__init__.py
+lib/xed/plugins/textsize/documenthelper.py
+lib/xed/plugins/textsize/signals.py
+lib/xed/plugins/time.plugin
+lib/xed/plugins/trailsave.plugin
+lib/xed/plugins/wordcompletion.plugin
+libdata/pkgconfig/xed.pc
+man/man1/xed.1.gz
+share/applications/xed.desktop
+share/dbus-1/services/org.x.editor.service
+share/help/C/xed/figures/xed_format_bold.png
+share/help/C/xed/figures/xed_format_italic.png
+share/help/C/xed/figures/xed_format_strikethrough.png
+share/help/C/xed/figures/xed_format_underline.png
+share/help/C/xed/figures/xed_recent_files_menu_icon.png
+share/help/C/xed/figures/xed_window.png
+share/help/C/xed/index.docbook
+share/help/C/xed/legal.xml
+share/help/ar/xed/figures/xed_format_bold.png
+share/help/ar/xed/figures/xed_format_italic.png
+share/help/ar/xed/figures/xed_format_strikethrough.png
+share/help/ar/xed/figures/xed_format_underline.png
+share/help/ar/xed/figures/xed_recent_files_menu_icon.png
+share/help/ar/xed/figures/xed_window.png
+share/help/ar/xed/index.docbook
+share/help/ar/xed/legal.xml
+share/help/bg/xed/figures/xed_format_bold.png
+share/help/bg/xed/figures/xed_format_italic.png
+share/help/bg/xed/figures/xed_format_strikethrough.png
+share/help/bg/xed/figures/xed_format_underline.png
+share/help/bg/xed/figures/xed_recent_files_menu_icon.png
+share/help/bg/xed/figures/xed_window.png
+share/help/bg/xed/index.docbook
+share/help/bg/xed/legal.xml
+share/help/ca/xed/figures/xed_format_bold.png
+share/help/ca/xed/figures/xed_format_italic.png
+share/help/ca/xed/figures/xed_format_strikethrough.png
+share/help/ca/xed/figures/xed_format_underline.png
+share/help/ca/xed/figures/xed_recent_files_menu_icon.png
+share/help/ca/xed/figures/xed_window.png
+share/help/ca/xed/index.docbook
+share/help/ca/xed/legal.xml
+share/help/cs/xed/figures/xed_format_bold.png
+share/help/cs/xed/figures/xed_format_italic.png
+share/help/cs/xed/figures/xed_format_strikethrough.png
+share/help/cs/xed/figures/xed_format_underline.png
+share/help/cs/xed/figures/xed_recent_files_menu_icon.png
+share/help/cs/xed/figures/xed_window.png
+share/help/cs/xed/index.docbook
+share/help/cs/xed/legal.xml
+share/help/da/xed/figures/xed_format_bold.png
+share/help/da/xed/figures/xed_format_italic.png
+share/help/da/xed/figures/xed_format_strikethrough.png
+share/help/da/xed/figures/xed_format_underline.png
+share/help/da/xed/figures/xed_recent_files_menu_icon.png
+share/help/da/xed/figures/xed_window.png
+share/help/da/xed/index.docbook
+share/help/da/xed/legal.xml
+share/help/de/xed/figures/xed_format_bold.png
+share/help/de/xed/figures/xed_format_italic.png
+share/help/de/xed/figures/xed_format_strikethrough.png
+share/help/de/xed/figures/xed_format_underline.png
+share/help/de/xed/figures/xed_recent_files_menu_icon.png
+share/help/de/xed/figures/xed_window.png
+share/help/de/xed/index.docbook
+share/help/de/xed/legal.xml
+share/help/el/xed/figures/xed_format_bold.png
+share/help/el/xed/figures/xed_format_italic.png
+share/help/el/xed/figures/xed_format_strikethrough.png
+share/help/el/xed/figures/xed_format_underline.png
+share/help/el/xed/figures/xed_recent_files_menu_icon.png
+share/help/el/xed/figures/xed_window.png
+share/help/el/xed/index.docbook
+share/help/el/xed/legal.xml
+share/help/es/xed/figures/xed_format_bold.png
+share/help/es/xed/figures/xed_format_italic.png
+share/help/es/xed/figures/xed_format_strikethrough.png
+share/help/es/xed/figures/xed_format_underline.png
+share/help/es/xed/figures/xed_recent_files_menu_icon.png
+share/help/es/xed/figures/xed_window.png
+share/help/es/xed/index.docbook
+share/help/es/xed/legal.xml
+share/help/fi/xed/figures/xed_format_bold.png
+share/help/fi/xed/figures/xed_format_italic.png
+share/help/fi/xed/figures/xed_format_strikethrough.png
+share/help/fi/xed/figures/xed_format_underline.png
+share/help/fi/xed/figures/xed_recent_files_menu_icon.png
+share/help/fi/xed/figures/xed_window.png
+share/help/fi/xed/index.docbook
+share/help/fi/xed/legal.xml
+share/help/fr/xed/figures/xed_format_bold.png
+share/help/fr/xed/figures/xed_format_italic.png
+share/help/fr/xed/figures/xed_format_strikethrough.png
+share/help/fr/xed/figures/xed_format_underline.png
+share/help/fr/xed/figures/xed_recent_files_menu_icon.png
+share/help/fr/xed/figures/xed_window.png
+share/help/fr/xed/index.docbook
+share/help/fr/xed/legal.xml
+share/help/hu/xed/figures/xed_format_bold.png
+share/help/hu/xed/figures/xed_format_italic.png
+share/help/hu/xed/figures/xed_format_strikethrough.png
+share/help/hu/xed/figures/xed_format_underline.png
+share/help/hu/xed/figures/xed_recent_files_menu_icon.png
+share/help/hu/xed/figures/xed_window.png
+share/help/hu/xed/index.docbook
+share/help/hu/xed/legal.xml
+share/help/it/xed/figures/xed_format_bold.png
+share/help/it/xed/figures/xed_format_italic.png
+share/help/it/xed/figures/xed_format_strikethrough.png
+share/help/it/xed/figures/xed_format_underline.png
+share/help/it/xed/figures/xed_recent_files_menu_icon.png
+share/help/it/xed/figures/xed_window.png
+share/help/it/xed/index.docbook
+share/help/it/xed/legal.xml
+share/help/ja/xed/figures/xed_format_bold.png
+share/help/ja/xed/figures/xed_format_italic.png
+share/help/ja/xed/figures/xed_format_strikethrough.png
+share/help/ja/xed/figures/xed_format_underline.png
+share/help/ja/xed/figures/xed_recent_files_menu_icon.png
+share/help/ja/xed/figures/xed_window.png
+share/help/ja/xed/index.docbook
+share/help/ja/xed/legal.xml
+share/help/ko/xed/figures/xed_format_bold.png
+share/help/ko/xed/figures/xed_format_italic.png
+share/help/ko/xed/figures/xed_format_strikethrough.png
+share/help/ko/xed/figures/xed_format_underline.png
+share/help/ko/xed/figures/xed_recent_files_menu_icon.png
+share/help/ko/xed/figures/xed_window.png
+share/help/ko/xed/index.docbook
+share/help/ko/xed/legal.xml
+share/help/oc/xed/figures/xed_format_bold.png
+share/help/oc/xed/figures/xed_format_italic.png
+share/help/oc/xed/figures/xed_format_strikethrough.png
+share/help/oc/xed/figures/xed_format_underline.png
+share/help/oc/xed/figures/xed_recent_files_menu_icon.png
+share/help/oc/xed/figures/xed_window.png
+share/help/oc/xed/index.docbook
+share/help/oc/xed/legal.xml
+share/help/pt_BR/xed/figures/xed_format_bold.png
+share/help/pt_BR/xed/figures/xed_format_italic.png
+share/help/pt_BR/xed/figures/xed_format_strikethrough.png
+share/help/pt_BR/xed/figures/xed_format_underline.png
+share/help/pt_BR/xed/figures/xed_recent_files_menu_icon.png
+share/help/pt_BR/xed/figures/xed_window.png
+share/help/pt_BR/xed/index.docbook
+share/help/pt_BR/xed/legal.xml
+share/help/ru/xed/figures/xed_format_bold.png
+share/help/ru/xed/figures/xed_format_italic.png
+share/help/ru/xed/figures/xed_format_strikethrough.png
+share/help/ru/xed/figures/xed_format_underline.png
+share/help/ru/xed/figures/xed_recent_files_menu_icon.png
+share/help/ru/xed/figures/xed_window.png
+share/help/ru/xed/index.docbook
+share/help/ru/xed/legal.xml
+share/help/sv/xed/figures/xed_format_bold.png
+share/help/sv/xed/figures/xed_format_italic.png
+share/help/sv/xed/figures/xed_format_strikethrough.png
+share/help/sv/xed/figures/xed_format_underline.png
+share/help/sv/xed/figures/xed_recent_files_menu_icon.png
+share/help/sv/xed/figures/xed_window.png
+share/help/sv/xed/index.docbook
+share/help/sv/xed/legal.xml
+share/help/th/xed/figures/xed_format_bold.png
+share/help/th/xed/figures/xed_format_italic.png
+share/help/th/xed/figures/xed_format_strikethrough.png
+share/help/th/xed/figures/xed_format_underline.png
+share/help/th/xed/figures/xed_recent_files_menu_icon.png
+share/help/th/xed/figures/xed_window.png
+share/help/th/xed/index.docbook
+share/help/th/xed/legal.xml
+share/help/uk/xed/figures/xed_format_bold.png
+share/help/uk/xed/figures/xed_format_italic.png
+share/help/uk/xed/figures/xed_format_strikethrough.png
+share/help/uk/xed/figures/xed_format_underline.png
+share/help/uk/xed/figures/xed_recent_files_menu_icon.png
+share/help/uk/xed/figures/xed_window.png
+share/help/uk/xed/index.docbook
+share/help/uk/xed/legal.xml
+share/help/zh_CN/xed/figures/xed_format_bold.png
+share/help/zh_CN/xed/figures/xed_format_italic.png
+share/help/zh_CN/xed/figures/xed_format_strikethrough.png
+share/help/zh_CN/xed/figures/xed_format_underline.png
+share/help/zh_CN/xed/figures/xed_recent_files_menu_icon.png
+share/help/zh_CN/xed/figures/xed_window.png
+share/help/zh_CN/xed/index.docbook
+share/help/zh_CN/xed/legal.xml
+share/help/zh_HK/xed/figures/xed_format_bold.png
+share/help/zh_HK/xed/figures/xed_format_italic.png
+share/help/zh_HK/xed/figures/xed_format_strikethrough.png
+share/help/zh_HK/xed/figures/xed_format_underline.png
+share/help/zh_HK/xed/figures/xed_recent_files_menu_icon.png
+share/help/zh_HK/xed/figures/xed_window.png
+share/help/zh_HK/xed/index.docbook
+share/help/zh_HK/xed/legal.xml
+share/help/zh_TW/xed/figures/xed_format_bold.png
+share/help/zh_TW/xed/figures/xed_format_italic.png
+share/help/zh_TW/xed/figures/xed_format_strikethrough.png
+share/help/zh_TW/xed/figures/xed_format_underline.png
+share/help/zh_TW/xed/figures/xed_recent_files_menu_icon.png
+share/help/zh_TW/xed/figures/xed_window.png
+share/help/zh_TW/xed/index.docbook
+share/help/zh_TW/xed/legal.xml
+share/locale/ab/LC_MESSAGES/xed.mo
+share/locale/af/LC_MESSAGES/xed.mo
+share/locale/am/LC_MESSAGES/xed.mo
+share/locale/ar/LC_MESSAGES/xed.mo
+share/locale/as/LC_MESSAGES/xed.mo
+share/locale/ast/LC_MESSAGES/xed.mo
+share/locale/az/LC_MESSAGES/xed.mo
+share/locale/be/LC_MESSAGES/xed.mo
+share/locale/be@latin/LC_MESSAGES/xed.mo
+share/locale/bg/LC_MESSAGES/xed.mo
+share/locale/bn/LC_MESSAGES/xed.mo
+share/locale/bn_IN/LC_MESSAGES/xed.mo
+share/locale/br/LC_MESSAGES/xed.mo
+share/locale/bs/LC_MESSAGES/xed.mo
+share/locale/ca/LC_MESSAGES/xed.mo
+share/locale/ca@valencia/LC_MESSAGES/xed.mo
+share/locale/cmn/LC_MESSAGES/xed.mo
+share/locale/crh/LC_MESSAGES/xed.mo
+share/locale/cs/LC_MESSAGES/xed.mo
+share/locale/cy/LC_MESSAGES/xed.mo
+share/locale/da/LC_MESSAGES/xed.mo
+share/locale/de/LC_MESSAGES/xed.mo
+share/locale/dz/LC_MESSAGES/xed.mo
+share/locale/el/LC_MESSAGES/xed.mo
+share/locale/en@shaw/LC_MESSAGES/xed.mo
+share/locale/en_AU/LC_MESSAGES/xed.mo
+share/locale/en_CA/LC_MESSAGES/xed.mo
+share/locale/en_GB/LC_MESSAGES/xed.mo
+share/locale/eo/LC_MESSAGES/xed.mo
+share/locale/es/LC_MESSAGES/xed.mo
+share/locale/et/LC_MESSAGES/xed.mo
+share/locale/eu/LC_MESSAGES/xed.mo
+share/locale/fa/LC_MESSAGES/xed.mo
+share/locale/fi/LC_MESSAGES/xed.mo
+share/locale/fr/LC_MESSAGES/xed.mo
+share/locale/fr_CA/LC_MESSAGES/xed.mo
+share/locale/ga/LC_MESSAGES/xed.mo
+share/locale/gl/LC_MESSAGES/xed.mo
+share/locale/gu/LC_MESSAGES/xed.mo
+share/locale/he/LC_MESSAGES/xed.mo
+share/locale/hi/LC_MESSAGES/xed.mo
+share/locale/hr/LC_MESSAGES/xed.mo
+share/locale/hu/LC_MESSAGES/xed.mo
+share/locale/hy/LC_MESSAGES/xed.mo
+share/locale/ia/LC_MESSAGES/xed.mo
+share/locale/id/LC_MESSAGES/xed.mo
+share/locale/ie/LC_MESSAGES/xed.mo
+share/locale/is/LC_MESSAGES/xed.mo
+share/locale/it/LC_MESSAGES/xed.mo
+share/locale/ja/LC_MESSAGES/xed.mo
+share/locale/ka/LC_MESSAGES/xed.mo
+share/locale/kab/LC_MESSAGES/xed.mo
+share/locale/kk/LC_MESSAGES/xed.mo
+share/locale/kn/LC_MESSAGES/xed.mo
+share/locale/ko/LC_MESSAGES/xed.mo
+share/locale/ku/LC_MESSAGES/xed.mo
+share/locale/ky/LC_MESSAGES/xed.mo
+share/locale/la/LC_MESSAGES/xed.mo
+share/locale/lt/LC_MESSAGES/xed.mo
+share/locale/lv/LC_MESSAGES/xed.mo
+share/locale/mai/LC_MESSAGES/xed.mo
+share/locale/mg/LC_MESSAGES/xed.mo
+share/locale/mi/LC_MESSAGES/xed.mo
+share/locale/mk/LC_MESSAGES/xed.mo
+share/locale/ml/LC_MESSAGES/xed.mo
+share/locale/mn/LC_MESSAGES/xed.mo
+share/locale/mr/LC_MESSAGES/xed.mo
+share/locale/ms/LC_MESSAGES/xed.mo
+share/locale/my/LC_MESSAGES/xed.mo
+share/locale/nb/LC_MESSAGES/xed.mo
+share/locale/nds/LC_MESSAGES/xed.mo
+share/locale/ne/LC_MESSAGES/xed.mo
+share/locale/nl/LC_MESSAGES/xed.mo
+share/locale/nn/LC_MESSAGES/xed.mo
+share/locale/oc/LC_MESSAGES/xed.mo
+share/locale/or/LC_MESSAGES/xed.mo
+share/locale/pa/LC_MESSAGES/xed.mo
+share/locale/pl/LC_MESSAGES/xed.mo
+share/locale/ps/LC_MESSAGES/xed.mo
+share/locale/pt/LC_MESSAGES/xed.mo
+share/locale/pt_BR/LC_MESSAGES/xed.mo
+share/locale/ro/LC_MESSAGES/xed.mo
+share/locale/ru/LC_MESSAGES/xed.mo
+share/locale/rw/LC_MESSAGES/xed.mo
+share/locale/si/LC_MESSAGES/xed.mo
+share/locale/sk/LC_MESSAGES/xed.mo
+share/locale/sl/LC_MESSAGES/xed.mo
+share/locale/sq/LC_MESSAGES/xed.mo
+share/locale/sr/LC_MESSAGES/xed.mo
+share/locale/sr@latin/LC_MESSAGES/xed.mo
+share/locale/sv/LC_MESSAGES/xed.mo
+share/locale/ta/LC_MESSAGES/xed.mo
+share/locale/te/LC_MESSAGES/xed.mo
+share/locale/tg/LC_MESSAGES/xed.mo
+share/locale/th/LC_MESSAGES/xed.mo
+share/locale/tk/LC_MESSAGES/xed.mo
+share/locale/tr/LC_MESSAGES/xed.mo
+share/locale/uk/LC_MESSAGES/xed.mo
+share/locale/ur/LC_MESSAGES/xed.mo
+share/locale/vi/LC_MESSAGES/xed.mo
+share/locale/wa/LC_MESSAGES/xed.mo
+share/locale/xh/LC_MESSAGES/xed.mo
+share/locale/zh_CN/LC_MESSAGES/xed.mo
+share/locale/zh_HK/LC_MESSAGES/xed.mo
+share/locale/zh_TW/LC_MESSAGES/xed.mo
+share/metainfo/xed.appdata.xml
+%%DATADIR%%/gir-1.0/Xed-1.0.gir
+%%DATADIR%%/icons/xed-plugin.png
+%%DATADIR%%/plugins/docinfo/docinfo.ui
+%%DATADIR%%/plugins/filebrowser/xed-file-browser-widget-ui.xml
+%%DATADIR%%/plugins/modelines/language-mappings
+%%DATADIR%%/plugins/taglist/C.tags.gz
+%%DATADIR%%/plugins/taglist/HTML.tags.gz
+%%DATADIR%%/plugins/taglist/Latex.tags.gz
+%%DATADIR%%/plugins/taglist/XSLT.tags.gz
+%%DATADIR%%/plugins/taglist/XUL.tags.gz
+%%DATADIR%%/plugins/time/xed-time-dialog.ui
+%%DATADIR%%/plugins/time/xed-time-setup-dialog.ui
+%%DATADIR%%/plugins/wordcompletion/xed-wordcompletion-configure.ui