aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2021-03-16 10:39:33 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-03-16 10:39:33 +0000
commitc7ae8198038a8585bd68078ba00f04873466eda8 (patch)
tree8dfe85582412832af129c5c56adaf068ca7cfb0c /editors
parent7b94aff4ea1b930810cc29027de515eca25173c1 (diff)
downloadports-c7ae8198038a8585bd68078ba00f04873466eda8.tar.gz
ports-c7ae8198038a8585bd68078ba00f04873466eda8.zip
Add editors/sly-asdf: SLY support for ASDF
PR: 254016 Submitted by: Olivier Certner <olivier.freebsd@free.fr>
Notes
Notes: svn path=/head/; revision=568552
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/sly-asdf/Makefile54
-rw-r--r--editors/sly-asdf/distinfo3
-rw-r--r--editors/sly-asdf/files/patch-README.md16
-rw-r--r--editors/sly-asdf/files/patch-sly-asdf.el13
-rw-r--r--editors/sly-asdf/pkg-descr4
-rw-r--r--editors/sly-asdf/pkg-message27
-rw-r--r--editors/sly-asdf/pkg-plist4
8 files changed, 122 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index d90eb596f272..cbed61a2f1e0 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -232,6 +232,7 @@
SUBDIR += shed
SUBDIR += slime
SUBDIR += sly
+ SUBDIR += sly-asdf
SUBDIR += sly-named-readtables
SUBDIR += sly-quicklisp
SUBDIR += ssed
diff --git a/editors/sly-asdf/Makefile b/editors/sly-asdf/Makefile
new file mode 100644
index 000000000000..c4238e21e897
--- /dev/null
+++ b/editors/sly-asdf/Makefile
@@ -0,0 +1,54 @@
+# $FreeBSD$
+
+PORTNAME= sly-asdf
+PORTVERSION= 20210308
+CATEGORIES= editors elisp
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
+
+MAINTAINER= olce.freebsd.ports@certner.fr
+COMMENT= SLY support for ASDF
+
+LICENSE= GPLv3
+
+MY_DEPENDS= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/sly/sly.el:editors/sly
+BUILD_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= ${MY_DEPENDS}
+
+USES= emacs
+USE_GITHUB= yes
+GH_ACCOUNT= mmgeorge
+GH_TAGNAME= bcaeba9b73b582ae1c4fadc23c71ee7e38d9a64e
+
+NO_ARCH= yes
+
+EMACS_COMPILE= ${EMACS_CMD} --batch --no-site-file -L ${WRKSRC} \
+ -f batch-byte-compile
+
+PLIST_THIS_LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+THIS_LISPDIR= ${PREFIX}/${PLIST_THIS_LISPDIR}
+PLIST_SUB+= THIS_LISPDIR=${PLIST_THIS_LISPDIR}
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= README.md
+
+post-patch:
+ cd ${WRKSRC} && ${RM} *flymake*
+
+do-build:
+ cd ${WRKSRC} && ${EMACS_COMPILE} sly-*.el
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${THIS_LISPDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${THIS_LISPDIR} \
+ "! ( -depth 1 ( ${PORTDOCS:C/^(.*)$/-name \1 -o/} \
+ -name LICENSE -o -name *\.md ) -o \
+ -path \./test* -o -path \./.[^.]* -o \
+ -name *\.orig )")
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:%=${WRKSRC}/%} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/editors/sly-asdf/distinfo b/editors/sly-asdf/distinfo
new file mode 100644
index 000000000000..bc8b2a7fb57d
--- /dev/null
+++ b/editors/sly-asdf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615760525
+SHA256 (mmgeorge-sly-asdf-20210308-bcaeba9b73b582ae1c4fadc23c71ee7e38d9a64e_GH0.tar.gz) = c23141f2c9a0dfff9a6452c7753f2c3d236ef0b36c5b1c967f61b898a3ab4ed7
+SIZE (mmgeorge-sly-asdf-20210308-bcaeba9b73b582ae1c4fadc23c71ee7e38d9a64e_GH0.tar.gz) = 42843
diff --git a/editors/sly-asdf/files/patch-README.md b/editors/sly-asdf/files/patch-README.md
new file mode 100644
index 000000000000..35af6b7ef00e
--- /dev/null
+++ b/editors/sly-asdf/files/patch-README.md
@@ -0,0 +1,16 @@
+--- README.md.orig 2021-03-08 03:32:35 UTC
++++ README.md
+@@ -16,9 +16,8 @@ Installing manually will require the contrib be regist
+ ```
+ (add-to-list 'sly-contribs 'sly-asdf 'append)
+ ```
++
+ ## Experimental
+-SLY-ASDF currently supports a very experimental system-aware checker that builds on flymake. This loads the system in a separate process and highlights any compilation/load errors for currently opened buffers. Only tested with SBCL. Enable this with
+-```
+-(setq sly-asdf-enable-experimental-syntax-checking t)
+-(require 'sly-asdf-flymake)
+-```
++Upstream currently supports a very experimental system-aware checker that
++builds on flymake. It is not available in this port (please use some ELPA
++package instead).
diff --git a/editors/sly-asdf/files/patch-sly-asdf.el b/editors/sly-asdf/files/patch-sly-asdf.el
new file mode 100644
index 000000000000..4340586fd101
--- /dev/null
+++ b/editors/sly-asdf/files/patch-sly-asdf.el
@@ -0,0 +1,13 @@
+--- sly-asdf.el.orig 2021-03-08 03:32:35 UTC
++++ sly-asdf.el
+@@ -354,10 +354,5 @@ in the directory of the current buffer."
+
+
+
+-;;;###autoload
+-(with-eval-after-load 'sly
+- (add-to-list 'sly-contribs 'sly-asdf 'append))
+-
+-
+ (provide 'sly-asdf)
+ ;;; sly-asdf.el ends here
diff --git a/editors/sly-asdf/pkg-descr b/editors/sly-asdf/pkg-descr
new file mode 100644
index 000000000000..c728baf4b31e
--- /dev/null
+++ b/editors/sly-asdf/pkg-descr
@@ -0,0 +1,4 @@
+sly-asdf is an external contrib for SLY that enables specific support and
+shortcuts for ASDF operations.
+
+WWW: https://github.com/mmgeorge/sly-asdf
diff --git a/editors/sly-asdf/pkg-message b/editors/sly-asdf/pkg-message
new file mode 100644
index 000000000000..ddf7840442ea
--- /dev/null
+++ b/editors/sly-asdf/pkg-message
@@ -0,0 +1,27 @@
+[
+{ type: install
+ message: <<EOM
+To use the sly-asdf contrib, you must:
+1. Register sly-asdf into SLY. You just have to add this line to some init
+ file:
+(require 'sly-asdf)
+ Doing this is not strictly necessary if you want to automatically activate
+ this contrib using `sly-contribs' (see below), but it never hurts.
+ This contrib's automatic activation at load was disabled, contrary to what
+ upstream does.
+2. Ensure that ASDF is loaded by your Common Lisp implementation.
+
+If you want sly-asdf to be automatically activated on each new SLY
+session, put it in the `sly-contribs' list. E.g., you can add something like
+this in some Emacs' init file:
+(setq sly-contribs '(sly-fancy sly-asdf))
+or customize the variable.
+
+To enable it on demand in already running SLY sessions instead, just use the
+`sly-enable-contrib' command, or modify `sly-contribs' and run `sly-setup'.
+
+NOTE: The experimental Flymake code has been elided from this port (it requires
+dependencies that are not in ports currently).
+EOM
+}
+]
diff --git a/editors/sly-asdf/pkg-plist b/editors/sly-asdf/pkg-plist
new file mode 100644
index 000000000000..606397fb233d
--- /dev/null
+++ b/editors/sly-asdf/pkg-plist
@@ -0,0 +1,4 @@
+%%THIS_LISPDIR%%/sly-asdf.el
+%%THIS_LISPDIR%%/sly-asdf.elc
+%%THIS_LISPDIR%%/slynk-asdf.asd
+%%THIS_LISPDIR%%/slynk-asdf.lisp