aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2003-02-14 20:41:08 +0000
committerPatrick Li <pat@FreeBSD.org>2003-02-14 20:41:08 +0000
commite7319382bd5fd05947d873006778b34e967a27e2 (patch)
tree952762d0f12cbfd4f37dd40a45c576152781a467 /editors
parentf6b149851c625a642f53f80ef81cd9e295d7144d (diff)
downloadports-e7319382bd5fd05947d873006778b34e967a27e2.tar.gz
ports-e7319382bd5fd05947d873006778b34e967a27e2.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/hnb/Makefile10
-rw-r--r--editors/hnb/distinfo2
-rw-r--r--editors/hnb/files/patch-Makefile33
-rw-r--r--editors/hnb/files/patch-libcli::Makefile26
4 files changed, 68 insertions, 3 deletions
diff --git a/editors/hnb/Makefile b/editors/hnb/Makefile
index 53bfb72c4541..ac7cbdfb7618 100644
--- a/editors/hnb/Makefile
+++ b/editors/hnb/Makefile
@@ -6,15 +6,21 @@
#
PORTNAME= hnb
-PORTVERSION= 1.8.1
+PORTVERSION= 1.9.8
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@FreeBSD.org
-GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_GMAKE= yes
+ALL_TARGET=
MAN1= hnb.1
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hnb ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/../doc/hnb.1 ${MANPREFIX}/man/man1
+
.include <bsd.port.mk>
diff --git a/editors/hnb/distinfo b/editors/hnb/distinfo
index e7c3f039bde7..a85834d72134 100644
--- a/editors/hnb/distinfo
+++ b/editors/hnb/distinfo
@@ -1 +1 @@
-MD5 (hnb-1.8.1.tar.gz) = bcbf069d7cb3d3f80d7ee39bc6f5f669
+MD5 (hnb-1.9.8.tar.gz) = f571f61a0c4f65d9f8a3669234490f42
diff --git a/editors/hnb/files/patch-Makefile b/editors/hnb/files/patch-Makefile
new file mode 100644
index 000000000000..40b266867b6e
--- /dev/null
+++ b/editors/hnb/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig Fri Feb 14 13:28:40 2003
++++ Makefile Fri Feb 14 13:28:26 2003
+@@ -1,5 +1,5 @@
+ LIBS=-lncurses libcli/libcli.a
+-CFLAGS=-I.. -Ilibcli -DHAVE_CONFIG_H -Wall -O2
++CFLAGS+=-I.. -Ilibcli -DHAVE_CONFIG_H -Wall
+
+ OBJS= ui_cli.o hnb.o node.o path.o prefs.o tokenizer.o tree.o tree_sort.o tree_todo.o\
+ ui.o ui_binding.o ui_draw.o ui_overlay.o evilloop.o ui_edit.o \
+@@ -10,12 +10,12 @@
+
+
+ hnb: libcli/libcli.a $(OBJS) Makefile
+- cc -o hnb $(OBJS) $(LIBS)
++ $(CC) -o hnb $(OBJS) $(LIBS)
+
+ ui_cli.c: cli_entries.inc cli_decls.inc
+
+ xml_debug: xml_tok.o xml_debug.o
+- cc -o xml_debug xml_tok.o xml_debug.o
++ $(CC) -o xml_debug xml_tok.o xml_debug.o
+
+ libcli/libcli.a: libcli/*.c
+ (cd libcli;make)
+@@ -32,7 +32,7 @@
+ rm -f xml_debug hnb $(OBJS) *~ cli_*.inc
+ (cd libcli;make clean)
+ hnb_p: *.c libcli/libcli_p.a
+- cc -o hnb_p *.c -pg -lncurses_p libcli/libcli_p.a -I.. -Ilibcli -DHAVE_CONFIG_H
++ $(CC) -o hnb_p *.c -pg $(LIBS) $(CFLAGS)
+
+ ps:
+ dot -Tps xml.dot > xml_states.ps
diff --git a/editors/hnb/files/patch-libcli::Makefile b/editors/hnb/files/patch-libcli::Makefile
new file mode 100644
index 000000000000..c2322afbf6ac
--- /dev/null
+++ b/editors/hnb/files/patch-libcli::Makefile
@@ -0,0 +1,26 @@
+--- libcli/Makefile.orig Fri Feb 14 13:29:46 2003
++++ libcli/Makefile Fri Feb 14 13:30:11 2003
+@@ -1,5 +1,3 @@
+-CFLAGS = -Wall -O3
+-
+ OBJS = cli.o cli_history.o
+
+ all: libcli.a libcli.so test-static test-shared
+@@ -9,12 +7,12 @@
+ libcli.a: $(OBJS)
+ ar rcs libcli.a cli*.o
+ libcli_p.a:
+- cc -pg -c cli.c
+- cc -pg -c cli_history.c
++ $(CC) -pg -c cli.c
++ $(CC) -pg -c cli_history.c
+ ar rcs libcli_p.a cli*.o
+ libcli.so: $(OBJS)
+- cc -shared cli*.o -o libcli.so $(CFLAGS) $(LIBS)
++ $(CC) -shared cli*.o -o libcli.so $(CFLAGS) $(LIBS)
+ test-static: test.o libcli.a
+- cc -o test-static test.o libcli.a $(CFLAGS) $(LIBS)
++ $(CC) -o test-static test.o libcli.a $(CFLAGS) $(LIBS)
+ test-shared: test.o libcli.so
+- cc -o test-shared test.o -L. -lcli $(CFLAGS) $(LIBS)
++ $(CC) -o test-shared test.o -L. -lcli $(CFLAGS) $(LIBS)