aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 10:34:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 10:34:46 +0000
commitf3381fa548d3edd4687bf4cf975577eeb10d68b7 (patch)
treea607b9b0948608d5c47edc8a47b7a82c47b30717 /editors
parent67375d16b1d5928bed929dcddfd6dcf003678869 (diff)
downloadports-f3381fa548d3edd4687bf4cf975577eeb10d68b7.tar.gz
ports-f3381fa548d3edd4687bf4cf975577eeb10d68b7.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299103
Diffstat (limited to 'editors')
-rw-r--r--editors/kile/Makefile10
-rw-r--r--editors/mp/Makefile30
-rw-r--r--editors/ted/Makefile6
-rw-r--r--editors/the/Makefile16
4 files changed, 31 insertions, 31 deletions
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 5c4368a76f75..c0f61dc01380 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -25,16 +25,18 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+OPTIONS_DEFINE= KPDF
+OPTIONS_DEFAULT= KPDF
+KPDF_DESC= Use KPDF and KDVI for viewing
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_KPDF)
+.if ${PORT_OPTIONS:MKPDF}
RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index 58a1bc5dd7c0..6ae402948c63 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -16,10 +16,10 @@ COMMENT= A programming text editor
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS= NLS "Native language support" on \
- GTK2 "Build with GTK2 support" off \
- QT4 "Build with QT4 support" off \
- PCRE "Build with PCRE support" on
+OPTIONS_DEFINE= NLS GUI PCRE DOCS
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= GTK2 QT4
+OPTIONS_DEFAULT= PCRE
WANT_GNOME= yes
USE_NCURSES= yes
@@ -34,25 +34,21 @@ DATADIR= ${PREFIX}/share/mp-5
.include <bsd.port.options.mk>
-.if defined(WITH_GTK2) && defined(WITH_QT4)
-IGNORE= GTK2 and QT4 GUIs are mutually exclusive. Please rerun 'make config' and disable one of these
-.endif
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --without-gettext
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --without-gettext
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
.else
CONFIGURE_ARGS+= --without-gtk
.endif
-.if defined(WITH_QT4)
+.if ${PORT_OPTIONS:MQT4}
USE_QT4= corelib gui moc_build
QT_NONSTANDARD= yes
CONFIGURE_ENV+= CPP="${CXX}" CCLINK="${CXX}"
@@ -60,7 +56,7 @@ CONFIGURE_ENV+= CPP="${CXX}" CCLINK="${CXX}"
CONFIGURE_ARGS+= --without-qt4
.endif
-.if !defined(WITHOUT_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre
.endif
@@ -87,14 +83,14 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/mp_*.mpsl ${DATADIR}
@${MKDIR} ${DATADIR}/lang
${INSTALL_DATA} ${WRKSRC}/lang/*.mpsl ${DATADIR}/lang
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
.for lang in de es it nl ru sv
@${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/po/${lang}.mo \
${PREFIX}/share/locale/${lang}/LC_MESSAGES/minimum-profit.mo
.endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS README RELEASE_NOTES mp_templates.sample doc/*.*
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index 2b98000d60cf..e18d16f441e2 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre \
paper.2:${PORTSDIR}/print/libpaper
RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
-OPTIONS= GTK "Use Gtk+ user intarface" off
+OPTIONS_DEFINE= GTK2 DOCS
WRKSRC= ${WRKDIR}/Ted-${PORTVERSION}
@@ -49,7 +49,7 @@ INDDIR= ${DATADIR}/dfa
.include <bsd.port.options.mk>
-.if defined(WITH_GTK)
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME= gtk20
CONFIGURE_ARGS+=--with-GTK
.else
@@ -81,7 +81,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/tedPackage/Ted/afm/*.afm ${AFMDIR}
@${MKDIR} ${INDDIR}
${INSTALL_DATA} ${WRKSRC}/tedPackage/Ted/dfa/*.dfa ${INDDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/tedPackage/Ted/TedDocument-en_US.rtf ${DOCSDIR}
.endif
diff --git a/editors/the/Makefile b/editors/the/Makefile
index 90a06be8a715..234c654a5192 100644
--- a/editors/the/Makefile
+++ b/editors/the/Makefile
@@ -27,8 +27,10 @@ ALL_TARGET= all html
MAN1= the.1
-OPTIONS= XAW3D "Enable Xaw3D" off \
- XCURSES "Build XCurses (X11) version" off
+OPTIONS_DEFINE= XAW3D XCURSES REXX_REGINA DOCS
+XAW3D_DESC= Enable Xaw3D
+XCURSES_DESC= Build XCurses (X11) version
+REXX_REGINA_DESC= Enable Rexx interpreter
.include <bsd.port.pre.mk>
@@ -36,12 +38,12 @@ OPTIONS= XAW3D "Enable Xaw3D" off \
BROKEN= Does not configure on powerpc
.endif
-.if defined(WITH_XAW3D)
+.if ${PORT_OPTIONS:MXAW3D}
CONFIGURE_ARGS+=--with-xaw3d
LIB_DEPENDS+= Xaw3d.8:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
-.if defined(WITH_XCURSES)
+.if ${PORT_OPTIONS:MXCURSES}
CONFIGURE_ARGS+=--with-xcurses \
--with-cursesincdir=${LOCALBASE}/include \
--with-curseslibdir=${LOCALBASE}/lib
@@ -52,7 +54,7 @@ PLIST_SUB= XCURSES="" NCURSES="@comment "
PLIST_SUB= XCURSES="@comment " NCURSES=""
.endif
-.if defined(WITH_REXX_REGINA)
+.if ${PORT_OPTIONS:MREXX_REGINA}
BUILD_DEPENDS+= regina:${PORTSDIR}/lang/rexx-regina
RUN_DEPENDS+= regina:${PORTSDIR}/lang/rexx-regina
CONFIGURE_ARGS+= --with-rexx=regina
@@ -63,12 +65,12 @@ CONFIGURE_ARGS+= --with-rexx=rexximc
.endif
post-install:
-.if defined(WITH_XCURSES)
+.if ${PORT_OPTIONS:MXCURSES}
@${LN} -sf xthe ${PREFIX}/bin/the
.else
@${LN} -sf nthe ${PREFIX}/bin/the
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${PREFIX}/share/doc/THE
${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/share/doc/THE
.endif