aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-07-11 01:17:35 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-07-11 01:17:35 +0000
commitf71ddd644e429d167650ad634cea06adfbfb6eb5 (patch)
treec04c808af7809845595400e19bdf6119732b5d51 /editors
parent43e14250978a985075556c500181e75c9a7c4015 (diff)
downloadports-f71ddd644e429d167650ad634cea06adfbfb6eb5.tar.gz
ports-f71ddd644e429d167650ad634cea06adfbfb6eb5.zip
- Construct CPP and CXXCPP from the existing variables.
- Pass CXXCPP as an environment variable for the configure script as it is only useful there at the moment. Actually, ports infrastructure ignores it.
Notes
Notes: svn path=/head/; revision=300745
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 57346e3e3d57..e40c0601adae 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -213,17 +213,18 @@ MANCOMPRESSED= yes
# XXX Clang PR13308 (http://llvm.org/bugs/show_bug.cgi?id=13308)
# Fixed in r159895 (http://llvm.org/viewvc/llvm-project?view=rev&revision=159895)
CC= /usr/bin/clang
-CXX= /usr/bin/clang++
-CXXCPP= /usr/bin/clang-cpp -x c++
CPP= /usr/bin/clang-cpp
+CXX= /usr/bin/clang++
+CXXCPP= ${CPP} -x c++
.else
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
USE_BINUTILS= yes
CC= ${LOCALBASE}/bin/clang
+CPP= ${CC} -E
CXX= ${LOCALBASE}/bin/clang++
-CXXCPP= ${LOCALBASE}/bin/clang++ -E
-CPP= ${LOCALBASE}/bin/clang -E
+CXXCPP= ${CXX} -E
.endif
+CONFIGURE_ENV+= CXXCPP="${CXXCPP}"
CONFIGURE_ARGS+= --with-system-cppunit
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit
#.endif