aboutsummaryrefslogtreecommitdiff
path: root/emulators/advancemame
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-02-25 15:12:40 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-02-25 15:12:40 +0000
commite375bed4fb45839a09d739702b4dbb04885a46a5 (patch)
treeaf6369ff9707caa8af4415365e53da6e933861d4 /emulators/advancemame
parent60f31a87fa52c72f8b6154859b08a90915738920 (diff)
downloadports-e375bed4fb45839a09d739702b4dbb04885a46a5.tar.gz
ports-e375bed4fb45839a09d739702b4dbb04885a46a5.zip
AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with an
advanced video support for helping the use with TVs, Arcade Monitors, Fixed Frequencies Monitors and also for PC Monitors. They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other platforms supported by the SDL library. The main difference compared with the official emulators is that the Advance versions are able to program directly the video board to always get a video mode with the correct size and frequency. Generally the Advance emulators are able to use a video mode which doesn't require any stretching or other unneeded effects to match the original arcade display. The direct video board programming is fully supported in Linux and DOS. It's partially supported in Windows. It isn't supported in Mac OS X and other platforms. See website for other improvements. WWW: http://advancemame.sourceforge.net/
Notes
Notes: svn path=/head/; revision=185890
Diffstat (limited to 'emulators/advancemame')
-rw-r--r--emulators/advancemame/Makefile56
-rw-r--r--emulators/advancemame/distinfo3
-rw-r--r--emulators/advancemame/pkg-descr22
-rw-r--r--emulators/advancemame/pkg-plist62
4 files changed, 143 insertions, 0 deletions
diff --git a/emulators/advancemame/Makefile b/emulators/advancemame/Makefile
new file mode 100644
index 000000000000..3f9db06a23dd
--- /dev/null
+++ b/emulators/advancemame/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: advancemame
+# Date created: 2007-01-10
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= advancemame
+PORTVERSION= 0.106.0
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= SDL MAME port with advanced TV and monitor video support
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GL= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -idirafter ${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= FREETYPE "Enable FreeType2 support" off \
+ SLANG "Enable sLang support (for video driver)" off
+
+MAN1= advdev.1 advj.1 advk.1 advm.1 advmame.1 advs.1
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+
+.if defined(WITH_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.else
+CONFIGURE_ARGS+=--disable-freetype
+.endif
+
+.if defined(WITH_SLANG)
+LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+.else
+CONFIGURE_ARGS+=--disable-slang
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's|^(pkg.*)/advance|\1/${PORTNAME}|' \
+ ${WRKSRC}/advance/advance.mak
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/pkgdocdir/d' ${WRKSRC}/advance/advance.mak
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/advancemame/distinfo b/emulators/advancemame/distinfo
new file mode 100644
index 000000000000..6b7610ca165e
--- /dev/null
+++ b/emulators/advancemame/distinfo
@@ -0,0 +1,3 @@
+MD5 (advancemame-0.106.0.tar.gz) = aa097a4a9046124e17aa83a215e454ea
+SHA256 (advancemame-0.106.0.tar.gz) = 2752b16ccbff2eb04b36ab4152901b9e483ef84f780b80596fb5fd1495bf6425
+SIZE (advancemame-0.106.0.tar.gz) = 16284344
diff --git a/emulators/advancemame/pkg-descr b/emulators/advancemame/pkg-descr
new file mode 100644
index 000000000000..4a03e51cf5ac
--- /dev/null
+++ b/emulators/advancemame/pkg-descr
@@ -0,0 +1,22 @@
+AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with an
+advanced video support for helping the use with TVs, Arcade Monitors, Fixed
+Frequencies Monitors and also for PC Monitors.
+
+They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other platforms
+supported by the SDL library.
+
+The main difference compared with the official emulators is that the Advance
+versions are able to program directly the video board to always get a video
+mode with the correct size and frequency.
+
+Generally the Advance emulators are able to use a video mode which doesn't
+require any stretching or other unneeded effects to match the original arcade
+display.
+
+The direct video board programming is fully supported in Linux and DOS. It's
+partially supported in Windows. It isn't supported in Mac OS X and other
+platforms.
+
+See website for other improvements.
+
+WWW: http://advancemame.sourceforge.net/
diff --git a/emulators/advancemame/pkg-plist b/emulators/advancemame/pkg-plist
new file mode 100644
index 000000000000..18bb23078a34
--- /dev/null
+++ b/emulators/advancemame/pkg-plist
@@ -0,0 +1,62 @@
+@exec for i in artwork crc image rom sample; do mkdir -p %D/%%DATADIR%%/${i}; done
+bin/advj
+bin/advk
+bin/advm
+bin/advmame
+bin/advs
+%%DATADIR%%/event.dat
+%%DATADIR%%/hiscore.dat
+%%DATADIR%%/history.dat
+%%PORTDOCS%%%%DOCSDIR%%/advcfg.html
+%%PORTDOCS%%%%DOCSDIR%%/advcfg.txt
+%%PORTDOCS%%%%DOCSDIR%%/advdev.html
+%%PORTDOCS%%%%DOCSDIR%%/advdev.txt
+%%PORTDOCS%%%%DOCSDIR%%/advj.html
+%%PORTDOCS%%%%DOCSDIR%%/advj.txt
+%%PORTDOCS%%%%DOCSDIR%%/advk.html
+%%PORTDOCS%%%%DOCSDIR%%/advk.txt
+%%PORTDOCS%%%%DOCSDIR%%/advline.html
+%%PORTDOCS%%%%DOCSDIR%%/advline.txt
+%%PORTDOCS%%%%DOCSDIR%%/advm.html
+%%PORTDOCS%%%%DOCSDIR%%/advm.txt
+%%PORTDOCS%%%%DOCSDIR%%/advmame.html
+%%PORTDOCS%%%%DOCSDIR%%/advmame.txt
+%%PORTDOCS%%%%DOCSDIR%%/advs.html
+%%PORTDOCS%%%%DOCSDIR%%/advs.txt
+%%PORTDOCS%%%%DOCSDIR%%/advv.html
+%%PORTDOCS%%%%DOCSDIR%%/advv.txt
+%%PORTDOCS%%%%DOCSDIR%%/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/authors.txt
+%%PORTDOCS%%%%DOCSDIR%%/build.html
+%%PORTDOCS%%%%DOCSDIR%%/build.txt
+%%PORTDOCS%%%%DOCSDIR%%/carddos.html
+%%PORTDOCS%%%%DOCSDIR%%/carddos.txt
+%%PORTDOCS%%%%DOCSDIR%%/cardlinx.html
+%%PORTDOCS%%%%DOCSDIR%%/cardlinx.txt
+%%PORTDOCS%%%%DOCSDIR%%/cardwin.html
+%%PORTDOCS%%%%DOCSDIR%%/cardwin.txt
+%%PORTDOCS%%%%DOCSDIR%%/cost.html
+%%PORTDOCS%%%%DOCSDIR%%/cost.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/histemu.html
+%%PORTDOCS%%%%DOCSDIR%%/histemu.txt
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/install.txt
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/reademu.html
+%%PORTDOCS%%%%DOCSDIR%%/reademu.txt
+%%PORTDOCS%%%%DOCSDIR%%/releemu.html
+%%PORTDOCS%%%%DOCSDIR%%/releemu.txt
+%%PORTDOCS%%%%DOCSDIR%%/script.html
+%%PORTDOCS%%%%DOCSDIR%%/script.txt
+%%PORTDOCS%%%%DOCSDIR%%/svgawin.html
+%%PORTDOCS%%%%DOCSDIR%%/svgawin.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/sample
+@dirrm %%DATADIR%%/rom
+@dirrm %%DATADIR%%/image
+@dirrm %%DATADIR%%/crc
+@dirrm %%DATADIR%%/artwork
+@dirrm %%DATADIR%%