aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-18 12:40:47 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-18 12:40:47 +0000
commit8ad4c6ed541cfc6ee1b391b5155181aca6254a67 (patch)
treeb47ea438039b728ce1199e3d47e78b37e6832771 /emulators/bochs
parent559d2fa969aa5ed56ab89033dc02e39f2650eaf8 (diff)
downloadports-8ad4c6ed541cfc6ee1b391b5155181aca6254a67.tar.gz
ports-8ad4c6ed541cfc6ee1b391b5155181aca6254a67.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile4
-rw-r--r--emulators/bochs/files/patch-iodev-eth_vde.cc12
2 files changed, 9 insertions, 7 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index d74df2dd36bd..57ae99770500 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -114,7 +114,6 @@ pre-patch::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_AMD64=yes\""
@${ECHO_MSG}
.endif
- @${ECHO_MSG}
post-patch:
@${REINPLACE_CMD} -E ' \
@@ -132,9 +131,6 @@ post-patch:
${WRKSRC}/doc/man/*.5
@${SED} 's|%%DOCSDIR%%|${DOCSDIR}|g' ${MSG_FILE} > ${PKGMESSAGE}
-# Post-install
-#
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/emulators/bochs/files/patch-iodev-eth_vde.cc b/emulators/bochs/files/patch-iodev-eth_vde.cc
index 9556d729027f..1512659d52b7 100644
--- a/emulators/bochs/files/patch-iodev-eth_vde.cc
+++ b/emulators/bochs/files/patch-iodev-eth_vde.cc
@@ -1,6 +1,6 @@
---- iodev/eth_vde.cc.orig Sat Dec 10 12:37:35 2005
-+++ iodev/eth_vde.cc Thu Mar 16 13:02:15 2006
-@@ -41,13 +41,17 @@
+--- iodev/eth_vde.cc.orig Sat Dec 10 16:37:35 2005
++++ iodev/eth_vde.cc Sat Mar 18 00:25:18 2006
+@@ -41,18 +41,22 @@
#include <sys/poll.h>
#include <sys/time.h>
#include <sys/resource.h>
@@ -19,3 +19,9 @@
#include <assert.h>
#include <fcntl.h>
#include <errno.h>
+ #include <unistd.h>
+-#include <stdint.h>
++#include <inttypes.h>
+
+ #define SWITCH_MAGIC 0xfeedface
+