aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2003-04-14 01:52:50 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2003-04-14 01:52:50 +0000
commitb86fda0dd0e122dabecf4ee9f0b6b841af60e1a8 (patch)
tree871e47736edaea1b9221059aad2537634e1d7978 /emulators/bochs
parentdb20e3c91aaa590ae2a592445e0108bdbd4cf989 (diff)
downloadports-b86fda0dd0e122dabecf4ee9f0b6b841af60e1a8.tar.gz
ports-b86fda0dd0e122dabecf4ee9f0b6b841af60e1a8.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index adfc8fc21043..6ccc715f37cd 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -56,6 +56,10 @@ WITH_BOCHS_CPU_LEVEL= 6
CONFIGURE_ARGS+= --enable-cpu-level=${WITH_BOCHS_CPU_LEVEL}
.endif
+.if defined(WITH_BOCHS_AMD64)
+CONFIGURE_ARGS+= --enable-x86-64
+.endif
+
.if defined(WITH_BOCHS_DEBUGGER)
CONFIGURE_ARGS+= --enable-debugger --enable-disasm
.endif
@@ -112,6 +116,11 @@ pre-everything::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_X86_DEBUGGER=yes\""
@${ECHO_MSG}
.endif
+.if !defined(WITH_BOCHS_AMD64)
+ @${ECHO_MSG} "If you want to compile with AMD x86-64 support."
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_AMD64=yes\""
+ @${ECHO_MSG}
+.endif
.if !defined(WITH_NE2000)
@${ECHO_MSG} "If you want to compile with networking (ne2000) support."
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_NE2000=yes\""