aboutsummaryrefslogtreecommitdiff
path: root/emulators/bsvc/Makefile
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1999-09-07 03:10:49 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1999-09-07 03:10:49 +0000
commitbacdfe64cd9b10b037eb5efb27ad7d0b50e514a1 (patch)
tree9b79a8f8f9f567d0cbb56af8da22dbf8f797824c /emulators/bsvc/Makefile
parentcacaf6688c5ca03e5ff81f8943ca43be35bd6498 (diff)
downloadports-bacdfe64cd9b10b037eb5efb27ad7d0b50e514a1.tar.gz
ports-bacdfe64cd9b10b037eb5efb27ad7d0b50e514a1.zip
Notes
Diffstat (limited to 'emulators/bsvc/Makefile')
-rw-r--r--emulators/bsvc/Makefile44
1 files changed, 10 insertions, 34 deletions
diff --git a/emulators/bsvc/Makefile b/emulators/bsvc/Makefile
index b8daaf335839..0addd8f822cc 100644
--- a/emulators/bsvc/Makefile
+++ b/emulators/bsvc/Makefile
@@ -1,50 +1,26 @@
# New ports collection Makefile for: bsvc
-# Version required: 2.0
+# Version required: 2.1
# Date created: 03-Mar-1997
-# Whom: tenser
+# Whom: tenser@spitfire.ecsel.psu.edu
#
# $FreeBSD$
#
-DISTNAME= bsvc-2.0
-CATEGORIES= emulators tk41
+DISTNAME= bsvc-2.1-src
+PKGNAME= bsvc-2.1
+CATEGORIES= emulators tk82
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= system/emulators
-EXTRACT_SUFX= -src.tar.z
-MAINTAINER= tenser@spitfire.ecsel.psu.edu
+MAINTAINER= jseger@FreeBSD.org
-RUN_DEPENDS= wish4.1:${PORTSDIR}/x11-toolkits/tk41
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+WRKSRC= ${WRKDIR}/${PKGNAME}/src
-WISH= wish4.1
-
-pre-patch:
- @${AWK} ' \
- { \
- if (/^## Makefile/) { \
- print "## Makefile.FreeBSD - System Dependent Makefile for FreeBSD" \
- } else { \
- print \
- } \
- }' < ${WRKSRC}/Makefile.ULTRIX > ${WRKSRC}/Makefile
+MAKE_ENV= PROJECT_BASE=${PREFIX} WRKSRC=${WRKSRC}
post-patch:
- @${AWK} ' \
- { \
- if (/PROJECT_BASE/ && /AWK_CHANGE_ME/) { \
- print "PROJECT_BASE='"${WRKDIR}/${DISTNAME}"'" \
- } else if (/INSTALL_DIR/ && /AWK_CHANGE_ME/) { \
- print "INSTALL_DIR='"${PREFIX}/bin"'" \
- } else if (/LIB_DIR/ && /AWK_CHANGE_ME/) { \
- print "LIB_DIR ='"${PREFIX}/lib/bsvc"'" \
- } else if (/WISH/ && /AWK_CHANGE_ME/) { \
- print "WISH='"${WISH}"'" \
- } else { \
- print \
- } \
- }' < ${WRKSRC}/Makefile.common > ${WRKSRC}/Makefile.common.tmp
- @${MV} -f ${WRKSRC}/Makefile.common.tmp ${WRKSRC}/Makefile.common
+ ${CP} ${WRKSRC}/Makefile.ULTRIX ${WRKSRC}/Makefile
.include <bsd.port.mk>