aboutsummaryrefslogtreecommitdiff
path: root/emulators/citra
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 19:46:26 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 20:30:19 +0000
commit295a84d82e2170abb4fc04a3faff427a8621ae9a (patch)
tree324e0f449c8a5ed5ec90a3825653cb9a65f8c44d /emulators/citra
parent99c21060926df8c58d9fa379f380290d05c77461 (diff)
downloadports-295a84d82e2170abb4fc04a3faff427a8621ae9a.tar.gz
ports-295a84d82e2170abb4fc04a3faff427a8621ae9a.zip
emulators/citra: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'emulators/citra')
-rw-r--r--emulators/citra/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index 5731ac4e5588..e5d902cdfbd3 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -92,15 +92,21 @@ QT5_PLIST_FILES=bin/${PORTNAME}-qt \
share/man/man6/${PORTNAME}-qt.6.gz \
share/mime/packages/${PORTNAME}.xml
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e '/check_submodules_present()/d' \
${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's/@GIT_BRANCH@/master/' \
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
${WRKSRC}/src/common/scm_rev.cpp.in
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+ @${REINPLACE_CMD} -e 's|std::unary_function|std::__unary_function|' \
+ ${WRKSRC}/externals/boost/boost/container_hash/hash.hpp
+.endif
post-configure:
@${CP} ${DISTFILES:M*\:gamedb:C/\:.*//:S,^,${_DISTDIR},} \
${BUILD_WRKSRC}/dist/compatibility_list/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>