aboutsummaryrefslogtreecommitdiff
path: root/emulators/cpmtools
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>1994-12-28 11:53:42 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>1994-12-28 11:53:42 +0000
commitd5ae87d0fa8304031152c748c67853b77674a78a (patch)
treef6b5fc40fb3aba401989e5a931478669a19a6e89 /emulators/cpmtools
parent0231da1390768772f6e105102d28b35570235526 (diff)
downloadports-d5ae87d0fa8304031152c748c67853b77674a78a.tar.gz
ports-d5ae87d0fa8304031152c748c67853b77674a78a.zip
Another attempt to import cpm(1).
Hope i got it right this time...
Notes
Notes: svn path=/head/; revision=639
Diffstat (limited to 'emulators/cpmtools')
-rw-r--r--emulators/cpmtools/Makefile20
-rw-r--r--emulators/cpmtools/files/patch-aa222
-rw-r--r--emulators/cpmtools/pkg-comment1
-rw-r--r--emulators/cpmtools/pkg-descr20
-rw-r--r--emulators/cpmtools/pkg-plist4
5 files changed, 267 insertions, 0 deletions
diff --git a/emulators/cpmtools/Makefile b/emulators/cpmtools/Makefile
new file mode 100644
index 000000000000..844a8ff17e22
--- /dev/null
+++ b/emulators/cpmtools/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: cpm(1)
+# Version required: 1.1
+# Date created: 25 December 1994
+# Whom: joerg
+#
+# $Id: Makefile,v 1.1.1.1 1994/12/26 15:23:47 joerg Exp $
+#
+
+DISTNAME= cpm-1.1
+WRKSRC= ${WRKDIR}/cpm
+
+#
+# need our own build target to pass PREFIX down to the make command
+#
+build:
+ @echo "===> Building for ${DISTNAME}"
+ @(cd ${WRKSRC}; ${MAKE} PREFIX=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} all)
+
+
+.include <bsd.port.mk>
diff --git a/emulators/cpmtools/files/patch-aa b/emulators/cpmtools/files/patch-aa
new file mode 100644
index 000000000000..63fb3274c114
--- /dev/null
+++ b/emulators/cpmtools/files/patch-aa
@@ -0,0 +1,222 @@
+diff -c -N ../cpm.orig/Makefile.inc ./Makefile.inc
+*** ../cpm.orig/Makefile.inc Thu Jan 1 01:00:00 1970
+--- ./Makefile.inc Mon Dec 26 10:17:54 1994
+***************
+*** 0 ****
+--- 1 ----
++ PREFIX ?= /usr/local
+diff -c -r ../cpm.orig/Makefile ./Makefile
+*** ../cpm.orig/Makefile Wed Jul 27 19:10:43 1983
+--- ./Makefile Mon Dec 26 09:55:13 1994
+***************
+*** 1,13 ****
+! # Makefile 4.2 83/07/27
+! #
+! DESTDIR=
+
+! all:
+! cd src; make ${MFLAGS}
+!
+! install: all
+! cd src; make ${MFLAGS} DESTDIR=${DESTDIR} install
+! cd man; make ${MFLAGS} DESTDIR=${DESTDIR} install
+!
+! clean:
+! cd src; make ${MFLAGS} clean
+--- 1,3 ----
+! SUBDIR = src man
+
+! .include <bsd.subdir.mk>
+Only in .: Makefile.inc
+diff -c -r ../cpm.orig/man/Makefile ./man/Makefile
+*** ../cpm.orig/man/Makefile Sat May 28 12:56:44 1994
+--- ./man/Makefile Mon Dec 26 10:00:13 1994
+***************
+*** 1,11 ****
+! all:;
+
+- #MANEXT=n
+- MANEXT=1
+- #MANDIR=/usr/man/man${MANEXT}
+- MANDIR=/usr/local/man/man${MANEXT}
+
+! install:
+! cp cpm.1 ${DESTDIR}/${MANDIR}/cpm.${MANEXT}
+
+! clean:;
+--- 1,14 ----
+! .include "${.CURDIR}/../Makefile.inc"
+
+
+! MANDIR = ${PREFIX}/man/man
+
+! MAN1 = cpm.1
+!
+! NOMANCOMPRESS = This will go into a .tgz archive, don't compress it!
+!
+! install: maninstall
+!
+! clean all depend:
+!
+! .include <bsd.man.mk>
+diff -c -r ../cpm.orig/src/Makefile ./src/Makefile
+*** ../cpm.orig/src/Makefile Sat May 28 09:10:55 1994
+--- ./src/Makefile Mon Dec 26 09:57:07 1994
+***************
+*** 1,128 ****
+! #
+! # Makefile 1.8 83/07/27
+! #
+! DEST = /usr/local/bin
+! DFLAG = -g -O2
+
+! HELPFILE = cpm.hlp
+! HELPFILEDIR = /usr/local/lib
+!
+! # CFLAGS = -O -DVAX ${DFLAG}
+! CFLAGS = ${DFLAG} -DHELPFILE=\"$(HELPFILEDIR)/$(HELPFILE)\" # -DDEBUG
+
+! EXTHDRS = /usr/include/ctype.h \
+! /usr/include/stdio.h
+!
+! HDRS = command.h \
+! cpmfio.h \
+! cpmio.h
+!
+! LDFLAGS =
+!
+! LIBLIST =
+!
+! LIST = ls -C
+!
+! LOADER = cc
+!
+! MAKEFILE = Makefile
+!
+! OBJS = bitmap.o \
+! blockio.o \
+! cclose.o \
+! ccreat.o \
+! cfillbuf.o \
+! cflsbuf.o \
+! cmdhdl.o \
+! copen.o \
+! copy.o \
+! cpm.o \
+! delete.o \
+! dirhdl.o \
+! extent.o \
+! ffc.o \
+! gensktab.o \
+! hexdmp.o \
+! interact.o \
+! physio.o \
+! pip.o \
+! rename.o
+!
+! PRINT = pr
+!
+! PROGRAM = cpm
+!
+! SRCS = bitmap.c \
+! blockio.c \
+! cclose.c \
+! ccreat.c \
+! cfillbuf.c \
+! cflsbuf.c \
+! cmdhdl.c \
+! copen.c \
+! copy.c \
+! cpm.c \
+! delete.c \
+! dirhdl.c \
+! extent.c \
+! ffc.c \
+! gensktab.c \
+! hexdmp.c \
+! interact.c \
+! physio.c \
+! pip.c \
+! rename.c
+!
+! $(PROGRAM): $(OBJS) $(LIBLIST)
+! @echo -n "Loading $(PROGRAM) ... "
+! @$(LOADER) $(LDFLAGS) $(OBJS) $(LIBLIST) -o $(PROGRAM)
+! @echo "done"
+!
+! debug:; @echo DFLAG = -g -DDEBUG > Makefile.tmp00
+! @cat makefile >>Makefile.tmp00
+! @make -f Makefile.tmp00
+! @rm -f Makefile.tmp00
+!
+! clean:; @rm -f $(OBJS)
+!
+! install: $(PROGRAM)
+! @echo Installing $(PROGRAM) in $(DEST)
+! @install -s $(PROGRAM) $(DEST)
+! @cp $(HELPFILE) $(HELPFILEDIR)
+!
+! depend:; @mkmf PROGRAM=$(PROGRAM) DEST=$(DEST)
+!
+! index:; @ctags -wx $(HDRS) $(SRCS)
+!
+! print:; @$(PRINT) $(HDRS) $(SRCS)
+!
+! program: $(PROGRAM)
+!
+! strip:; @strip $(PROGRAM)
+!
+! tags: $(SRCS); @ctags $(SRCS)
+!
+! update: $(DEST)/$(PROGRAM)
+!
+! $(DEST)/$(PROGRAM): $(SRCS) $(LIBLIST)
+! @make -f $(MAKEFILE) DEST=$(DEST) install
+! ###
+! bitmap.o: /usr/include/stdio.h cpmio.h
+! blockio.o: /usr/include/stdio.h cpmio.h
+! cclose.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! ccreat.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! cfillbuf.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! cflsbuf.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! cmdhdl.o: /usr/include/ctype.h /usr/include/stdio.h cpmio.h
+! copen.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! copy.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! cpm.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! delete.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! dirhdl.o: /usr/include/stdio.h cpmio.h
+! extent.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! gensktab.o: /usr/include/stdio.h cpmio.h
+! hexdmp.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! interact.o: /usr/include/stdio.h command.h
+! physio.o: /usr/include/stdio.h cpmio.h
+! pip.o: /usr/include/stdio.h cpmio.h cpmfio.h
+! rename.o: /usr/include/stdio.h cpmio.h cpmfio.h
+--- 1,27 ----
+! # include path for man page
+
+! .include "${.CURDIR}/../Makefile.inc"
+
+! HELPFILE = cpm.hlp
+! HELPFILEDIR = ${PREFIX}/lib
+! BINDIR = ${PREFIX}/bin
+! FILEMODE = 444
+!
+! CFLAGS += -DHELPFILE=\"${HELPFILEDIR}/${HELPFILE}\"
+! #CLFAGS += -DDEBUG
+!
+! PROG = cpm
+! NOMAN = look at ${.CURDIR}/../man
+!
+! SRCS = bitmap.c blockio.c cclose.c ccreat.c cfillbuf.c \
+! cflsbuf.c cmdhdl.c copen.c copy.c cpm.c delete.c \
+! dirhdl.c extent.c ffc.c gensktab.c hexdmp.c interact.c \
+! physio.c pip.c rename.c
+!
+!
+! install:
+! ${INSTALL} -c -m ${FILEMODE} -o ${BINOWN} -g ${BINGRP} \
+! ${.CURDIR}/${HELPFILE} ${HELPFILEDIR}
+! ${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} \
+! ${PROG} ${BINDIR}
+! .include <bsd.prog.mk>
diff --git a/emulators/cpmtools/pkg-comment b/emulators/cpmtools/pkg-comment
new file mode 100644
index 000000000000..6b253b5f16ef
--- /dev/null
+++ b/emulators/cpmtools/pkg-comment
@@ -0,0 +1 @@
+Utility to transfer files from/to CP/M (R) diskettes.
diff --git a/emulators/cpmtools/pkg-descr b/emulators/cpmtools/pkg-descr
new file mode 100644
index 000000000000..f7d797e66ac4
--- /dev/null
+++ b/emulators/cpmtools/pkg-descr
@@ -0,0 +1,20 @@
+Title: CPM
+
+Author: Helge Skrivervik, now (1994) helge@mellvik.no
+
+Description:
+
+Cpm lets UNIX users read and write standard cp/m 8" floppy disks and
+provides a cp/m like user interface for manipulating cp/m files.
+
+History:
+
+The program has been developed in 1983. Helge was kind enough to change
+the original copyright to a BSD-like one, so i've been able to port the
+program to FreeBSD and distribute it freely.
+
+Ported & maintained by: J"org Wunsch <joerg@FreeBSD.org>, 1994
+
+Frequently asked question:
+
+No, FreeBSD's floppy-disk driver does not (yet) understand FM diskettes.
diff --git a/emulators/cpmtools/pkg-plist b/emulators/cpmtools/pkg-plist
new file mode 100644
index 000000000000..faed0268864d
--- /dev/null
+++ b/emulators/cpmtools/pkg-plist
@@ -0,0 +1,4 @@
+@cwd /usr/local
+bin/cpm
+lib/cpm.hlp
+man/man1/cpm.1