aboutsummaryrefslogtreecommitdiff
path: root/emulators/dolphin-emu/Makefile
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2020-09-28 10:42:14 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2020-09-28 10:42:14 +0000
commitfdb3cafc5ad36322ea536212c6200ca27e0b7fc1 (patch)
treec5993bee60ec478beab4cca11da1c691f70ee397 /emulators/dolphin-emu/Makefile
parent94b1b9ba04a9cc681cbe8273647c435236d8e723 (diff)
downloadports-fdb3cafc5ad36322ea536212c6200ca27e0b7fc1.tar.gz
ports-fdb3cafc5ad36322ea536212c6200ca27e0b7fc1.zip
Update to 5.0.12247
Notes
Notes: svn path=/head/; revision=550417
Diffstat (limited to 'emulators/dolphin-emu/Makefile')
-rw-r--r--emulators/dolphin-emu/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index ce68b5ba40b2..9d1df03c39bc 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dolphin-emu
-PORTVERSION= 5.0.10960
-PORTREVISION= 1
+PORTVERSION= 5.0.12247
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
@@ -15,11 +14,12 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BROKEN_aarch64= fails to build: Source/Core/Common/ArmCPUDetect.cpp:5:10: fatal error: 'asm/hwcap.h' file not found
# Notes on dependencies:
+# - alsa support has been disabled (not optimal)
# - enet and soundtouch come from Externals/ as Dolphin's versions diverge
# (see comments in CMakeLists.txt)
-# - alsa support has been disabled (not optimal)
# Various problems that may be addressed in the future:
# - xxhash comes from Externals/ as it cannot be properly detected yet
+# - minizip comes from Externals/ as v>=2.0.0 is not available from ports yet
# - freesurround comes from Externals/ as it is not available from ports yet
# - cubeb comes from Externals/ as it is not available from ports yet
# - gtest detection is missing (Externals/ version enforced by CMakeLists.txt)
@@ -40,22 +40,25 @@ LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libminiupnpc.so:net/miniupnpc \
libmbedtls.so:security/mbedtls \
libcurl.so:ftp/curl \
- libhidapi.so:comms/hidapi
+ libhidapi.so:comms/hidapi \
+ libzstd.so:archivers/zstd \
+ libfmt.so:devel/libfmt
USES= cmake compiler:c++17-lang desktop-file-utils gl iconv \
pkgconfig qmake qt:5 sdl xorg
+# See: https://fr.dolphin-emu.org/download/?ref=btn
+# for latest beta version and associated commit
USE_GITHUB= yes
GH_PROJECT= dolphin
-GH_TAGNAME= 19ed641
+GH_TAGNAME= 9c12a84
USE_GL= gl glew glu
USE_SDL= sdl2
USE_XORG= ice sm x11 xext xi xrandr
USE_QT= buildtools_build core gui widgets
-CMAKE_ARGS+= -DTRY_X11:BOOL=ON \
- -DUSE_UPNP:BOOL=ON \
+CMAKE_ARGS+= -DUSE_UPNP:BOOL=ON \
-DENABLE_QT:BOOL=ON \
-DENABLE_ALSA:BOOL=OFF \
-DENABLE_PULSEAUDIO:BOOL=ON \