aboutsummaryrefslogtreecommitdiff
path: root/emulators/dolphin-emu
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2014-09-04 08:27:10 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2014-09-04 08:27:10 +0000
commit6d02d4ca51dd66f19ee92ce0acbe70bbd3071101 (patch)
tree2e0ba1850b6f117cca0fde464a2f7cbeb7e4c45b /emulators/dolphin-emu
parent4486d009590e7e5f50aa2ed8f58797f7c37906d1 (diff)
downloadports-6d02d4ca51dd66f19ee92ce0acbe70bbd3071101.tar.gz
ports-6d02d4ca51dd66f19ee92ce0acbe70bbd3071101.zip
Notes
Diffstat (limited to 'emulators/dolphin-emu')
-rw-r--r--emulators/dolphin-emu/Makefile10
-rw-r--r--emulators/dolphin-emu/distinfo4
-rw-r--r--emulators/dolphin-emu/files/patch-Source-Plugins-Plugin_VideoOGL-Src-Render.cpp11
3 files changed, 19 insertions, 6 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index deaf3345e635..6f2ea6a91a3b 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -2,11 +2,8 @@
# $FreeBSD$
PORTNAME= dolphin-emu
-PORTVERSION= 4.0.0
-PORTREVISION= 5
+PORTVERSION= 4.0.2
CATEGORIES= emulators
-MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
- LOCAL/martymac
MAINTAINER= martymac@FreeBSD.org
COMMENT= Gamecube and Wii Emulator
@@ -19,6 +16,11 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libSoundTouch.so:${PORTSDIR}/audio/soundtouch \
libpolarssl.so:${PORTSDIR}/security/polarssl
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}
+GH_PROJECT= dolphin
+GH_COMMIT= 88fabf7
+
USE_SDL= sdl
USE_XORG= ice xext x11 xrandr xi
USE_WX= 3.0+
diff --git a/emulators/dolphin-emu/distinfo b/emulators/dolphin-emu/distinfo
index b35fc5825456..8e284507a3da 100644
--- a/emulators/dolphin-emu/distinfo
+++ b/emulators/dolphin-emu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dolphin-emu-4.0.0.tgz) = b738bbad1555292efd4c517cd56ed084a5489575d6652e3f26739f9a5f95dcbe
-SIZE (dolphin-emu-4.0.0.tgz) = 20543858
+SHA256 (dolphin-emu-4.0.2.tgz) = 65a343acb1d02cac8337388303291518d84ca6e42639a5902fe8819e9ecbb9da
+SIZE (dolphin-emu-4.0.2.tgz) = 25123770
diff --git a/emulators/dolphin-emu/files/patch-Source-Plugins-Plugin_VideoOGL-Src-Render.cpp b/emulators/dolphin-emu/files/patch-Source-Plugins-Plugin_VideoOGL-Src-Render.cpp
new file mode 100644
index 000000000000..be5796ac3844
--- /dev/null
+++ b/emulators/dolphin-emu/files/patch-Source-Plugins-Plugin_VideoOGL-Src-Render.cpp
@@ -0,0 +1,11 @@
+--- Source/Plugins/Plugin_VideoOGL/Src/Render.cpp.orig 2014-09-02 16:22:19.000000000 +0200
++++ Source/Plugins/Plugin_VideoOGL/Src/Render.cpp 2014-09-02 16:24:58.000000000 +0200
+@@ -220,7 +220,7 @@
+ #endif
+ }
+
+-void GLAPIENTRY ErrorCallback( GLenum source, GLenum type, GLuint id, GLenum severity, GLsizei length, const char* message, void* userParam)
++void GLAPIENTRY ErrorCallback( GLenum source, GLenum type, GLuint id, GLenum severity, GLsizei length, const char* message, const void* userParam)
+ {
+ // GLES3 doesn't natively support this
+ // XXX: Include GLES2 extensions header so we can use this