aboutsummaryrefslogtreecommitdiff
path: root/emulators/dolphin-emu
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2018-12-13 21:28:15 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2018-12-13 21:28:15 +0000
commitb5d7c74f3724d96805923757803d2a84c019341b (patch)
treead675386dc3082aa5499f6ebbec1ac49c58ff079 /emulators/dolphin-emu
parent6950a6c2b208e84e459762dfbeb06001d684a921 (diff)
downloadports-b5d7c74f3724d96805923757803d2a84c019341b.tar.gz
ports-b5d7c74f3724d96805923757803d2a84c019341b.zip
Update to 5.0.9209 and re-enable SDL support
Notes
Notes: svn path=/head/; revision=487390
Diffstat (limited to 'emulators/dolphin-emu')
-rw-r--r--emulators/dolphin-emu/Makefile9
-rw-r--r--emulators/dolphin-emu/distinfo6
-rw-r--r--emulators/dolphin-emu/files/patch-CMakeLists.txt18
3 files changed, 15 insertions, 18 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index a4aa1ac9cad7..50af7248ac92 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dolphin-emu
-PORTVERSION= 5.0.8715
-PORTREVISION= 2
+PORTVERSION= 5.0.9209
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
@@ -20,8 +19,6 @@ LICENSE_FILE= ${WRKSRC}/license.txt
# - xxhash comes from Externals/ as it cannot be properly detected yet
# - gtest detection is missing (Externals/ version enforced by CMakeLists.txt)
# - cubeb comes from Externals/ as it is not available from ports yet
-# - sdl2 support is buggy and leads to an infinite wait when Dolphin starts:
-# ciface::SDL::PopulateDevices () at Source/Core/InputCommon/ControllerInterface/SDL/SDL.cpp:177
LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libavcodec.so:multimedia/ffmpeg \
libavdevice.so:multimedia/ffmpeg \
@@ -46,9 +43,10 @@ USES= cmake compiler:c++17-lang desktop-file-utils gl iconv \
USE_GITHUB= yes
GH_PROJECT= dolphin
-GH_TAGNAME= 5f0d825
+GH_TAGNAME= 2dcd058
USE_GL= gl glew glu
+USE_SDL= sdl2
USE_XORG= ice sm x11 xext xi xrandr
USE_QT= buildtools_build core gui widgets
@@ -58,7 +56,6 @@ CMAKE_ARGS+= -DTRY_X11:BOOL=ON \
-DENABLE_ALSA:BOOL=OFF \
-DENABLE_PULSEAUDIO:BOOL=ON \
-DUSE_DISCORD_PRESENCE:BOOL=OFF \
- -DENABLE_SDL:BOOL=OFF \
-DCMAKE_REQUIRED_INCLUDES:PATH="${LOCALBASE}/include" \
-DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib"
MAKE_ENV+= DESTDIR="${STAGEDIR}"
diff --git a/emulators/dolphin-emu/distinfo b/emulators/dolphin-emu/distinfo
index 05b4f50aa33a..13dc8e0ed6ea 100644
--- a/emulators/dolphin-emu/distinfo
+++ b/emulators/dolphin-emu/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536610912
-SHA256 (dolphin-emu-dolphin-5.0.8715-5f0d825_GH0.tar.gz) = d9cfc6b3ab5aeccfae8e78569580621c6a959291fea8c5e62dee7b0ca9c60cbd
-SIZE (dolphin-emu-dolphin-5.0.8715-5f0d825_GH0.tar.gz) = 36775798
+TIMESTAMP = 1544740825
+SHA256 (dolphin-emu-dolphin-5.0.9209-2dcd058_GH0.tar.gz) = 5958e6f524420aa39ca3e1073f4dac190b9b96f201892675b225aef8533eded8
+SIZE (dolphin-emu-dolphin-5.0.9209-2dcd058_GH0.tar.gz) = 38095095
diff --git a/emulators/dolphin-emu/files/patch-CMakeLists.txt b/emulators/dolphin-emu/files/patch-CMakeLists.txt
index 0c339bb6f41e..7f8b76bdd496 100644
--- a/emulators/dolphin-emu/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2018-09-17 22:39:14.470717000 +0200
-+++ CMakeLists.txt 2018-09-17 22:39:47.456106000 +0200
-@@ -92,7 +92,7 @@
- set(mandir ${CMAKE_INSTALL_PREFIX}/documentation/man CACHE PATH "mandir")
- else()
- set(datadir ${CMAKE_INSTALL_PREFIX}/share/dolphin-emu CACHE PATH "datadir")
-- set(mandir ${CMAKE_INSTALL_PREFIX}/share/man CACHE PATH "mandir")
-+ set(mandir ${CMAKE_INSTALL_PREFIX}/man CACHE PATH "mandir")
- endif()
+--- CMakeLists.txt.orig 2018-12-13 21:39:07.971867000 +0100
++++ CMakeLists.txt 2018-12-13 21:39:46.807545000 +0100
+@@ -93,7 +93,7 @@
+ # Set up paths
+ set(bindir ${CMAKE_INSTALL_PREFIX}/bin CACHE PATH "bindir")
+ set(datadir ${CMAKE_INSTALL_PREFIX}/share/dolphin-emu CACHE PATH "datadir")
+-set(mandir ${CMAKE_INSTALL_PREFIX}/share/man CACHE PATH "mandir")
++set(mandir ${CMAKE_INSTALL_PREFIX}/man CACHE PATH "mandir")
add_definitions(-DDATA_DIR="${datadir}/")
+ if(CMAKE_SYSROOT)