aboutsummaryrefslogtreecommitdiff
path: root/emulators/dps8m
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-08-19 17:52:41 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-08-19 17:57:38 +0000
commit37e7d652f24e942384ec593873d67ff4f553aaa9 (patch)
treedcbdb8ce97332d0f19dacfefc70dc52607c15123 /emulators/dps8m
parenta13e8d285c9195e769514732ea4493c90432e39f (diff)
downloadports-37e7d652f24e942384ec593873d67ff4f553aaa9.tar.gz
ports-37e7d652f24e942384ec593873d67ff4f553aaa9.zip
emulators/dps8m: Restore various port and build fixes
* Restore verbose build output * Restore build fixes for PPC64 and RISC-V * Disable optimization that overrides framework Approved by: portmgr (blanket, build fix)
Diffstat (limited to 'emulators/dps8m')
-rw-r--r--emulators/dps8m/Makefile7
-rw-r--r--emulators/dps8m/files/patch-src_Makefile.mk11
2 files changed, 18 insertions, 0 deletions
diff --git a/emulators/dps8m/Makefile b/emulators/dps8m/Makefile
index 4a2689879a58..748efbfd4bd4 100644
--- a/emulators/dps8m/Makefile
+++ b/emulators/dps8m/Makefile
@@ -1,6 +1,7 @@
PORTNAME= dps8m
DISTVERSIONPREFIX= R
DISTVERSION= 3.0.1
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= gspurki@gmail.com
@@ -20,12 +21,18 @@ LIB_DEPENDS= libuv.so:devel/libuv
USES= gmake
USE_GITLAB= yes
+CFLAGS_powerpc64= -Datomic_testandset_64=atomic_testandset_long
+CFLAGS_powerpc64le= -Datomic_testandset_64=atomic_testandset_long
+CFLAGS_riscv64= -Datomic_testandset_64=atomic_testandset_long
+
MAKEFILE= GNUmakefile
PLIST_FILES= bin/dps8 \
bin/prt2pdf \
bin/punutil
+MAKE_ARGS= V=1 NO_LTO=1
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dps8/dps8 ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/prt2pdf/prt2pdf ${STAGEDIR}${PREFIX}/bin
diff --git a/emulators/dps8m/files/patch-src_Makefile.mk b/emulators/dps8m/files/patch-src_Makefile.mk
new file mode 100644
index 000000000000..be9c3e886588
--- /dev/null
+++ b/emulators/dps8m/files/patch-src_Makefile.mk
@@ -0,0 +1,11 @@
+--- src/Makefile.mk.orig 2023-08-13 10:22:22 UTC
++++ src/Makefile.mk
+@@ -294,7 +294,7 @@ endif
+
+ _DEBUGOPTFLAG := -g
+ ifndef TESTING
+- OPTFLAGS = -O3 $(_DEBUGOPTFLAG) -U_FORTIFY_SOURCE -fno-stack-protector
++# OPTFLAGS = -O3 $(_DEBUGOPTFLAG) -U_FORTIFY_SOURCE -fno-stack-protector
+ ifdef DUMA
+ CFLAGS += -I../dps8 -I. -include dps8_duma.h
+ OPTFLAGS += -DDUMA=1