aboutsummaryrefslogtreecommitdiff
path: root/emulators/emu64
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-11-08 18:57:00 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-11-08 18:57:00 +0000
commit2bf27373327c9fb50709f0c6c445f95cf0a2a65f (patch)
tree7b54f84e1011da7f5ce9fbc0d12231a107ad2355 /emulators/emu64
parentc80f3d4c0678c9cadfe180608d5bd096dd712b7d (diff)
downloadports-2bf27373327c9fb50709f0c6c445f95cf0a2a65f.tar.gz
ports-2bf27373327c9fb50709f0c6c445f95cf0a2a65f.zip
archivers/quazip: update to 1.1
- fix / modify find calls and include directories in dependent ports
Notes
Notes: svn path=/head/; revision=554642
Diffstat (limited to 'emulators/emu64')
-rw-r--r--emulators/emu64/Makefile7
-rw-r--r--emulators/emu64/files/patch-src_src.pro11
-rw-r--r--emulators/emu64/files/patch-src_widget__file__browse.h13
3 files changed, 28 insertions, 3 deletions
diff --git a/emulators/emu64/Makefile b/emulators/emu64/Makefile
index bca54acfc629..660634ab3d8f 100644
--- a/emulators/emu64/Makefile
+++ b/emulators/emu64/Makefile
@@ -3,7 +3,7 @@
PORTNAME= emu64
PORTVERSION= 5.0.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MAINTAINER= felix@palmen-it.de
@@ -12,7 +12,7 @@ COMMENT= Commodore 64 emulator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libquazip5.so:archivers/quazip \
+LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip \
libpng.so:graphics/png \
libavcodec.so:multimedia/ffmpeg
@@ -21,7 +21,8 @@ USES= compiler:c++11-lang desktop-file-utils dos2unix gl pkgconfig \
USE_GL= gl glu
USE_QT= core gui widgets buildtools_build linguisttools_build
-DOS2UNIX_FILES= src/c64_class.cpp
+DOS2UNIX_FILES= src/c64_class.cpp \
+ src/widget_file_browse.h
USE_SDL= sdl2 image2
USE_GITHUB= yes
diff --git a/emulators/emu64/files/patch-src_src.pro b/emulators/emu64/files/patch-src_src.pro
new file mode 100644
index 000000000000..586df78af226
--- /dev/null
+++ b/emulators/emu64/files/patch-src_src.pro
@@ -0,0 +1,11 @@
+--- src/src.pro.orig 2020-11-08 17:21:01 UTC
++++ src/src.pro
+@@ -73,7 +73,7 @@ DEFINES += ZIP_SUPPORT=true
+ win32 {
+ PKGCONFIG += quazip
+ } else {
+- LIBS += -lquazip5
++ PKGCONFIG += quazip1-qt5
+ }
+
+ # Quelltexte
diff --git a/emulators/emu64/files/patch-src_widget__file__browse.h b/emulators/emu64/files/patch-src_widget__file__browse.h
new file mode 100644
index 000000000000..1c6e9eb8f825
--- /dev/null
+++ b/emulators/emu64/files/patch-src_widget__file__browse.h
@@ -0,0 +1,13 @@
+--- src/widget_file_browse.h.orig 2020-11-08 17:22:47 UTC
++++ src/widget_file_browse.h
+@@ -26,8 +26,8 @@
+ #include "quazip/quazip.h"
+ #include "quazip/quazipfile.h"
+ #else
+- #include "quazip5/quazip.h"
+- #include "quazip5/quazipfile.h"
++ #include "quazip/quazip.h"
++ #include "quazip/quazipfile.h"
+ #endif
+ #endif
+