aboutsummaryrefslogtreecommitdiff
path: root/emulators/emulationstation
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-01 17:49:58 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-01 17:49:58 +0000
commitcd99973f7cbc8dd2858a75e1161db0e81d4d4c40 (patch)
treeade80f49a54e69c729164a2c653109e99e623721 /emulators/emulationstation
parenta893eaca7711770587f55f2263d9c1fd46f0a3ff (diff)
downloadports-cd99973f7cbc8dd2858a75e1161db0e81d4d4c40.tar.gz
ports-cd99973f7cbc8dd2858a75e1161db0e81d4d4c40.zip
emulators/emulationstation: Update to 2.9.4
ChangeLog: https://github.com/RetroPie/EmulationStation/compare/v2.9.4...master PR: 251474 Submitted by: freebsd@coombscloud.com (maintainer)
Notes
Notes: svn path=/head/; revision=563600
Diffstat (limited to 'emulators/emulationstation')
-rw-r--r--emulators/emulationstation/Makefile19
-rw-r--r--emulators/emulationstation/distinfo6
-rw-r--r--emulators/emulationstation/files/patch-CMakeLists.txt23
-rw-r--r--emulators/emulationstation/files/patch-es-app_CMakeLists.txt14
-rw-r--r--emulators/emulationstation/files/patch-es-app_src_FileFilterIndex.h12
-rw-r--r--emulators/emulationstation/files/patch-es-app_src_MetaData.h13
-rw-r--r--emulators/emulationstation/files/patch-es-app_src_ScraperCmdLine.cpp6
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_InputConfig.h13
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_PowerSaver.cpp12
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_Settings.cpp13
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_Sound.h12
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_ThemeData.h13
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_resources_ResourceManager.cpp33
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_utils_FileSystemUtil.cpp39
-rw-r--r--emulators/emulationstation/files/patch-es-core_src_utils_TimeUtil.h10
-rw-r--r--emulators/emulationstation/pkg-plist68
16 files changed, 208 insertions, 98 deletions
diff --git a/emulators/emulationstation/Makefile b/emulators/emulationstation/Makefile
index 100cd927d718..c6d9f93f2610 100644
--- a/emulators/emulationstation/Makefile
+++ b/emulators/emulationstation/Makefile
@@ -2,8 +2,7 @@
PORTNAME= emulationstation
DISTVERSIONPREFIX= v
-DISTVERSION= 2.7.1
-PORTREVISION= 4
+DISTVERSION= 2.9.4
CATEGORIES= emulators
MAINTAINER= freebsd@coombscloud.com
@@ -14,6 +13,7 @@ LICENSE_COMB= multi
LICENSE_FILE_APACHE20= ${WRKSRC}/opensans_license.txt
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.md
+BUILD_DEPENDS= ${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libboost_filesystem.so:devel/boost-libs \
libboost_locale.so:devel/boost-libs \
@@ -31,12 +31,25 @@ GH_PROJECT= EmulationStation
USE_GL= gl glu
USE_SDL= sdl2
-PLIST_FILES= bin/emulationstation
PORTDOCS= CREDITS.md DEVNOTES.md GAMELISTS.md README.md SYSTEMS.md \
THEMES.md
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e 's|<pugixml/src/pugixml.hpp>|<pugixml.hpp>|g' \
+ ${WRKSRC}/es-app/src/CollectionSystemManager.cpp \
+ ${WRKSRC}/es-app/src/Gamelist.cpp \
+ ${WRKSRC}/es-app/src/MetaData.cpp \
+ ${WRKSRC}/es-app/src/SystemData.cpp \
+ ${WRKSRC}/es-app/src/scrapers/GamesDBJSONScraper.cpp \
+ ${WRKSRC}/es-app/src/scrapers/ScreenScraper.cpp \
+ ${WRKSRC}/es-core/src/InputConfig.cpp \
+ ${WRKSRC}/es-core/src/InputManager.cpp \
+ ${WRKSRC}/es-core/src/MameNames.cpp \
+ ${WRKSRC}/es-core/src/Settings.cpp \
+ ${WRKSRC}/es-core/src/ThemeData.cpp
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/emulators/emulationstation/distinfo b/emulators/emulationstation/distinfo
index d8c08dd74478..76331844b151 100644
--- a/emulators/emulationstation/distinfo
+++ b/emulators/emulationstation/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548463566
-SHA256 (RetroPie-EmulationStation-v2.7.1_GH0.tar.gz) = 07415511cc5abf36ba2e35d97bd2f651947040bcc8af9cffc491724a19afb214
-SIZE (RetroPie-EmulationStation-v2.7.1_GH0.tar.gz) = 1040103
+TIMESTAMP = 1606557422
+SHA256 (RetroPie-EmulationStation-v2.9.4_GH0.tar.gz) = 79452f6c1e8aaebe98c19708b3587a0a45330bf20b3301d556285d5cd756fa4a
+SIZE (RetroPie-EmulationStation-v2.9.4_GH0.tar.gz) = 852960
diff --git a/emulators/emulationstation/files/patch-CMakeLists.txt b/emulators/emulationstation/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7ccfc1448b9a
--- /dev/null
+++ b/emulators/emulationstation/files/patch-CMakeLists.txt
@@ -0,0 +1,23 @@
+--- CMakeLists.txt.orig 2020-11-01 21:39:18 UTC
++++ CMakeLists.txt
+@@ -16,6 +16,10 @@ endif()
+
+ project(emulationstation-all)
+
++# program name to be used as a reference when looking up resources
++set(AppDataName "EmulationStation" CACHE STRING "Internal program name passed to compiler")
++add_definitions(-DAPPDATANAME="${AppDataName}")
++
+ #-------------------------------------------------------------------------------
+ #add local find scripts to CMAKE path
+ LIST(APPEND CMAKE_MODULE_PATH
+@@ -244,6 +248,9 @@ set(dir ${CMAKE_CURRENT_SOURCE_DIR})
+ set(EXECUTABLE_OUTPUT_PATH ${dir} CACHE PATH "Build directory" FORCE)
+ set(LIBRARY_OUTPUT_PATH ${dir} CACHE PATH "Build directory" FORCE)
+
++# install rules for resources
++include(GNUInstallDirs)
++install(DIRECTORY resources DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/${AppDataName}/")
+
+ #-------------------------------------------------------------------------------
+ # add each component
diff --git a/emulators/emulationstation/files/patch-es-app_CMakeLists.txt b/emulators/emulationstation/files/patch-es-app_CMakeLists.txt
new file mode 100644
index 000000000000..410f96a18c7a
--- /dev/null
+++ b/emulators/emulationstation/files/patch-es-app_CMakeLists.txt
@@ -0,0 +1,14 @@
+--- es-app/CMakeLists.txt.orig 2020-11-29 16:39:56 UTC
++++ es-app/CMakeLists.txt
+@@ -143,9 +143,10 @@ endif()
+ #-------------------------------------------------------------------------------
+ # set up CPack install stuff so `make install` does something useful
+
++include(GNUInstallDirs)
+ install(TARGETS emulationstation
+ RUNTIME
+- DESTINATION bin)
++ DESTINATION "${CMAKE_INSTALL_BINDIR}")
+
+ INCLUDE(InstallRequiredSystemLibraries)
+
diff --git a/emulators/emulationstation/files/patch-es-app_src_FileFilterIndex.h b/emulators/emulationstation/files/patch-es-app_src_FileFilterIndex.h
deleted file mode 100644
index a7e97e6bae4d..000000000000
--- a/emulators/emulationstation/files/patch-es-app_src_FileFilterIndex.h
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix compiler error (missing include)
-
---- es-app/src/FileFilterIndex.h.orig 2018-08-11 01:19:16 UTC
-+++ es-app/src/FileFilterIndex.h
-@@ -4,6 +4,7 @@
-
- #include <map>
- #include <vector>
-+#include <string>
-
- class FileData;
-
diff --git a/emulators/emulationstation/files/patch-es-app_src_MetaData.h b/emulators/emulationstation/files/patch-es-app_src_MetaData.h
deleted file mode 100644
index 370e050f300d..000000000000
--- a/emulators/emulationstation/files/patch-es-app_src_MetaData.h
+++ /dev/null
@@ -1,13 +0,0 @@
-Use pugixml from ports, rather than embedded
-
---- es-app/src/MetaData.h.orig 2018-08-11 01:00:43 UTC
-+++ es-app/src/MetaData.h
-@@ -4,7 +4,7 @@
-
- #include <boost/date_time/posix_time/ptime.hpp>
- #include <boost/filesystem/path.hpp>
--#include <pugixml/src/pugixml.hpp>
-+#include <pugixml.hpp>
-
- enum MetaDataType
- {
diff --git a/emulators/emulationstation/files/patch-es-app_src_ScraperCmdLine.cpp b/emulators/emulationstation/files/patch-es-app_src_ScraperCmdLine.cpp
index 97e5087977ae..2c6672b70c39 100644
--- a/emulators/emulationstation/files/patch-es-app_src_ScraperCmdLine.cpp
+++ b/emulators/emulationstation/files/patch-es-app_src_ScraperCmdLine.cpp
@@ -1,6 +1,4 @@
-Use POSIX sleep funtion, instead of Windows
-
---- es-app/src/ScraperCmdLine.cpp.orig 2018-08-11 01:17:21 UTC
+--- es-app/src/ScraperCmdLine.cpp.orig 2020-11-29 11:43:15 UTC
+++ es-app/src/ScraperCmdLine.cpp
@@ -5,17 +5,13 @@
#include "SystemData.h"
@@ -14,7 +12,7 @@ Use POSIX sleep funtion, instead of Windows
std::ostream& out = std::cout;
- void handle_interrupt_signal(int p)
+ void handle_interrupt_signal(int /*p*/)
{
- sleep(50);
+ usleep(50);
diff --git a/emulators/emulationstation/files/patch-es-core_src_InputConfig.h b/emulators/emulationstation/files/patch-es-core_src_InputConfig.h
deleted file mode 100644
index b8b6e2cccd91..000000000000
--- a/emulators/emulationstation/files/patch-es-core_src_InputConfig.h
+++ /dev/null
@@ -1,13 +0,0 @@
-Use pugixml from ports, rather than embedded
-
---- es-core/src/InputConfig.h.orig 2018-08-11 01:03:59 UTC
-+++ es-core/src/InputConfig.h
-@@ -2,7 +2,7 @@
- #ifndef ES_CORE_INPUT_CONFIG_H
- #define ES_CORE_INPUT_CONFIG_H
-
--#include <pugixml/src/pugixml.hpp>
-+#include <pugixml.hpp>
- #include <SDL_joystick.h>
- #include <SDL_keyboard.h>
- #include <map>
diff --git a/emulators/emulationstation/files/patch-es-core_src_PowerSaver.cpp b/emulators/emulationstation/files/patch-es-core_src_PowerSaver.cpp
deleted file mode 100644
index 8b0818cb4927..000000000000
--- a/emulators/emulationstation/files/patch-es-core_src_PowerSaver.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix compiler error (missing include)
-
---- es-core/src/PowerSaver.cpp.orig 2018-08-11 01:13:24 UTC
-+++ es-core/src/PowerSaver.cpp
-@@ -2,6 +2,7 @@
-
- #include "AudioManager.h"
- #include "Settings.h"
-+#include <string>
-
- bool PowerSaver::mState = false;
- bool PowerSaver::mRunningScreenSaver = false;
diff --git a/emulators/emulationstation/files/patch-es-core_src_Settings.cpp b/emulators/emulationstation/files/patch-es-core_src_Settings.cpp
deleted file mode 100644
index 5d06111fe9bd..000000000000
--- a/emulators/emulationstation/files/patch-es-core_src_Settings.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-Use pugixml from ports, rather than embedded
-
---- es-core/src/Settings.cpp.orig 2018-08-11 01:05:37 UTC
-+++ es-core/src/Settings.cpp
-@@ -3,7 +3,7 @@
- #include "Log.h"
- #include "platform.h"
- #include <boost/filesystem/operations.hpp>
--#include <pugixml/src/pugixml.hpp>
-+#include <pugixml.hpp>
-
- Settings* Settings::sInstance = NULL;
-
diff --git a/emulators/emulationstation/files/patch-es-core_src_Sound.h b/emulators/emulationstation/files/patch-es-core_src_Sound.h
deleted file mode 100644
index 7d78d5ffdc14..000000000000
--- a/emulators/emulationstation/files/patch-es-core_src_Sound.h
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix compiler error (missing include)
-
---- es-core/src/Sound.h.orig 2018-08-11 01:14:12 UTC
-+++ es-core/src/Sound.h
-@@ -5,6 +5,7 @@
- #include "SDL_audio.h"
- #include <map>
- #include <memory>
-+#include <string>
-
- class ThemeData;
-
diff --git a/emulators/emulationstation/files/patch-es-core_src_ThemeData.h b/emulators/emulationstation/files/patch-es-core_src_ThemeData.h
deleted file mode 100644
index 6d5564cbf3ca..000000000000
--- a/emulators/emulationstation/files/patch-es-core_src_ThemeData.h
+++ /dev/null
@@ -1,13 +0,0 @@
-Use pugixml from ports, rather than embedded
-
---- es-core/src/ThemeData.h.orig 2018-08-11 01:03:37 UTC
-+++ es-core/src/ThemeData.h
-@@ -6,7 +6,7 @@
- #include <boost/filesystem/path.hpp>
- #include <boost/variant/get.hpp>
- #include <boost/variant/variant.hpp>
--#include <pugixml/src/pugixml.hpp>
-+#include <pugixml.hpp>
- #include <deque>
- #include <map>
- #include <sstream>
diff --git a/emulators/emulationstation/files/patch-es-core_src_resources_ResourceManager.cpp b/emulators/emulationstation/files/patch-es-core_src_resources_ResourceManager.cpp
new file mode 100644
index 000000000000..725cfcb07423
--- /dev/null
+++ b/emulators/emulationstation/files/patch-es-core_src_resources_ResourceManager.cpp
@@ -0,0 +1,33 @@
+--- es-core/src/resources/ResourceManager.cpp.orig 2020-11-29 16:33:50 UTC
++++ es-core/src/resources/ResourceManager.cpp
+@@ -3,6 +3,10 @@
+ #include "utils/FileSystemUtil.h"
+ #include <fstream>
+
++#ifndef APPDATANAME
++#define APPDATANAME "EmulationStation"
++#endif
++
+ auto array_deleter = [](unsigned char* p) { delete[] p; };
+ auto nop_deleter = [](unsigned char* /*p*/) { };
+
+@@ -26,6 +30,19 @@ std::string ResourceManager::getResourcePath(const std
+ if((path[0] == ':') && (path[1] == '/'))
+ {
+ std::string test;
++
++ // check in standard AppData locations
++ test = Utils::FileSystem::getHomePath() + "/.local/share/" + APPDATANAME + "/resources/" + &path[2];
++ if (Utils::FileSystem::exists(test))
++ return test;
++
++ test = std::string("/usr/local/share/") + APPDATANAME + "/resources/" + &path[2];
++ if (Utils::FileSystem::exists(test))
++ return test;
++
++ test = std::string("/usr/share/") + APPDATANAME + "/resources/" + &path[2];
++ if (Utils::FileSystem::exists(test))
++ return test;
+
+ // check in homepath
+ test = Utils::FileSystem::getHomePath() + "/.emulationstation/resources/" + &path[2];
diff --git a/emulators/emulationstation/files/patch-es-core_src_utils_FileSystemUtil.cpp b/emulators/emulationstation/files/patch-es-core_src_utils_FileSystemUtil.cpp
new file mode 100644
index 000000000000..ecdf735fba88
--- /dev/null
+++ b/emulators/emulationstation/files/patch-es-core_src_utils_FileSystemUtil.cpp
@@ -0,0 +1,39 @@
+--- es-core/src/utils/FileSystemUtil.cpp.orig 2020-11-29 11:37:59 UTC
++++ es-core/src/utils/FileSystemUtil.cpp
+@@ -577,10 +577,10 @@ namespace Utils
+ bool exists(const std::string& _path)
+ {
+ std::string path = getGenericPath(_path);
+- struct stat64 info;
++ struct stat info;
+
+ // check if stat64 succeeded
+- return (stat64(path.c_str(), &info) == 0);
++ return (stat(path.c_str(), &info) == 0);
+
+ } // exists
+
+@@ -599,10 +599,10 @@ namespace Utils
+ bool isRegularFile(const std::string& _path)
+ {
+ std::string path = getGenericPath(_path);
+- struct stat64 info;
++ struct stat info;
+
+ // check if stat64 succeeded
+- if(stat64(path.c_str(), &info) != 0)
++ if(stat(path.c_str(), &info) != 0)
+ return false;
+
+ // check for S_IFREG attribute
+@@ -670,8 +670,8 @@ namespace Utils
+ } // isHidden
+ #ifndef WIN32 // osx / linux
+ bool isExecutable(const std::string& _path) {
+- struct stat64 st;
+- if(stat64(_path.c_str(), &st) == 0){
++ struct stat st;
++ if(stat(_path.c_str(), &st) == 0){
+ mode_t perm = st.st_mode;
+ // regular files and executables but not setuid, setgid, shared text (mode 0755)
+ mode_t mask = S_IFREG | S_IRWXU | S_IRGRP | S_IXGRP | S_IROTH | S_IXOTH;
diff --git a/emulators/emulationstation/files/patch-es-core_src_utils_TimeUtil.h b/emulators/emulationstation/files/patch-es-core_src_utils_TimeUtil.h
new file mode 100644
index 000000000000..21e8131fcb9e
--- /dev/null
+++ b/emulators/emulationstation/files/patch-es-core_src_utils_TimeUtil.h
@@ -0,0 +1,10 @@
+--- es-core/src/utils/TimeUtil.h.orig 2020-11-29 11:32:59 UTC
++++ es-core/src/utils/TimeUtil.h
+@@ -3,6 +3,7 @@
+ #define ES_CORE_UTILS_TIME_UTIL_H
+
+ #include <string>
++#include <time.h>
+
+ namespace Utils
+ {
diff --git a/emulators/emulationstation/pkg-plist b/emulators/emulationstation/pkg-plist
new file mode 100644
index 000000000000..93318c21a7ac
--- /dev/null
+++ b/emulators/emulationstation/pkg-plist
@@ -0,0 +1,68 @@
+bin/emulationstation
+share/EmulationStation/resources/arrow.svg
+share/EmulationStation/resources/busy_0.svg
+share/EmulationStation/resources/busy_1.svg
+share/EmulationStation/resources/busy_2.svg
+share/EmulationStation/resources/busy_3.svg
+share/EmulationStation/resources/button.png
+share/EmulationStation/resources/button_filled.png
+share/EmulationStation/resources/cartridge.svg
+share/EmulationStation/resources/checkbox_checked.svg
+share/EmulationStation/resources/checkbox_unchecked.svg
+share/EmulationStation/resources/fav_add.svg
+share/EmulationStation/resources/fav_remove.svg
+share/EmulationStation/resources/folder.svg
+share/EmulationStation/resources/frame.png
+share/EmulationStation/resources/help/analog_down.svg
+share/EmulationStation/resources/help/analog_left.svg
+share/EmulationStation/resources/help/analog_right.svg
+share/EmulationStation/resources/help/analog_stick.svg
+share/EmulationStation/resources/help/analog_thumb.svg
+share/EmulationStation/resources/help/analog_up.svg
+share/EmulationStation/resources/help/button_1.svg
+share/EmulationStation/resources/help/button_2.svg
+share/EmulationStation/resources/help/button_3.svg
+share/EmulationStation/resources/help/button_4.svg
+share/EmulationStation/resources/help/button_a.svg
+share/EmulationStation/resources/help/button_b.svg
+share/EmulationStation/resources/help/button_circle.svg
+share/EmulationStation/resources/help/button_cross.svg
+share/EmulationStation/resources/help/button_hotkey.svg
+share/EmulationStation/resources/help/button_l.svg
+share/EmulationStation/resources/help/button_lr.svg
+share/EmulationStation/resources/help/button_lt.svg
+share/EmulationStation/resources/help/button_r.svg
+share/EmulationStation/resources/help/button_rt.svg
+share/EmulationStation/resources/help/button_select.svg
+share/EmulationStation/resources/help/button_square.svg
+share/EmulationStation/resources/help/button_start.svg
+share/EmulationStation/resources/help/button_triangle.svg
+share/EmulationStation/resources/help/button_x.svg
+share/EmulationStation/resources/help/button_y.svg
+share/EmulationStation/resources/help/buttons_east.svg
+share/EmulationStation/resources/help/buttons_north.svg
+share/EmulationStation/resources/help/buttons_south.svg
+share/EmulationStation/resources/help/buttons_west.svg
+share/EmulationStation/resources/help/dpad_all.svg
+share/EmulationStation/resources/help/dpad_down.svg
+share/EmulationStation/resources/help/dpad_left.svg
+share/EmulationStation/resources/help/dpad_leftright.svg
+share/EmulationStation/resources/help/dpad_right.svg
+share/EmulationStation/resources/help/dpad_up.svg
+share/EmulationStation/resources/help/dpad_updown.svg
+share/EmulationStation/resources/mamebioses.xml
+share/EmulationStation/resources/mamedevices.xml
+share/EmulationStation/resources/mamenames.xml
+share/EmulationStation/resources/off.svg
+share/EmulationStation/resources/on.svg
+share/EmulationStation/resources/opensans_hebrew_condensed_light.ttf
+share/EmulationStation/resources/opensans_hebrew_condensed_regular.ttf
+share/EmulationStation/resources/option_arrow.svg
+share/EmulationStation/resources/scroll_gradient.png
+share/EmulationStation/resources/slider_knob.svg
+share/EmulationStation/resources/splash.svg
+share/EmulationStation/resources/star_filled.svg
+share/EmulationStation/resources/star_unfilled.svg
+share/EmulationStation/resources/textinput_ninepatch.png
+share/EmulationStation/resources/textinput_ninepatch_active.png
+share/EmulationStation/resources/window_icon_256.png