aboutsummaryrefslogtreecommitdiff
path: root/emulators/fceux
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-19 08:18:03 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-19 08:18:03 +0000
commit43bbb124d254b6abe06afabac908973a80f95f45 (patch)
treedc647c5cb49901ecbf4faa5ebfc83c559c393e7b /emulators/fceux
parentd5972a4eb5269c9f37db737f54bd1a518b19cfd0 (diff)
downloadports-43bbb124d254b6abe06afabac908973a80f95f45.tar.gz
ports-43bbb124d254b6abe06afabac908973a80f95f45.zip
Notes
Diffstat (limited to 'emulators/fceux')
-rw-r--r--emulators/fceux/Makefile6
-rw-r--r--emulators/fceux/distinfo4
-rw-r--r--emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c20
3 files changed, 26 insertions, 4 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index 1d1398a90371..8310eb7406c3 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.8
+PORTVERSION= 0.98.10
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://fceultra.sourceforge.net/releases/
MASTER_SITE_SUBDIR= fceultra
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -19,6 +20,7 @@ USE_SDL= sdl
MAN6= fceu.6
WRKSRC= ${WRKDIR}/fceu
USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index ac68286bb6b5..36bfa681216f 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,2 +1,2 @@
-MD5 (fceu-0.98.8.src.tar.gz) = cffb95097a256da18748865e52a828d8
-SIZE (fceu-0.98.8.src.tar.gz) = 666950
+MD5 (fceu-0.98.10.src.tar.bz2) = e0b396955b3ef4c7e4b5cc518cdec39f
+SIZE (fceu-0.98.10.src.tar.bz2) = 559750
diff --git a/emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c b/emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c
new file mode 100644
index 000000000000..dbf70d19e1a1
--- /dev/null
+++ b/emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c
@@ -0,0 +1,20 @@
+--- src/drivers/pc/unix-netplay.c.orig Sun May 16 22:28:06 2004
++++ src/drivers/pc/unix-netplay.c Tue May 18 12:57:05 2004
+@@ -24,7 +24,7 @@
+ #include <sys/socket.h>
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+ #include <arpa/inet.h>
+@@ -42,6 +42,8 @@
+ #ifndef socklen_t
+ #define socklen_t int
+ #endif
++
++#define SOL_TCP IPPROTO_TCP
+
+ char *netplayhost=0;
+ char *netplaynick=0;