aboutsummaryrefslogtreecommitdiff
path: root/emulators/fceux
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-28 17:32:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-28 17:32:40 +0000
commitd352da8f3f9c618648d5a90c1264a1c117e2c3d5 (patch)
tree9997f1b36a066703f6e871aebad52de3a7cc4e15 /emulators/fceux
parenta01b5e39ad6caca73a5c2bf1fe62f1d12ca4c86d (diff)
downloadports-d352da8f3f9c618648d5a90c1264a1c117e2c3d5.tar.gz
ports-d352da8f3f9c618648d5a90c1264a1c117e2c3d5.zip
Notes
Diffstat (limited to 'emulators/fceux')
-rw-r--r--emulators/fceux/Makefile4
-rw-r--r--emulators/fceux/files/patch-configure52
-rw-r--r--emulators/fceux/files/patch-configure.ac13
3 files changed, 62 insertions, 7 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index 2015ef39632e..28d63c9034b1 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -35,10 +35,6 @@ PLIST_DIRS= %%DOCSDIR%%
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not configure"
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= "Does not compile on sparc64"
.endif
diff --git a/emulators/fceux/files/patch-configure b/emulators/fceux/files/patch-configure
index 50d608465fc1..16d3c59c5218 100644
--- a/emulators/fceux/files/patch-configure
+++ b/emulators/fceux/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig Tue Dec 21 13:25:09 2004
-+++ configure Tue Dec 21 13:25:36 2004
-@@ -5130,7 +5130,7 @@
+--- configure.orig Wed Sep 15 20:31:55 2004
++++ configure Mon Feb 28 08:45:42 2005
+@@ -308,7 +308,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CPP CCAS CCASFLAGS CXX CXXFLAGS ac_ct_CXX CXXDEPMODE CXXCPP WIN32_TRUE WIN32_FALSE UNIX_TRUE UNIX_FALSE USE_SEXYAL_TRUE USE_SEXYAL_FALSE NATIVEWIN32_TRUE NATIVEWIN32_FALSE OPENGL_TRUE OPENGL_FALSE HAVE_GTK_TRUE HAVE_GTK_FALSE EGREP SDL_CONFIG SDL_CFLAGS SDL_LIBS C80x86_TRUE C80x86_FALSE LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CPP CCAS CCASFLAGS CXX CXXFLAGS ac_ct_CXX CXXDEPMODE CXXCPP WIN32_TRUE WIN32_FALSE UNIX_TRUE UNIX_FALSE USE_SEXYAL_TRUE USE_SEXYAL_FALSE NATIVEWIN32_TRUE NATIVEWIN32_FALSE OPENGL_TRUE OPENGL_FALSE HAVE_GTK_TRUE HAVE_GTK_FALSE EGREP SDL_CONFIG SDL_CFLAGS SDL_LIBS LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -5130,21 +5130,11 @@
fi
@@ -9,3 +18,40 @@
cat >>confdefs.h <<\_ACEOF
#define C80x86 1
_ACEOF
+
+-
+-
+-if true; then
+- C80x86_TRUE=
+- C80x86_FALSE='#'
+-else
+- C80x86_TRUE='#'
+- C80x86_FALSE=
+-fi
+-
+ fi
+
+ echo "$as_me:$LINENO: checking whether byte ordering is bigendian" >&5
+@@ -5589,13 +5579,6 @@
+ Usually this means the macro was only invoked conditionally." >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+-if test -z "${C80x86_TRUE}" && test -z "${C80x86_FALSE}"; then
+- { { echo "$as_me:$LINENO: error: conditional \"C80x86\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&5
+-echo "$as_me: error: conditional \"C80x86\" was never defined.
+-Usually this means the macro was only invoked conditionally." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+
+ : ${CONFIG_STATUS=./config.status}
+ ac_clean_files_save=$ac_clean_files
+@@ -6188,8 +6171,6 @@
+ s,@SDL_CONFIG@,$SDL_CONFIG,;t t
+ s,@SDL_CFLAGS@,$SDL_CFLAGS,;t t
+ s,@SDL_LIBS@,$SDL_LIBS,;t t
+-s,@C80x86_TRUE@,$C80x86_TRUE,;t t
+-s,@C80x86_FALSE@,$C80x86_FALSE,;t t
+ s,@LIBOBJS@,$LIBOBJS,;t t
+ s,@LTLIBOBJS@,$LTLIBOBJS,;t t
+ CEOF
diff --git a/emulators/fceux/files/patch-configure.ac b/emulators/fceux/files/patch-configure.ac
new file mode 100644
index 000000000000..d75bfb586ecd
--- /dev/null
+++ b/emulators/fceux/files/patch-configure.ac
@@ -0,0 +1,13 @@
+--- configure.ac.orig Sat Sep 11 14:32:25 2004
++++ configure.ac Mon Feb 28 08:46:24 2005
+@@ -114,9 +114,8 @@
+ fi
+
+
+-if expr match "$target_cpu" 'i.86' > /dev/null; then
++if echo ${target_cpu} | grep -q 'i.86' > /dev/null; then
+ AC_DEFINE([C80x86])
+- AM_CONDITIONAL(C80x86, true)
+ fi
+
+ AC_C_BIGENDIAN([], [AC_DEFINE([LSB_FIRST])])