aboutsummaryrefslogtreecommitdiff
path: root/emulators/fuse
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-09-23 16:42:30 +0000
committerRene Ladan <rene@FreeBSD.org>2013-09-23 16:42:30 +0000
commit5f26a0047137bb7ac5c46bdd6668eeb6bc83d276 (patch)
tree5721582639406da27f4f0b7d1345bea1efd4c7a4 /emulators/fuse
parenta81009fc18437e65743407e6cd8bd9cc8639e103 (diff)
downloadports-5f26a0047137bb7ac5c46bdd6668eeb6bc83d276.tar.gz
ports-5f26a0047137bb7ac5c46bdd6668eeb6bc83d276.zip
Let my ports pass 'make check-sanity' by using modern LIB_DEPENDS
Notes
Notes: svn path=/head/; revision=328021
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 33bf066b3d32..f4a51e4f535f 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -11,9 +11,9 @@ COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LICENSE= GPLv2
-LIB_DEPENDS= spectrum:${PORTSDIR}/emulators/libspectrum \
- png15:${PORTSDIR}/graphics/png \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libspectrum.so:${PORTSDIR}/emulators/libspectrum \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USES= pkgconfig
@@ -35,13 +35,13 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--with-libao
-LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= libao.so:${PORTSDIR}/audio/libao
.else
CONFIGURE_ARGS+=--without-libao
.endif
.if ${PORT_OPTIONS:MSAMPLERATE}
-LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
+LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+=--without-libsamplerate
.endif