aboutsummaryrefslogtreecommitdiff
path: root/emulators/gbe
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2001-04-16 13:11:50 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2001-04-16 13:11:50 +0000
commit31c44476a8a3a38ff60032fb452d013eba568fa1 (patch)
tree4e8b3d6836922c3ec58f0ab48060b62c13cab43b /emulators/gbe
parent680a234ce5a8d955995c9a17c7a46396dcf2fcc9 (diff)
downloadports-31c44476a8a3a38ff60032fb452d013eba568fa1.tar.gz
ports-31c44476a8a3a38ff60032fb452d013eba568fa1.zip
New Nintendo Gameboy(TM) emulmulator.
Notes
Notes: svn path=/head/; revision=41461
Diffstat (limited to 'emulators/gbe')
-rw-r--r--emulators/gbe/Makefile24
-rw-r--r--emulators/gbe/distinfo1
-rw-r--r--emulators/gbe/files/patch-aa10
-rw-r--r--emulators/gbe/files/patch-ab10
-rw-r--r--emulators/gbe/pkg-comment1
-rw-r--r--emulators/gbe/pkg-descr1
-rw-r--r--emulators/gbe/pkg-plist1
7 files changed, 48 insertions, 0 deletions
diff --git a/emulators/gbe/Makefile b/emulators/gbe/Makefile
new file mode 100644
index 000000000000..8a8c1efd0c29
--- /dev/null
+++ b/emulators/gbe/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gbe
+# Date created: 16 April 2001
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gbe
+PORTVERSION= 0.0.22
+CATEGORIES= emulators
+MASTER_SITES= http://www.zophar.net/unix/Files/
+
+MAINTAINER= nakai@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_X_PREFIX= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gbe ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/emulators/gbe/distinfo b/emulators/gbe/distinfo
new file mode 100644
index 000000000000..d4b53e289a5f
--- /dev/null
+++ b/emulators/gbe/distinfo
@@ -0,0 +1 @@
+MD5 (gbe-0.0.22.tar.gz) = eb78d06c95b6e43210dd8232a3215577
diff --git a/emulators/gbe/files/patch-aa b/emulators/gbe/files/patch-aa
new file mode 100644
index 000000000000..0aa72cececc3
--- /dev/null
+++ b/emulators/gbe/files/patch-aa
@@ -0,0 +1,10 @@
+--- Makefile.orig Mon Apr 16 21:07:21 2001
++++ Makefile Mon Apr 16 21:13:21 2001
+@@ -1,5 +1,5 @@
+-LFLAGS = -L/usr/X11R6/lib -lX11 -g3 -lreadline -lncurses -lvga
+-CFLAGS = -O6 -DBUILD_SVGA -DBUILD_X11 -DBUILD_JLIB -DCPU_DEBUG -g3 -ffast-math -fomit-frame-pointer -finline-functions #-DNOT_LINEBASED #-DCPU_DEBUG_EXTENDED
++LFLAGS = -L/usr/X11R6/lib -lX11 -g3 -lgnugetopt -L/usr/local/lib
++CFLAGS = -I/usr/X11R6/include -I/usr/local/include -O6 -DBUILD_X11 -g3 -ffast-math -fomit-frame-pointer -finline-functions #-DNOT_LINEBASED #-DCPU_DEBUG_EXTENDED
+ OBJS = main.o rom.o mem.o cpu.o vram.o debug.o joypad.o jlib.o x11.o svga.o
+ BIN = gbe
+
diff --git a/emulators/gbe/files/patch-ab b/emulators/gbe/files/patch-ab
new file mode 100644
index 000000000000..e8e469ed273a
--- /dev/null
+++ b/emulators/gbe/files/patch-ab
@@ -0,0 +1,10 @@
+--- vram.c.orig Mon Apr 16 22:12:03 2001
++++ vram.c Mon Apr 16 22:12:08 2001
+@@ -31,7 +31,6 @@
+ #include "cpu.h"
+ #include "data.h"
+ #include "x11.h"
+-#include "svga.h"
+ #include "win32.h"
+ #include "joypad.h"
+
diff --git a/emulators/gbe/pkg-comment b/emulators/gbe/pkg-comment
new file mode 100644
index 000000000000..3f9f9ac490c2
--- /dev/null
+++ b/emulators/gbe/pkg-comment
@@ -0,0 +1 @@
+Nintendo GameBoy(tm) emulator with GNU source code
diff --git a/emulators/gbe/pkg-descr b/emulators/gbe/pkg-descr
new file mode 100644
index 000000000000..3f9f9ac490c2
--- /dev/null
+++ b/emulators/gbe/pkg-descr
@@ -0,0 +1 @@
+Nintendo GameBoy(tm) emulator with GNU source code
diff --git a/emulators/gbe/pkg-plist b/emulators/gbe/pkg-plist
new file mode 100644
index 000000000000..05004ac66e65
--- /dev/null
+++ b/emulators/gbe/pkg-plist
@@ -0,0 +1 @@
+bin/gbe