aboutsummaryrefslogtreecommitdiff
path: root/emulators/gngb
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2002-07-30 11:55:28 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2002-07-30 11:55:28 +0000
commit4bd162e8abdbb60cb7aa168924da9dbc3bc2cbd7 (patch)
tree0584aad9efe3221fba6911627a66f5dc000fc404 /emulators/gngb
parent1aa1a998b33b1afe6783713eba0b7e92341e74c7 (diff)
downloadports-4bd162e8abdbb60cb7aa168924da9dbc3bc2cbd7.tar.gz
ports-4bd162e8abdbb60cb7aa168924da9dbc3bc2cbd7.zip
Update to 20020111
PR: ports/39215 Submitted by: Michael Nottebrock <michaelnottebrock@gmx.net>
Notes
Notes: svn path=/head/; revision=63728
Diffstat (limited to 'emulators/gngb')
-rw-r--r--emulators/gngb/Makefile43
-rw-r--r--emulators/gngb/distinfo2
-rw-r--r--emulators/gngb/files/patch-aa30
3 files changed, 33 insertions, 42 deletions
diff --git a/emulators/gngb/Makefile b/emulators/gngb/Makefile
index 36906064e293..f8f024644dbd 100644
--- a/emulators/gngb/Makefile
+++ b/emulators/gngb/Makefile
@@ -6,24 +6,45 @@
#
PORTNAME= gngb
-PORTVERSION= 20010318
+PORTVERSION= 20020111
CATEGORIES= emulators
-MASTER_SITES= http://frogus.multimania.com/
-DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+MASTER_SITES= http://membres.lycos.fr/frogus/gngb/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= nakai@FreeBSD.org
LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
+GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_XLIB= yes
USE_X_PREFIX= yes
-
-post-patch:
- perl -pi -e 's/<SDL\//<SDL11\//' ${WRKSRC}/*.[ch]
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gngb ${PREFIX}/bin
+CONFIGURE_ENV= CFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
+PORT_CFLAGS= -DSDL_YUV -I${LOCALBASE}/include -I${LOCALBASE}/include/SDL11 -I${X11BASE}/include
+
+pre-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "You can enable additional compilation optimizations"
+ @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.endif
+.if defined(WITH_GL)
+CONFIGURE_ARGS= --with-gl
+PORT_CFLAGS+= -DSDL_GL
+.else
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You can enable OpenGL support by defining WITH_GL"
+ @${ECHO_MSG}
+.endif
+
+pre-configure:
+ @${PERL} -pi -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lSDL|-lSDL-1.1|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+post-configure:
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${PERL} -pi -e 's|(CFLAGS =).*|\1 ${PORT_CFLAGS} ${CFLAGS}|' ${WRKSRC}/src/Makefile
+.endif
.include <bsd.port.mk>
diff --git a/emulators/gngb/distinfo b/emulators/gngb/distinfo
index 862ccf2b3ad1..cc53269c6fb6 100644
--- a/emulators/gngb/distinfo
+++ b/emulators/gngb/distinfo
@@ -1 +1 @@
-MD5 (gngb_20010318_src.tar.gz) = cd7d0c1cd8852f49ae938f0f8c1ba9a5
+MD5 (gngb-20020111.tar.gz) = 549100377559045cf80d370de6203ba8
diff --git a/emulators/gngb/files/patch-aa b/emulators/gngb/files/patch-aa
deleted file mode 100644
index 20bbca29b48a..000000000000
--- a/emulators/gngb/files/patch-aa
+++ /dev/null
@@ -1,30 +0,0 @@
---- Makefile.orig Sun Apr 22 10:34:08 2001
-+++ Makefile Sun Apr 22 10:39:35 2001
-@@ -15,23 +15,23 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
--GL_MODE = 1
-+#GL_MODE = 1
-
- CC = gcc
- INCDIRS = -I. -I/usr/include
- LIBDIRS = -L/usr/X11R6/lib
- DEBUG = -g
- PROFILE = -pg -O3
--OPT = -O3 -mpentiumpro -Wno-unused -funroll-loops -fstrength-reduce -ffast-math -malign-functions=2 -malign-jumps=2 -malign-loops=2 -fomit-frame-pointer -Wall -g
-+OPT = -O3 -mpentiumpro -Wno-unused -funroll-loops -fstrength-reduce -ffast-math -malign-functions=2 -malign-jumps=2 -malign-loops=2 -fomit-frame-pointer -Wall -g -I/usr/local/include/
- OBJ = memory.o vram.o interrupt.o cpu.o rom.o sound.o serial.o frame_skip.o main.o
- DOBJ = debuger/memory.o debuger/vram.o debuger/interrupt.o debuger/cpu.o debuger/rom.o debuger/sound.o debuger/serial.o debuger/frame_skip.o debuger/log.o debuger/debuger.o
-
- ifdef GL_MODE
- CFLAGS = $(OPT) -D_REENTRANT -DSDL_GL
--LIBS = -lSDL -lpthread -lGL
-+LIBS = -lSDL-1.1 -lpthread -lGL -L/usr/local/lib
- else
- CFLAGS = $(OPT) -D_REENTRANT
--LIBS = -lSDL -lpthread
-+LIBS = -lSDL-1.1 -L/usr/local/lib -lc_r
- endif
-
- all : gngb